xoops forums

Mamba

Moderator
Posted on: 2012/4/5 18:57
Mamba
Mamba (Show more)
Moderator
Posts: 10779
Since: 2004/4/23
#11

Re: Errors and need to upgrade, but...

Quote:
You should then upgrade to either 2.4.5 before you try 2.5.4 or go straight to 2.5.4. Some modules will break under 2.5.4 that work fine with 2.4.5 so that is your choice. The latest version of xoops should be the most secure.

Since he is testing, it's better to go to 2.5.5 RC:

- 2.5.5 is hopefully only couple of week away from Final release
- it will help us with testing so we can make sure that 2.5.5 is working for him
- once tested, it will save him time, because he doesn't have to test 2.5.5 anymore, and doesn't have to install 2.5.4 and then 2.5.5
- 2.5.5 is more secure than 2.5.4
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

kapeman

Just popping in
Posted on: 2012/4/5 19:45
kapeman
kapeman (Show more)
Just popping in
Posts: 87
Since: 2005/5/3 1
#12

Re: Errors and need to upgrade, but...

Good news and bad news!

Good news! I was able to successfully upgrade my site to 2.5.5RC!

Thanks for that!

Now the bad news, there are two modules I need to access:

NewBB and Xoopsgallery.

I have moved the updated files onto my server and run the upgrade process on both of these.

With Xoopsgallery, the script looks like it runs properly, but the version never changes in the module admin and I get the white screen when trying to access it.

With NewBB, I run the update script and then get a blank page. If I manually refresh it loads the admin page, but the module does not update its version.

Any ideas?


EDIT: also almost everything I click on gives me a white screen: e.g. trying to edit a user.

Mamba

Moderator
Posted on: 2012/4/5 20:00
Mamba
Mamba (Show more)
Moderator
Posts: 10779
Since: 2004/4/23
#13

Re: Errors and need to upgrade, but...

For NewBB you can try the new version 4.3 Beta. There are still some few small bugs, but overall it's pretty stable.

Regarding XoopsGallery, you might have a problem, as this is a pretty old module, that might have problems with newer PHP versions. Which XoopsGallery version do you have, and what PHP version are you running?

I don't know how many pictures/albums you have there, but it might be better to consider to convert to something different, like the extGallery module.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

kapeman

Just popping in
Posted on: 2012/4/5 20:05
kapeman
kapeman (Show more)
Just popping in
Posts: 87
Since: 2005/5/3 1
#14

Re: Errors and need to upgrade, but...

PHP Version:
5.3.10



Quote:

Mamba wrote:
For NewBB you can try the new version 4.3 Beta. There are still some few small bugs, but overall it's pretty stable.

Regarding XoopsGallery, you might have a problem, as this is a pretty old module, that might have problems with newer PHP versions. Which XoopsGallery version do you have, and what PHP version are you running?

I don't know how many pictures/albums you have there, but it might be better to consider to convert to something different, like the extGallery module.



Xoopsgallery version 1337, I didn't realize when I re-installed it that it was still old.

I may just have to manually pull off the pictures.


EDIT: Thanks that fixed my forum module.

I guess I am out of luck concerning my gallery module.

Oh well. I am better off than I was...

redheadedrod

Home away from home
Posted on: 2012/4/5 21:04
redheadedrod
redheadedrod (Show more)
Home away from home
Posts: 1296
Since: 2008/2/26
#15

Re: Errors and need to upgrade, but...

With the gallery module you should be able to move the pictures over reasonably easily if the databases have similar structures.

Your best bet here is to disable the bad module, install the new gallery module you want to use and see if there is an import script for it. If there is not one you could do the conversion yourself mostly through phpmyadmin if you can figure out the difference between the databases.

extGallery appears to be the best current solution.



Rodney
Attending College working towards Bachelors in Software Engineering and Network Security.