1
tayling
You dont have permission - again
  • 2012/3/27 5:15

  • tayling

  • Just popping in

  • Posts: 86

  • Since: 2002/1/3 7


Hi
I have upgraded a critical user site today to 2.5.4 all went well. BUT after logging in - successfully - I can get to the main system admin screen but on select any item - or any other installed module - I get the message - you do not have permission ...... and returned to the user login screen

I have deleted xoop_session table records and checed files - have cleared cache and templates_c folder.

I am now stuck for options and would appreciate any help or direction as a matter of urgency

Kind regards

Tony Ayling
Brisbane
Australia

2
Mamba
Re: You dont have permission - again
  • 2012/3/27 5:36

  • Mamba

  • Moderator

  • Posts: 11254

  • Since: 2004/4/23


From which XOOPS version did you upgrade from?

And did you run the "upgrade" script, and updated the System module?
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

3
tayling
Re: You dont have permission - again
  • 2012/3/27 7:37

  • tayling

  • Just popping in

  • Posts: 86

  • Since: 2002/1/3 7


Hi Mamba - thanks for checking in.

I had the problem on a stable 2.13 version that just happened yesterday. I read all the comments and tried them. I thought if I upgraded it would fix the issue and did and UPDATE to 2.3 and then 2.3 to 2.54 - both went well - I remeoved the files and folders as per doco.

The site looks ok and occasionally using IE9 I can log in - get logged out but on logging in again i can access all the backend - but that is intermittent.

Strangely - I was going to sytematically remove some modules but I cannot remove them 0 when I deactivate-and Submit - the red decativate appears but in the last submit no modules are deleted. I have not notices any thing else.

Regards

Tony Aylin

4
tayling
Re: You dont have permission - again
  • 2012/3/27 8:22

  • tayling

  • Just popping in

  • Posts: 86

  • Since: 2002/1/3 7


Just noticed that if I get into system (occasionally) I can access preferences but any changes are NOT saved.

All was ok yesterday - I beleive all I did was create a bcakup in cpanel

Cheers

Tony

5
redheadedrod
Re: You dont have permission - again

I am creating a tutorial here... Make sure you have followed all the steps... It is incomplete right now because I have to get to work but should let you know if you started out right atleast.


https://xoops.org/modules/newbb/viewto ... id=345225#forumpost345225
Attending College working towards Bachelors in Software Engineering and Network Security.

6
Anonymous
Re: You dont have permission - again
  • 2012/3/30 8:49

  • Anonymous

  • Posts: 0

  • Since:


Did you check group settings for webmasters, are you sure you have all system and module administration rights?

7
Mamba
Re: You dont have permission - again
  • 2012/3/30 10:12

  • Mamba

  • Moderator

  • Posts: 11254

  • Since: 2004/4/23


It might be a problem with

1) write permits for /cache or other directories

2) some old modules being incompatbile

3) with Protector not being in sync with its files (there are two directories:
a) in /modules
b) in /xoops_lib/modules
c) but there could be an old protector files in an old XOOPS_TRUST_PATH directory

I would run a file check to make sure that you have all the required files.

Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

Login

Who's Online

68 user(s) are online (38 user(s) are browsing Support Forums)


Members: 0


Guests: 68


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits