xoops forums

verdult

Just popping in
Posted on: 2010/6/30 15:25
verdult
verdult (Show more)
Just popping in
Posts: 32
Since: 2008/11/29
#1

Big size mysql session

my total mysql database is 77.7 MB and the sessions table is over 62,8 MB.

The sess_date is filled with protector_last_ip|s"xx.xxx.xx.xxx." Can I empty the sessions table? and how is it possible that this table is so big.

Peekay

XOOPS is my life!
Posted on: 2010/6/30 16:11
Peekay
Peekay (Show more)
XOOPS is my life!
Posts: 2335
Since: 2004/11/20
#2

Re: Big size mysql session

Xoops version?

Protector version?
A thread is for life. Not just for Christmas.

Catzwolf

Home away from home
Posted on: 2010/6/30 17:03
Catzwolf
Catzwolf (Show more)
Home away from home
Posts: 1392
Since: 2007/9/30
#3

Re: Big size mysql session

Yes you can empty the session table, there shouldn't be any problems doing so.

Peekay

XOOPS is my life!
Posted on: 2010/6/30 17:56
Peekay
Peekay (Show more)
XOOPS is my life!
Posts: 2335
Since: 2004/11/20
#4

Re: Big size mysql session

Thx Catzwolf. However, I would be interested to know if this is a possible problem with Xoops or Protector.

That kind of issue could freeze up a site if the host's DB size limit is exceeded.
A thread is for life. Not just for Christmas.

Catzwolf

Home away from home
Posted on: 2010/6/30 18:43
Catzwolf
Catzwolf (Show more)
Home away from home
Posts: 1392
Since: 2007/9/30
#5

Re: Big size mysql session

Xoops should clear out old sessions when the time has expired, so I would point to this being an Xoops bug/issue. But, without having a proper look at this I couldn't be 100% positive that protector might not deal with its own sessions somewhere.

I will do some testing over the next few days and let you know one way or another.

ATB

John

ghia

Community Support Member
Posted on: 2010/6/30 19:02
ghia
ghia (Show more)
Community Support Member
Posts: 4954
Since: 2008/7/3 1
#6

Re: Big size mysql session

I think one reason can be an extended session time setting in the preferences for custom sessions.
Standard is 15 minutes, 1 hour should be a maximum.

Protector saves some high visibility data in the session variables, which then shows up in the data field of the table, but AFAIK does not create sessions.

verdult

Just popping in
Posted on: 2010/7/1 16:34
verdult
verdult (Show more)
Just popping in
Posts: 32
Since: 2008/11/29
#7

Re: Big size mysql session

this is some info

XOOPS Version XOOPS 2.4.4
PHP Version 5.2.13
mySQL Version 5.1.44-log
Server API apache2handler
OS Linux
safe_mode Off
register_globals Off
magic_quotes_gpc On
allow_url_fopen On
fsockopen On
allow_call_time_pass_reference On
post_max_size 8M
max_input_time 60
output_buffering
max_execution_time 30
memory_limit 128M
file_uploads On
upload_max_filesize 8M


and protector version = 3.4


I cleared out the sessions table