xoops forums

weeramon

Just popping in
Posted on: 2010/5/29 22:57
weeramon
weeramon (Show more)
Just popping in
Posts: 42
Since: 2009/12/13
#1

AdsLight on xoops 2.0.16

When trying to install the adslight module on 2.0.16 I am receiving the following message

Installing adslight

Column length too big for column 'cat_keywords' (max = 255); use BLOB or TEXT instead



any idea what this could mean, and is it fixable, hope this is the only issue for the module with 2.0.16 or has anyone tested the module

webmystar

Friend of XOOPS
Posted on: 2010/5/30 9:20
webmystar
webmystar (Show more)
Friend of XOOPS
Posts: 415
Since: 2008/6/23
#2

Re: AdsLight on xoops 2.0.16

https://xoops.org/modules/repository/singlefile.php?cid=9&lid=1899

System Requirements:

* 2.3.x
* 2.4.x

Peekay

XOOPS is my life!
Posted on: 2010/5/30 11:36
Peekay
Peekay (Show more)
XOOPS is my life!
Posts: 2335
Since: 2004/11/20
#3

Re: AdsLight on xoops 2.0.16

@weeramon

I still have a number of 2.0.16 sites operational because they use older modules, but for new modules, you're going to need Xoops 2.3 or 2.4.

There's nothing wrong with 2.0.16, but newer modules tend to use functions that are not present in that version of Xoops.

The same applies trying to run old modules on 2.4. More often than not, they simply won't work.
A thread is for life. Not just for Christmas.

Mamba

Moderator
Posted on: 2010/5/30 14:25
Mamba
Mamba (Show more)
Moderator
Posts: 10770
Since: 2004/4/23
#4

Re: AdsLight on xoops 2.0.16

Quote:
There's nothing wrong with 2.0.16,

Older versions tend to be less secure, so it's always good to updated to the newest stable version.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

Peekay

XOOPS is my life!
Posted on: 2010/5/30 19:05
Peekay
Peekay (Show more)
XOOPS is my life!
Posts: 2335
Since: 2004/11/20
#5

Re: AdsLight on xoops 2.0.16

I agree that keeping up to date is desirable mamba, but if you need a module and the latest Xoops breaks it, you have little choice but to stay with the older Xoops and hope an upgrade becomes available. At least Xoops track record in respect to security makes this possible.

I'll stick my neck out and say, that as far as I know, there are no inherent security issues with Xoops 2.0.16. Or Xoops 2.0.18 for that matter.

But if there are, please let us know!

A thread is for life. Not just for Christmas.

Mamba

Moderator
Posted on: 2010/5/31 11:22
Mamba
Mamba (Show more)
Moderator
Posts: 10770
Since: 2004/4/23
#6

Re: AdsLight on xoops 2.0.16

There is not only the issue with the XOOPS version itself, even if we had 2.0.18.1 release as security release.

With some of the older versions you're forced to use older versions of PHP, which might have their own vulnerabilities as they are not maintained anymore.

Plus the older modules might be less secure as well.

So for those reasons I tend to update my XOOPS versions
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

Peekay

XOOPS is my life!
Posted on: 2010/5/31 12:25
Peekay
Peekay (Show more)
XOOPS is my life!
Posts: 2335
Since: 2004/11/20
#7

Re: AdsLight on xoops 2.0.16

Well, if the core dev team could release a list of depracated objects and methods, along with their updated replacements, users might be able search through module code and make it compatible. I am sure that sometimes it may be a simple enough fix for anyone who is PHP savvy.

In fact, that would be really useful if anyone wanted to upgrade a older module under the 'Move to Blue' initiative.

We would need a list of things to look for. Does that information already exist somewhere?

@weeramon

Sounds like the installer is trying to write a default value to the database that exceeds the MySQL data type. The default character set in Xoops 2.0.16 is ISO-88951 and this module may be writing multi-byte strings in UTF-8.
A thread is for life. Not just for Christmas.

weeramon

Just popping in
Posted on: 2010/5/31 16:04
weeramon
weeramon (Show more)
Just popping in
Posts: 42
Since: 2009/12/13
#8

Re: AdsLight on xoops 2.0.16

Guys,

thanks for your input and in fact I am in discussion with Mamba about MX Directory on the current core version.

Once this is solved I will move to 2.4.4 with adslight and other modules I installed on 2.0,.16.

Generally most modules I am having on this version can be replaced with newer versions (compatible with 2.4.4 )

So I will opt for the upgrade or better new installation.
(Another reason for me is the already included protector module, which is a pain to install on the older versions )

However in my opinion the developers should separate modules
in the repository.

f.ex.
a) Modules for older versions
b)Modules for current version
c) Modules installed on current version of xoops.org

I mentioned in an earlier post that newcomers need a safe house in the beginning and if they break things later on with incompatible modules then no one can blame xoops because it was clearly seen that these modules are only for older versions.


Remark: I also would like to suggest since I have spent quite some time to evaluate Wordpress and how things are done with regard to modules ( they call it plugins )

Well if someone tries to install an incompatible module the user
gets a message in the admin panel.

Like: this plugin has not been tested with your version of wordpress, if you would like to continue then it is your ......................................................................

Unfortunately I am not a programmer but I believe this feature would definitely enhance the reputation of xoops .

Currently and it has always been, the module via core issue
is still a mXXX. Sorry but I cannot tell it in a more diplomatic way.

I strongly believe that you all do your best but a few warnings for the user especially at the introduction of the repository would save you as team and us as users/contributors a lot of hassle and time. you would have to spend less time for supporting these module issues.

INSTEAD of the

Welcome to the Official XOOPS Module Repository! in RED

there should be a few other commments in RED.

As I mentioned earlier I read at leat 2000 posts. but the average guy who would like to use a CMS ( xoops ) does not have that time and wants "JUST USE IT"

like open the door of a car and turn the key.

We all know it is not that easy.

But it could come close.

if there is a core with most used modules in the installer package.

These days most hosting companies anyway use the Auto-Installer.

THE PAST IS THE PAST AND CURRENT MEMBERS START TO KNOW ABOUT THE PROBLEMS I MENTIONED AND TRY TO SOLVE IT VIA TRYING ON THEIR OWN OR SEEKING SUPPORT.
THE LESS PERSISTENT ONES ALREADY HAVE GIVEN UP AND USE MOST PROBABLY NOW ANOTHER SYSTEM.

THE FUTURE AND FUTURE LESS PERSISTENT USERS SHOULD NOT BE CONFRONTED WITH THESE ISSUES ANYMORE SO THEY WILL BE HAPPY TO "just use it "

an entry message on the home page if this core with certain modules are once released should be.

Dear New Friends of Xoops,

once you have successfully setup (installed) your Xoops CMS platform please start to get accustomed with the process of
configuring the cores system and modules contained within Xoops.

We strongly advice to refrain installing other modules before you have not made at least one module work the way you want it.

This will not only save us all a lot of time in explaining and supporting you but give us precious time to improve, simplify and optimize the product of your choice.


P.S. with regard to wording some food for thought.

WP uses plugin and widgets

X uses modules and blocks.

my op it should be plugins and blocks

(Let us not forget that we should have a system which is also for non - native speakers - like me, you might have realized that on my upper construction of the suggested entry message )

So widget, no thank you
modules ?????

I know technically all these terms are correct.

Again things cannot be done from today until tomorrow and a little change on a website is definitely always a big issue.
THAT WAS JUST A SUGGESTION.