xoops forums

chocofrodo

Just popping in
Posted on: 2010/3/23 12:20
chocofrodo
chocofrodo (Show more)
Just popping in
Posts: 7
Since: 2010/2/23
#1

Automatic log out after correct log in

Hello everybody,

I'm using and configuring a web in XOOPS 2.4.4 and I have the next problem:

When I access to XOOPS in my job, I can log in, but if I press any link in the menu, automatically it appears a windows that shows that I have no permissions to access to the web and I have to log in again, how could I fix that?

In my job the internet conexion is through a proxy.

If I access at home, all runs perfectly and it doesn't log out. Could anyone help me to solve this?

kris_fr

Theme Designer
Posted on: 2010/3/23 14:10
kris_fr
kris_fr (Show more)
Theme Designer
Posts: 1009
Since: 2005/12/31
#2

Re: Automatic log out after correct log in

hi,

Do this test --> http://tutos.xoofoo.org/browser_check/

@+

chocofrodo

Just popping in
Posted on: 2010/3/23 20:45
chocofrodo
chocofrodo (Show more)
Just popping in
Posts: 7
Since: 2010/2/23
#3

Re: Automatic log out after correct log in

Hi Kris,

Thanks for your answer, I've just done this test at home with Firefox and it showed PASS in all the entries. I'll try with the test tomorrow in the job.

See you tomorrow

mboyden

Moderator
Posted on: 2010/3/24 3:29
mboyden
mboyden (Show more)
Moderator
Posts: 484
Since: 2005/3/9 1
#4

Re: Automatic log out after correct log in

I don't know if this is your particular issue, but one similar behavior I've run across generally happens with a site user on their laptop. The are logged in but then change physical locations such that their IP address changes. With Protector module, it prevents this. Thus, when you login, it says you logged in successfully, but since you likely have Protector to not let you switch IPs as an administrator you, it then doesn't actually log you in. You have to logout before XOOPS will allow you to login again but since it doesn't recognize you as logged in, there are no links to logout. So, try ROOTURL/user.php?op=logout and then try to login and see if that works for you. Using a proxy server such that XOOPS recognizes an IP address change can trigger the same behavior.

Mazar

Not too shy to talk
Posted on: 2010/3/24 11:27
Mazar
Mazar (Show more)
Not too shy to talk
Posts: 191
Since: 2009/1/4 0
#5

Re: Automatic log out after correct log in

if you have access to phpmyadmin then clear the session table it should sort out the problem. it seems the session table is full

chocofrodo

Just popping in
Posted on: 2010/3/25 16:35
chocofrodo
chocofrodo (Show more)
Just popping in
Posts: 7
Since: 2010/2/23
#6

Re: Automatic log out after correct log in

Hello everybody, thank you for all your answers and time.

I've just read your answers, and it was useful. @Mazar, the table was empty, but I cleared it anyway. The problem still was there.

@Mboyden, yeah, trying ROOTURL/user.php?op=logout allowed me to log out, and log in again later and work on it (that was another problem I had), but after a while the problem was again there...

@kris_fr, the test of Firefox at my job showed PASS in all the entries.

Anyway, looking up a bit more in google, I read that changing the value of var $enableRegenerateId from false to true in the line 65 of the file kernel/session.php all would work fine again, so I did it and it looks that everything is working OK at my job. The question is: Could someone explain why?