1
hal9008
Captcha doesn't work in some servers (Image mode)
  • 2010/3/10 14:29

  • hal9008

  • Just popping in

  • Posts: 8

  • Since: 2008/3/25


Hello.

I have a big trouble with the captcha image that comes with XOOPS 2.4.4. I have updated my web build in XOOPS 2.0.18. In that version i have installed the module "security image" and everything works fine in my hosting. When I do the update, I see that captcha is in the core of XOOPS 2.4.4 (I think that is based in that module). I updated my web in local and everything works fine, but when I have uploaded the web to my hosting, the captcha didn't works. If I configure captcha in text mode it works, but in graphic mode I can see the captcha image only sometimes. Most times i've tried, I can't see the captcha. But sometimes the captcha is seen. I don't understand why. In local I see the captcha fine.

In local I have this configuration.

XOOPS 2.4.4
PHP 5.2.11
mySQL 5.1.37
Server API: apache2handler
OS Darwin (MAC OS)
safe_mode Off
register_globals Off
magic_quotes_gpc On
allow_url_fopen On
fsockopen On
post_max_size 32M
max_input_time 60
output_buffering
max_execution_time 30
memory_limit 32M
file_uploads On
upload_max_filesize 32M
'safe_mode': off
'file_uploads': on
'register_globals': off
'upload_max_filesize': 32M byte
'post_max_size': 32M byte
'open_basedir': nothing

This is the configuration of the server:
debian 5.0.4 (lenny)
Apache 2.2.9
PHP 5.2.6-1+lenny6
mySQL 5.0.51a-24+lenny3-log
ServerAPI apache2handler
safe_mode Off
register_globals Off
magic_quotes_gpc On
allow_url_fopen On
fsockopen On
post_max_size 11M
max_input_time 90
output_buffering
max_execution_time 60
memory_limit 128M
file_uploads On
upload_max_filesize 11M

The master of my hosting, says that the problem is not in the script execution. It may be in the execution and the check of initial syntax. The problems comes by "XoopsCaptchaImageHandled".

It seems a XOOPS bug. ¿Is anybody working on that? ¿can anybody help me with this trouble?

Thanks.

2
deka87
Re: Captcha doesn't work in some servers (Image mode)
  • 2010/3/10 15:39

  • deka87

  • Friend of XOOPS

  • Posts: 1124

  • Since: 2007/10/5


You can try to replace it with reCaptcha. Works perfectly for me.

3
frankblack
Re: Captcha doesn't work in some servers (Image mode)
  • 2010/3/10 15:48

  • frankblack

  • Just can't stay away

  • Posts: 830

  • Since: 2005/6/13


Or follow this thread, although this is not a solution for your problem.

Maybe the GD library version differ from local and web.

4
hal9008
Re: Captcha doesn't work in some servers (Image mode)
  • 2010/3/10 16:07

  • hal9008

  • Just popping in

  • Posts: 8

  • Since: 2008/3/25


I forgot to say:

When captcha is not shown, script takes 100% of one server's processor until it
(I suppose) timeouts.

If I put some "echo" at the beginning or at the end of the php script, message
is not shown until script timeouts, so problem must be on some previous task
(syntax comprobation, resource allocation, etc)

I will try all that you say and then I will tell you the results.

Login

Username:
Password:

Lost Password? Register now!

Who's Online

63 user(s) are online (35 user(s) are browsing Support Forums)


Members: 0


Guests: 63


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jun 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits