xoops forums

showcase17

Not too shy to talk
Posted on: 2009/9/14 11:57
showcase17
showcase17 (Show more)
Not too shy to talk
Posts: 190
Since: 2005/1/6 0
#1

extgallery not showing publicly

I'm using extgallery but it's just showing to members, not to visitors. All settings are correct...
Both version 1.0.7 and 1.0.8 have this problem.

Solution anyone?

DarinAllan

Friend of XOOPS
Posted on: 2009/9/15 12:58
DarinAllan
DarinAllan (Show more)
Friend of XOOPS
Posts: 477
Since: 2005/5/18
#2

Re: extgallery not showing publicly

I know you say all settings are correct, but have you rechecked permissions in the module >>> Permissions and also in Admin >>> System >>> Groups, have you created at least one Album and placed an image in it?

:o)

showcase17

Not too shy to talk
Posted on: 2009/9/15 15:21
showcase17
showcase17 (Show more)
Not too shy to talk
Posts: 190
Since: 2005/1/6 0
#3

Re: extgallery not showing publicly

Yes Darin all settings are correct, there's 15 albums (all have images); module permissions set to allow Anonymous Users "Can access" and "Display this album" (same settings as registered users) and they have "Module Access rights" in the group.

Maybe there's a way to override this check in the code? Remove/change some code?

DarinAllan

Friend of XOOPS
Posted on: 2009/9/15 16:13
DarinAllan
DarinAllan (Show more)
Friend of XOOPS
Posts: 477
Since: 2005/5/18
#4

Re: extgallery not showing publicly

This does not help you but similar maybe?

https://xoops.org/modules/newbb/viewto ... id=314656#forumpost314656

Note from Chefry's last post:

Quote:
And it only happens in a public category if the parent category has more than 5 subdirectories

showcase17

Not too shy to talk
Posted on: 2009/9/15 20:41
showcase17
showcase17 (Show more)
Not too shy to talk
Posts: 190
Since: 2005/1/6 0
#5

Re: extgallery not showing publicly

Thanks Darin, no it didn't really help. :)

But I found a solution... for every excisting album I made a number 2 album, moved all the images in the original album to the number 2 and now it's fine. Still no clue what caused this problem, but things are working now.