1
biglove
Custom Blocks not displaying blockContent
  • 2009/5/8 19:19

  • biglove

  • Not too shy to talk

  • Posts: 157

  • Since: 2004/8/18


I just upgraded from XOOPS 2.0.7 to 2.3.3, the upgrade we relatively simple.

I'm confused about what is going on with my Custom Blocks.
When I look at the Blocks administration, I can see my custom blocks listed.
If I click on "Edit" I can see the original custom content of the blocks is there in the database.

The blocks don't seem to be showing up on the Top Page or anywhere else.

When I look at the page source:
<div style="padding: 5px;">
<fieldset>

<legend class="blockTitle">is Test Block displaying content?</legend>
<div class="blockContent"></div>
</fieldset>
</div>
The content within the blockContent is just not being displayed.
However, the blockTitle is visible.

I checked at the block are visible to all users.

Can someone please tell me what I'm doing wrong?
Learn about http://www.instantdirectmarketing.com and stay ahead of your competition and crush them with the science of marketing.

2
trabis
Re: Custom Blocks not displaying blockContent
  • 2009/5/8 20:52

  • trabis

  • Core Developer

  • Posts: 2269

  • Since: 2006/9/1 1


I think you need to upload XOOPS 2.3 files again. It seems that some file was not correctly replaced.

3
biglove
Re: Custom Blocks not displaying blockContent
  • 2009/5/15 15:03

  • biglove

  • Not too shy to talk

  • Posts: 157

  • Since: 2004/8/18


The checksum only shows that it's missing a theme/ and install/ which I deleted after I had already run the upgrade.

It must not be displaying in the div class="blockContent"


I'm still missing the block.content field for my custom blocks.
I checke the database as the content is there.
It seems that only the custom blocks are not displaying block.content.

I uploaded checksum and it seems the only files missing are:
install/
/themes/default
/themes/zetagenesis

The install/ should not be required because I was upgrading from XOOPS 2.0.7
The missing themes should also be irrelevant.
What else could be preventing block.content from displaying in the template?

I'm going to post a record from xoops_newblocks but predator banned me for 3 days last time when I tried this on Monday.
Learn about http://www.instantdirectmarketing.com and stay ahead of your competition and crush them with the science of marketing.

4
biglove
Re: Custom Blocks not displaying blockContent
  • 2009/5/15 15:04

  • biglove

  • Not too shy to talk

  • Posts: 157

  • Since: 2004/8/18


xoops_newblocks
bid = 13
mid = 0
func_num = 0
options = null
name = has content
title = has content
content = has html code for block inside
side = 5
visible = 1
block_type = c
isactive = 1
dirname = null
func_file = null
show_func = null
edit_func = null
template = null

It looks like there should be a value for those last 5 fields.
Learn about http://www.instantdirectmarketing.com and stay ahead of your competition and crush them with the science of marketing.

5
biglove
Re: Custom Blocks not displaying blockContent
  • 2009/5/18 14:15

  • biglove

  • Not too shy to talk

  • Posts: 157

  • Since: 2004/8/18


I'm still confused why the Custom Blocks are not being displayed.

It would seem that I need to modify some of the fields in Custom Block database records.

Which fields need to be changed and what should the be changed too?
Learn about http://www.instantdirectmarketing.com and stay ahead of your competition and crush them with the science of marketing.

6
biglove
Re: Custom Blocks not displaying blockContent
  • 2009/5/19 12:28

  • biglove

  • Not too shy to talk

  • Posts: 157

  • Since: 2004/8/18


I still don't have any idea why the Custom Block is not displaying blockContent is not being displayed.

show_func = null
Does this function need to be defined in the database?
If so, what should the function be?
Learn about http://www.instantdirectmarketing.com and stay ahead of your competition and crush them with the science of marketing.

7
zzzzsg
Re: Custom Blocks not displaying blockContent
  • 2009/5/19 16:17

  • zzzzsg

  • Just popping in

  • Posts: 86

  • Since: 2005/12/22


I had the same problem.

Resolved it by manually re-creating the custom blocks. Not so difficult as you can cut and paste from the old site (if you have the old site running somewhere else). Or you can copy and save the contents of the custom blocks to text files first before doing the upgrade.

8
biglove
Re: Custom Blocks not displaying blockContent
  • 2009/5/19 17:52

  • biglove

  • Not too shy to talk

  • Posts: 157

  • Since: 2004/8/18


I have tried to recreate the Custom Blocks and it has made no difference.

The database records are still being saved without these fields set:
dirname = null
func_file = null
show_func = null
edit_func = null
template = null

Hopefully someone understands how the Custom Blocks work and can point me in the right direction.
Learn about http://www.instantdirectmarketing.com and stay ahead of your competition and crush them with the science of marketing.

9
iHackCode
Re: Custom Blocks not displaying blockContent

those dont need to be set for custom blocks. what other fields are in the _newblocks table. c_type?
CBB / LatestNews / Publisher / XM-Spotlight

(ノ◕ヮ◕)ノ*:・゚✧

10
biglove
Re: Custom Blocks not displaying blockContent
  • 2009/5/19 19:40

  • biglove

  • Not too shy to talk

  • Posts: 157

  • Since: 2004/8/18


c_type = H
Learn about http://www.instantdirectmarketing.com and stay ahead of your competition and crush them with the science of marketing.

Login

Who's Online

83 user(s) are online (44 user(s) are browsing Support Forums)


Members: 0


Guests: 83


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits