71
wunderdog
Re: Database problem
  • 2006/4/22 23:22

  • wunderdog

  • Just popping in

  • Posts: 7

  • Since: 2006/4/22


Actualy I want to have forum like this on my page...is it possible and how?

72
rasiemse
Re: Database problem
  • 2006/5/13 16:23

  • rasiemse

  • Just popping in

  • Posts: 1

  • Since: 2006/5/13


Apache2.0.58 PHP5.1.4 MySQL WinXP
------------------------------------------------
I went around and around trying to resolve why PHP works properly with Apache, mySQL works fine and can create accounts and databases using MySQL Administrator and Query Browser but PHP wouldnt connect properly to mySQL. Finally, going to MySQL website, it was noted to use the MySQL dll's from them that they packaged in php_5.1.4_mysql_4.1.19-win32 which has the latest in libmysql.dll and php_mysql.dll. These files are to be put into the C:\php directory (or where ever you put them) , Apache httpd.conf needs to have the following entries:

PHPIniDir "C:/php"
LoadModule php5_module "c:/php/php5apache2.dll"
AddType application/x-httpd-php .php

The PATH to PHPIniDir has to be put up front before the Loadmodules in the httpd.conf. Next. THIS IS THE MOST IMPORTANT THING TO DO!!:
You Must Put The PATH of the c:\php in the Windows environment path by appending it to the end as explained here:

http://us2.php.net/manual/en/faq.inst ... aq.installation.addtopath

And REBOOT Machine! And not simply log out. I suspect most ISP's do not know to add to the windows PATH so they figure since php works except for mySQL that something is wrong with php or MySQL and dont want to tackle the problem. So, if you are not serving your own MySQL and PHP, tell them to put the PHP directory in their Windows Path and Reboot Server. Good Luck!

73
saima01
Re: Database problem
  • 2006/6/1 7:32

  • saima01

  • Just popping in

  • Posts: 22

  • Since: 2005/8/11


hi...

i m new to XOOPS and trying to install XOOPS 2.0.13 on my system running php 5, MySQL 4.1, apache 2, Windows XP. While proceeding with the installation steps, i get a blank screen after page 7 where it says Confirm Database Settings. i m providing the follwoing details here:
Database Hostname: localhost
Database Username: root
Database Name: XOOPS (already created in mysql)
Table Prefix: XOOPS


I've read numerous faqs on this site to get it resolved but to no avail. I even have re-installed apache, MySQL and php but tht doesn't helped even. Can anyone help me out?

74
ikkubus999
Re: Database problem
  • 2006/6/21 6:41

  • ikkubus999

  • Just popping in

  • Posts: 7

  • Since: 2006/6/21


hi,

ive setup LAMP in fedora core 3.. during XOOPS installation process to be exact after "confirm database settings" the installation wizard didnt check if the database exist. instead it redirect me to /xoops/index.html

index.html is a blank page

did i miss something during LAMP configuration?
thanks.

75
ShadowedKobr
Re: Database problem

Ignore my post I think I might have figured out what my problem is.

76
htphuoc
Re: Database problem
  • 2006/9/6 2:23

  • htphuoc

  • Just popping in

  • Posts: 1

  • Since: 2006/9/6 2


I have the same problem with you. Did you solved the problem?

77
riahi66
Re: Database problem
  • 2006/10/12 20:46

  • riahi66

  • Just popping in

  • Posts: 1

  • Since: 2006/10/12


hi.
You have mentioned".......and pointing to the right place." what do u mean by that. does that mean that XOOOPS and MYPHP have to be on the same folder or...?
Thank you

78
Sikandar
Re: Database problem
  • 2008/9/24 3:45

  • Sikandar

  • Just popping in

  • Posts: 99

  • Since: 2005/5/19


Hi,
In the latest version 2.3 can I provide IP instead of hostname of database server Database,

Hostname whatever your MySQL hostname is

as with IP it is not working.

Thanks

79
deepak267
Re: Database problem
  • 2008/11/23 20:51

  • deepak267

  • Quite a regular

  • Posts: 352

  • Since: 2008/8/15


I spent almost an afternoon to fix this on XOOPS 2.3.1 with PHP5 and MySQL 5.0 and the fix was to include
1. extension=php_mysqli.dll in php.ini
2. SET PASSWORD FOR 'user'@'localhost' = OLD_PASSWORD('password');

though it is still not working for user = root

Good luck

80
tsanba
Re: Database problem
  • 2009/3/19 8:01

  • tsanba

  • Just popping in

  • Posts: 3

  • Since: 2009/3/19


Hello!
I trying to install XOOPS 2.3.3
but have this error.
Fatal error: Class 'XoopsDatabaseFactory' not found in /var/www/xoops/install/class/dbmanager.php on line 47

OS: ubuntu 8.10
Server API: apache2handler Apache/2.2.9 (Ubuntu) PHP/5.2.6-2ubuntu4.1 with Suhosin-Patch
PHP: 5.2.6-2ubuntu4.1
MySQL: 5.0.67
Session extension: Success
PCRE extension: Success
file_uploads: ON

[Moderator's Note: Please ignore this post as it is a triple post. Replies to this topic please. tsanba, posting the same question in 3 place will not help you get an answer. It will distribute and fragment attention/advice. Please do not triple post: Sailjapan]

Login

Who's Online

34 user(s) are online (22 user(s) are browsing Support Forums)


Members: 0


Guests: 34


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Sep 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits