xoops forums

Mamba

Moderator
Posted on: 2009/3/15 9:57
Mamba
Mamba (Show more)
Moderator
Posts: 10810
Since: 2004/4/23
#1

XOOPS 2.3.3 Final Issues

Please post and discuss in this forum all issues related to XOOPS 2.3.3 Final

1) Language files

2) Full Local Installation

Please help us with more translations!!!
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

bjuti

Just can't stay away
Posted on: 2009/3/15 12:33
bjuti
bjuti (Show more)
Just can't stay away
Posts: 871
Since: 2009/1/7 2
#2

Re: XOOPS 2.3.3 Final Issues

What about manual update from 2.3.2b to 2.3.3, without update/ script.

Is enough just to copy files over the old ones and update system, pm, profile and protector module?

Tnx :)

jdseymour

Friend of XOOPS
Posted on: 2009/3/15 13:13
jdseymour
jdseymour (Show more)
Friend of XOOPS
Posts: 3782
Since: 2004/11/11
#3

Re: XOOPS 2.3.3 Final Issues

I see that the instructions even for 2.3.2b_to_2.3.3 ask to run the upgrade script. This usually means that database changes are needed. So no, just copying files and updating mods will not work. But not being in the dev, I may be wrong.

And I may well be. When I ran the script saw no changes. But even so, it is in the instructions so would not skip to be on the safe side, unless a dev can confirm.

jdseymour

Friend of XOOPS
Posted on: 2009/3/15 15:11
jdseymour
jdseymour (Show more)
Friend of XOOPS
Posts: 3782
Since: 2004/11/11
#4

Re: XOOPS 2.3.3 Final Issues

I seem to have come up with a couple of problems.

1. in the forum kioivi does not show preview (only title), but all other editors do. All I get in debug are the following warnings:

Warning: fopen(/xxx/xxxx/xxxx/warpigw2.com/xoops_lib/modules/protector/configs/configcachedd8af6) [function.fopen]: failed to open stream: Permission denied in file /xxxx/xxx/xxxx/warpigw2.com/xoops_lib/modules/protector/class/protector.php line 136
Warning: fwrite(): supplied argument is not a valid stream resource in file /xxx/xxxx/xxxx/warpigw2.com/xoops_lib/modules/protector/class/protector.php line 137
Warning: fclose(): supplied argument is not a valid stream resource in file /xxx/xxxx/xxxx/warpigw2.com/xoops_lib/modules/protector/class/protector.php line 138
Warning: MyTextSanitizer::makeTareaData4Show is deprecated in file /class/module.textsanitizer.php line 699
Warning: MyTextSanitizer::makeTareaData4Show is deprecated in file /class/module.textsanitizer.php line 699

The mytextsanitizer one repeats over 100 times.

2. My AMS spotlight block no longer shows. Again warnings:

Warning: Smarty error: unable to read resource: "db:ams_block_spotlight_center.html" in file /class/smarty/Smarty.class.php line 1092
Notice: Deprecated function 'mod_getUnameFromIds', use XoopsUserUtility directly. in file /Frameworks/art/functions.user.php line 26

Using the latest AMS module.

Thanks

Catzwolf

Home away from home
Posted on: 2009/3/15 15:16
Catzwolf
Catzwolf (Show more)
Home away from home
Posts: 1392
Since: 2007/9/30
#5

Re: XOOPS 2.3.3 Final Issues

/xxx/xxxx/xxxx/warpigw2.com/xoops_lib/modules/protector/configs/configcachedd8af6

Make sure that this folder exists and is writeable

Items within the php Error log like Warning: MyTextSanitizer::makeTareaData4Show is deprecated, just ignore.

These warning are to let developers know that they are no longer used and shouldn't be, but it seems that these lines are just confusing users more.

jdseymour

Friend of XOOPS
Posted on: 2009/3/15 15:29
jdseymour
jdseymour (Show more)
Friend of XOOPS
Posts: 3782
Since: 2004/11/11
#6

Re: XOOPS 2.3.3 Final Issues

Thanks Catz,

The directory was not there. I created it, first tried 775 (writable by my server) did not work. Then tried it at chmod 777, still have the same warning.

bjuti

Just can't stay away
Posted on: 2009/3/15 17:26
bjuti
bjuti (Show more)
Just can't stay away
Posts: 871
Since: 2009/1/7 2
#7

Re: XOOPS 2.3.3 Final Issues

My site cannot update!

First i closed my site
Then I copied the files
Then I put upgrade folder in docroot
I've started the www.mysite.com/upgrade

It reports that I have no package 2.17 -> 2.18 but it continue
Then the message was: "No upgrade necessary. Please remove this folder from your server"

After that I've go to system/modules to update system module, and there is no button!

It says press the button to upgrade, but there is no button

When I wanted to go to system/preferences to turn on debbuger i got a blank page!

Please help

p.s. It's 2.3.2b version

Catzwolf

Home away from home
Posted on: 2009/3/15 17:47
Catzwolf
Catzwolf (Show more)
Home away from home
Posts: 1392
Since: 2007/9/30
#8

Re: XOOPS 2.3.3 Final Issues

@bjuti,

Upload 2.3.3, and try the upgrade, let us know if this doesn't work.

Ps: Did you create a backup of your database before you updated to 2.3.2?

Catzwolf

Home away from home
Posted on: 2009/3/15 17:50
Catzwolf
Catzwolf (Show more)
Home away from home
Posts: 1392
Since: 2007/9/30
#9

Re: XOOPS 2.3.3 Final Issues

1. I will have a look at the protector issue for you, hopefully the code will through some light on the issue.

2. Just update your AMS module and look to see if the template actually exists in the package.

bjuti

Just can't stay away
Posted on: 2009/3/15 18:00
bjuti
bjuti (Show more)
Just can't stay away
Posts: 871
Since: 2009/1/7 2
#10

Re: XOOPS 2.3.3 Final Issues

Yup I try to upgrade from 2.3.2b to 2.3.3

I've create a backup... I copied all files manually, so 232 files have xxx.php~232 extension. Also I have zip file of whole site.

I could give you ftp usr and pass via pm if you wanna look?

Tnx