1
Mazarin
Blank admin.php on 2.3.2b - no errors - tried all the FAQ fixes
  • 2008/12/23 8:19

  • Mazarin

  • Just can't stay away

  • Posts: 533

  • Since: 2008/12/10


Yesterday I ran into the problem of the admin.php just returning a blank page. I turned on error logging, but no error messages. I run 2.3.2b and had just done the following when the problem occurred:

I had some problems with the language files in the piCal module corrupting things, so I decided to uninstall the module. I changed from my local language (Swedish) to English and uninstalled the module, which went fine. After uninstalling successfully, I once again went into the system preferences, changed my default language to Swedish and klicked "Go".

Now the language on the main page has changed, but I cannot access the admin.php page. As stated above, the only thing I did was change language back to english, uninstall piCal, and change it back to Swedish, which did work with admin.php before. I touched no other files than the piCal language files, which have now been removed.

This is driving me crazy. I stayed up half the night trying to fix it with all possible fixes, but to no avail. Anyone have any suggestion? As you can probably understand, I'd rather not make a clean install of my site. Also, I would like to understand what caused the problem so I can avoid it in future.

Any help is greatly appreciated.

2
anderssk
Re: Blank admin.php on 2.3.2b - no errors - tried all the FAQ fixes
  • 2008/12/23 8:30

  • anderssk

  • Quite a regular

  • Posts: 335

  • Since: 2006/3/21


Hi'
There is an error in the swedish language filer for the piCal module.

Is there any spaces after the "p" in;
<?php


Ore after the
?>

in the buttom of the files.

If it's not that, I will be happy to help You.
If You upload the language-file to ww.xoopsnordic.org we can use this forum

We will post in here when the error is found.

3
mrphilong
Re: Blank admin.php on 2.3.2b - no errors - tried all the FAQ fixes
  • 2008/12/23 9:41

  • mrphilong

  • Quite a regular

  • Posts: 351

  • Since: 2006/7/14


Check your mainfile.php make sure you have the following:

define( 'XOOPS_ROOT_PATH', '..........' );
define( 'XOOPS_PATH', '........../XoopsTrustPath' );
define( 'XOOPS_VAR_PATH', '........../xoops_data' );
define("XOOPS_TRUST_PATH", XOOPS_PATH);

4
anderssk
Re: Blank admin.php on 2.3.2b - no errors - tried all the FAQ fixes
  • 2008/12/23 9:56

  • anderssk

  • Quite a regular

  • Posts: 335

  • Since: 2006/3/21


If it is the mainfile, why dos it work when he uninstall the pical module and change language to english....

5
Mazarin
Re: Blank admin.php on 2.3.2b - no errors - tried all the FAQ fixes
  • 2008/12/23 11:51

  • Mazarin

  • Just can't stay away

  • Posts: 533

  • Since: 2008/12/10


It's all there in the mainfile, and I haven't touched that so I don't see how it could have changed it.

Also, yes, the language file for piCal wasn't the greatest, that's why I was working on changing it - both changing certain translations and adding the use of htmlentities for Scandinavian characters to display correctly.

However, it doesn't seem to me that any of these things should cause what I'm experiencing now as I a) checked mainfile and b) have uninstalled piCal. Also, the site has been up and running for some time before this happened, and I had no problems with it before this.

6
anderssk
Re: Blank admin.php on 2.3.2b - no errors - tried all the FAQ fixes
  • 2008/12/23 12:40

  • anderssk

  • Quite a regular

  • Posts: 335

  • Since: 2006/3/21


somewere in Your language-files something is missing

define('ABC','A'BC');
define('
DEF','DEF')
efine('
GHI','GHI');


is not the same as

define('ABC','ABC');
define('DEF','DEF');
define('GHI','GHI');


Trust me

7
Mazarin
Re: Blank admin.php on 2.3.2b - no errors - tried all the FAQ fixes
  • 2008/12/23 12:56

  • Mazarin

  • Just can't stay away

  • Posts: 533

  • Since: 2008/12/10


Agreed that that was the problem with piCal. However, I haven't even touched the general XOOPS translation files. Just to be sure, I reinstalled the Swedish translation of Xoops, but still the same.

Update: I went into the db and changed the language back to English, which made things work again. So it seems that the language files actually are the problem here. I'll continue to try and find the needle in the haystack that's causing this.

8
anderssk
Re: Blank admin.php on 2.3.2b - no errors - tried all the FAQ fixes
  • 2008/12/23 13:03

  • anderssk

  • Quite a regular

  • Posts: 335

  • Since: 2006/3/21


Is it still a problem with the core swedish translations (without pical) or is only when pical is installed

9
Mazarin
Re: Blank admin.php on 2.3.2b - no errors - tried all the FAQ fixes
  • 2008/12/23 13:19

  • Mazarin

  • Just can't stay away

  • Posts: 533

  • Since: 2008/12/10


Solved. It actually turned out to be the language file of a completely different module, which I had uploaded by accident and which had a ) missing in a line.

Sorry for taking your time with this stupid mistake, but I guess I learned even module language files can have far reaching consequences. Anyway, thanks for your help.

10
anderssk
Re: Blank admin.php on 2.3.2b - no errors - tried all the FAQ fixes
  • 2008/12/23 13:44

  • anderssk

  • Quite a regular

  • Posts: 335

  • Since: 2006/3/21


It's OK

Good You found the missing )

I really hate when it happens.

Looking foreward to see you at www.xoopsnordic.org

Login

Who's Online

56 user(s) are online (26 user(s) are browsing Support Forums)


Members: 0


Guests: 56


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits