1
piar
TinyMCE - tables problem
  • 2008/11/3 11:54

  • piar

  • Just popping in

  • Posts: 22

  • Since: 2008/10/30


I have problem with tables in TinyMCE editor in every modules which which I've tested. I can not change width of table - it always stay as wide as is the editor window.

There is a possibility to change width of table in TinyMCE and it works correct in example from TinyMCE site:http://tinymce.moxiecode.com/examples/full.php
But in XOOPS it does not work

I tried to configure TinyMCE exactly like in that example from tiny site by changing file: class/xoopseditor/tinymce/settings.php but it still does not work as I want to.

What should I do to allow useres to set width of table as they want in TinyMCE in XOOPS?

Regards

2
ghia
Re: TinyMCE - tables problem
  • 2008/11/3 12:53

  • ghia

  • Community Support Member

  • Posts: 4953

  • Since: 2008/7/3 1


There is probably a style in your CSS file that overrules it. Try to fill in the class with an unique name.

Can it be seen somewhere?

3
piar
Re: TinyMCE - tables problem
  • 2008/11/3 13:47

  • piar

  • Just popping in

  • Posts: 22

  • Since: 2008/10/30


Thank you for reply to my post.
In my original project I have modyfied CSS, but to show the problem I set it up on testing server with default configuration of XOOPS:http://piar.net23.net/xoops/modules/news/submit.php
After clickig there on 'inserts a new table' you will see the problem. Whatever you will put in Width field or when you will try to change width of table in WYSIWYG mode table is always full window wide (despite changes in html code are done).

4
ghia
Re: TinyMCE - tables problem
  • 2008/11/3 14:48

  • ghia

  • Community Support Member

  • Posts: 4953

  • Since: 2008/7/3 1


Your style.css and xoops.css have both the
table {
width:100%;
}
rule.

So, you have to put
width50%;
in your style field (advanced tab), but your configuration for tinyMCE hasn't this allowed. You have to add the rule.
Other style elements are working eg. color.

5
piar
Re: TinyMCE - tables problem
  • 2008/11/3 15:09

  • piar

  • Just popping in

  • Posts: 22

  • Since: 2008/10/30


Thank you for helping me!

I just removed 'width:100%' property of table from xoops.css and now it works as it should (I can set width using TinyMCE). I do know if this won't cause some problems with another tables of XOOPS (ie. main layout). If it will then I will search what shall I change in TinyMCE configuration to allow setting width in style field.

Login

Who's Online

63 user(s) are online (33 user(s) are browsing Support Forums)


Members: 0


Guests: 63


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Nov 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits