xoops forums

MarkReaves

Just popping in
Posted on: 2008/10/27 6:44
MarkReaves
MarkReaves (Show more)
Just popping in
Posts: 11
Since: 2008/10/27
#1

Changing choosing avatars doesn't work

I developed the latest (2.3.1) XOOPS locally with LAMPP and then transfered it over to a hosted server. I made sure the mainfile was edited to suit the new server and doublechecked everything I could think of. Locally choosing and changing avatars works while on the host it does not.

Could someone help me solve this issue?

The website in question is:
http://unitedchurchofloveandunderstanding.org/

I would HIGHLY appreciate any and all help provided, thank you.

MarkReaves

Just popping in
Posted on: 2008/11/1 0:34
MarkReaves
MarkReaves (Show more)
Just popping in
Posts: 11
Since: 2008/10/27
#2

Re: Changing choosing avatars doesn't work

Anyone?

Mamba

Moderator
Posted on: 2008/11/1 2:18
Mamba
Mamba (Show more)
Moderator
Posts: 10959
Since: 2004/4/23
#3

Re: Changing choosing avatars doesn't work

It seems to me that you haven't activate the Profile module on your Host.

When I click on your name's link, I'm getting:

http://unitedchurchofloveandunderstanding.org/userinfo.php?uid=1

However, when I do the same on our XOOPS site, I'm getting:

https://xoops.org/modules/profile/userinfo.php?uid=73545

I think, you should be able to view the avatar w/o having to install the Extended Profile, so I'll log it as a bug. But before I do it, can you tell me if you have installed the Profile on your LAMP site?
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

MarkReaves

Just popping in
Posted on: 2008/11/1 2:52
MarkReaves
MarkReaves (Show more)
Just popping in
Posts: 11
Since: 2008/10/27
#4

Re: Changing choosing avatars doesn't work

I just installed the user profile module and tried again to change the avatar.. still doesn't work.

Same symptoms.

Mamba

Moderator
Posted on: 2008/11/1 3:32
Mamba
Mamba (Show more)
Moderator
Posts: 10959
Since: 2004/4/23
#5

Re: Changing choosing avatars doesn't work

Can you try to change the theme - to default and to Zetagenesis, and see if this changes anything?
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

MarkReaves

Just popping in
Posted on: 2008/11/1 4:16
MarkReaves
MarkReaves (Show more)
Just popping in
Posts: 11
Since: 2008/10/27
#6

Re: Changing choosing avatars doesn't work

Changing the theme to the default didn't fix the issue so I changed the theme back to the one I was using.

Same symptoms when using the default them.

On a side note, I had to change the admin backend theme to legacy after I first transfered it to the host because it didn't show the menu.

Mamba

Moderator
Posted on: 2008/11/1 6:07
Mamba
Mamba (Show more)
Moderator
Posts: 10959
Since: 2004/4/23
#7

Re: Changing choosing avatars doesn't work

Do you have the same versions of PHP/MySQL on both systems? Which one is on your Host?
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

MarkReaves

Just popping in
Posted on: 2008/11/1 7:36
MarkReaves
MarkReaves (Show more)
Just popping in
Posts: 11
Since: 2008/10/27
#8

Re: Changing choosing avatars doesn't work

The host is using the latest XAMPP on Windows. I developed the site on Linux with the latest LAMPP. Both were latest as of the transfer of the site from my pc to the host.

His XAMPP has similar setup to the LAMPP I used except secured for production use.

Mamba

Moderator
Posted on: 2008/11/1 8:39
Mamba
Mamba (Show more)
Moderator
Posts: 10959
Since: 2004/4/23
#9

Re: Changing choosing avatars doesn't work

I really don't have an answer at the moment, as I cannot reproduce these errors.

Did you turn on the debugger? If yes, any error messages?
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

MarkReaves

Just popping in
Posted on: 2008/11/1 8:55
MarkReaves
MarkReaves (Show more)
Just popping in
Posts: 11
Since: 2008/10/27
#10

Re: Changing choosing avatars doesn't work

on the
/modules/profile/userinfo.php?uid=1
Get these errors:
Quote:
Notice: Only variable references should be returned by reference in file /modules/smartfaq/include/functions.php line 588
Warning: MyTextSanitizer::makeTboxData4Show is deprecated in file /class/module.textsanitizer.php line 619
Warning: MyTextSanitizer::makeTboxData4Show is deprecated in file /class/module.textsanitizer.php line 619
Warning: MyTextSanitizer::makeTboxData4Show is deprecated in file /class/module.textsanitizer.php line 619
Warning: MyTextSanitizer::makeTboxData4Show is deprecated in file /class/module.textsanitizer.php line 619
Warning: MyTextSanitizer::makeTboxData4Show is deprecated in file /class/module.textsanitizer.php line 619
Warning: Cache Engine file is not initialized in file /class/cache/xoopscache.php line 180
Warning: Cache Engine file is not set in file /class/cache/xoopscache.php line 138
Warning: Cache Engine file is not initialized in file /class/cache/xoopscache.php line 180
Warning: Cache Engine file is not set in file /class/cache/xoopscache.php line 138
Notice: Only variable references should be returned by reference in file /modules/smartfaq/include/functions.php line 588
Notice: Only variable references should be returned by reference in file /modules/smartpartner/include/functions.php line 163
Notice: Only variable references should be returned by reference in file /modules/smartpartner/include/functions.php line 163


On the avatar page of the profile I get:
Quote:
Notice: Only variable references should be returned by reference in file /modules/smartfaq/include/functions.php line 588
Warning: MyTextSanitizer::makeTboxData4Show is deprecated in file /class/module.textsanitizer.php line 619
Warning: MyTextSanitizer::makeTboxData4Show is deprecated in file /class/module.textsanitizer.php line 619
Warning: MyTextSanitizer::makeTboxData4Show is deprecated in file /class/module.textsanitizer.php line 619
Warning: MyTextSanitizer::makeTboxData4Show is deprecated in file /class/module.textsanitizer.php line 619
Warning: MyTextSanitizer::makeTboxData4Show is deprecated in file /class/module.textsanitizer.php line 619


After choosing a new avatar and after it takes me back to the avatar page, the errors shown are now:
Quote:
Notice: Only variable references should be returned by reference in file /modules/smartfaq/include/functions.php line 588
Warning: MyTextSanitizer::makeTboxData4Show is deprecated in file /class/module.textsanitizer.php line 619
Warning: MyTextSanitizer::makeTboxData4Show is deprecated in file /class/module.textsanitizer.php line 619
Warning: MyTextSanitizer::makeTboxData4Show is deprecated in file /class/module.textsanitizer.php line 619
Warning: MyTextSanitizer::makeTboxData4Show is deprecated in file /class/module.textsanitizer.php line 619
Warning: MyTextSanitizer::makeTboxData4Show is deprecated in file /class/module.textsanitizer.php line 619
Warning: Cache Engine file is not initialized in file /class/cache/xoopscache.php line 180
Warning: Cache Engine file is not set in file /class/cache/xoopscache.php line 138
Warning: Cache Engine file is not initialized in file /class/cache/xoopscache.php line 180
Warning: Cache Engine file is not set in file /class/cache/xoopscache.php line 138
Notice: Only variable references should be returned by reference in file /modules/smartfaq/include/functions.php line 588
Notice: Only variable references should be returned by reference in file /modules/smartpartner/include/functions.php line 163
Notice: Only variable references should be returned by reference in file /modules/smartpartner/include/functions.php line 163