• 2008/9/28 4:18

  • trina

  • Just popping in

  • Posts: 34

  • Since: 2006/6/28

Okay I want to turn off register_globals due to the protector module letting me know it's not a good thing to have that on..
'register_globals' : on Not secure
This setting invites a variety of injecting attacks.
If you can put .htaccess, edit or create...

But when I edit the .htaccess then I get an internal error for the whole site.

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

How do I then turn off register globals but keep my site up?

Re: Register_globals
  • 2008/9/28 17:54

  • ghia

  • Community Support Member

  • Posts: 4953

  • Since: 2008/7/3 1

When you get an 500 error after editing the .htaccess, this means usually that some instructions in it are wrong or have a bad format.
What did you add?

Re: Register_globals
  • 2008/10/3 15:00

  • hrac

  • Quite a regular

  • Posts: 305

  • Since: 2002/7/15

I got same problem:

I created a new .htaccess file and it has only 1 line:

php_flag register_globals off

Than I get 500 error

Re: Register_globals
  • 2008/10/6 13:51

  • ghia

  • Community Support Member

  • Posts: 4953

  • Since: 2008/7/3 1

Maybe with:
php_flag register_globals off
Order allow
Allow from all

Another possibility is that your hoster disabled .htacces .
Open a ticket for that case or switch to a better hoster.

Re: Register_globals
  • 2008/10/6 16:43

  • yeppers

  • Just popping in

  • Posts: 27

  • Since: 2008/9/15

or PHP is running in CGI mode. in which case you can't use php flags in .htaccess you have to create a php.ini file instead.

this is discussed many times on this site if you search


Who's Online

171 user(s) are online (46 user(s) are browsing Support Forums)

Members: 0

Guests: 171



Goal: $100.00
Due Date: Dec 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits