1
kevcar
Upgrading from PHP4 to PHP5
  • 2008/7/14 12:11

  • kevcar

  • Not too shy to talk

  • Posts: 127

  • Since: 2007/6/2 1


Hi,

I am looking to update my server from PHP4 to PHP5 will this affect my Modules on my site at present,or will it site which is 2.0.18 ?

2
Anonymous
Re: Upgrading from PHP4 to PHP5
  • 2008/7/14 12:42

  • Anonymous

  • Posts: 0

  • Since:


xoops 2.0.18 will not itself be affected by the change.

If you list the modules you use (inc version numbers) then I'm sure you will be inundated with replies

3
kevcar
Re: Upgrading from PHP4 to PHP5
  • 2008/7/14 15:28

  • kevcar

  • Not too shy to talk

  • Posts: 127

  • Since: 2007/6/2 1


-----Module Installed-------

Forum CBB version 1.16
ExtCal version 2.2
Polls version 1
PD Downloads version 1.2
Content version 0.52
Contact Us version 1
Template Cash Cleaner version 1
Smart Media version 0.85
Filemanager version 3
ExtGallery version 1.04
Member List version 1
Web Links version 0.93
x-Movie version 2.65
Smart Section version 2.13
Shout Box version 4
Liaise version 1.27
SmartObject version 0.92
My Quiz version 3
Video Tube version 1.5
Alumni version 2.3

4
Anonymous
Re: Upgrading from PHP4 to PHP5
  • 2008/7/14 18:31

  • Anonymous

  • Posts: 0

  • Since:


Okay, I'll start the ball rolling

Forum CBB version 1.16
I don't know but would recommend upgrading to CBB3.08 together with Frameworks 1.22 and xoopseditors 1.21, all from xoopsforge.com - and yes, you can upgrade without losing any Forums/Posts

ExtCal version 2.2
Definitely works

Polls version 1
If this is xoopspoll 1 then yep, should be okay. I use v1.1 and can let you have it if you'd like to upgrade.

ExtGallery version 1.04
This is the latest version and yes, it is fine on php5.

Smart Section version 2.13
I use this on php5 without a problem, but I will be upgrading to 2.14 (needs SmartObject 1.0.1 as well to work).

Liaise version 1.27
I use v1.26 and that's fine, so this will be too.

SmartObject version 0.92
See above (re SmartSection)


Cant comment on the rest of the modules, but if they are the latest then they should be fine. PHP5 has been about for quite a while now.

5
kevcar
Re: Upgrading from PHP4 to PHP5
  • 2008/7/14 19:05

  • kevcar

  • Not too shy to talk

  • Posts: 127

  • Since: 2007/6/2 1


Thanks with the help with my question on PHP5

Thanks I take up the offer of the Polls version 1.1

6
ladysham
Re: Upgrading from PHP4 to PHP5
  • 2008/8/14 4:42

  • ladysham

  • Quite a regular

  • Posts: 274

  • Since: 2003/11/11


I have moved my site to a new server that gives me the option of running PHP4 OR PHP5. I have a site that is XOOPS 2.0.18.1 RC.

I have my site running with PHP4. However, when I change it to PHP5, I get an internal server error.

Anyone have any ideas on why this would happen? I know that it's because of the server, but where would I start them looking?

Thanks!
Kelly Ling
Shamrock's Web Design
http://www.shamrocksweb.com

If you're coming to see my house - give me two weeks. If you're coming to see ME - come any time!

7
ladysham
Re: Upgrading from PHP4 to PHP5
  • 2008/8/14 4:56

  • ladysham

  • Quite a regular

  • Posts: 274

  • Since: 2003/11/11


NEVERMIND! Found out some of the problem. Thanks!
Kelly Ling
Shamrock's Web Design
http://www.shamrocksweb.com

If you're coming to see my house - give me two weeks. If you're coming to see ME - come any time!

Login

Who's Online

75 user(s) are online (41 user(s) are browsing Support Forums)


Members: 0


Guests: 75


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits