xoops forums

danyblue

Just popping in
Posted on: 2008/5/30 8:39
danyblue
danyblue (Show more)
Just popping in
Posts: 48
Since: 2002/4/15
#1

Xoops 2.3 and previous version modules

Hello all,

I have recently installed the new version of xoops, 2.3.0 in order to try it, and the installation went like a charm.
Aftewards I have uploaded the modules that I need to try with CM4F application (that integrates mailinglists and forums) newBB and news.
When I go to the module administration the modules uploaded are not showing in the administration interface. I have checked If the upload process was correct, the right locations, etc... ( i am working with XOOPS for 6 years now) but every seems to be correct.

Is there any trick that is not documented to have the modules installed?

Regards,

D.

Mamba

Moderator
Posted on: 2008/5/30 11:21
Mamba
Mamba (Show more)
Moderator
Posts: 10988
Since: 2004/4/23
#2

Re: Xoops 2.3 and previous version modules

You have to make sure that the new XOOPS directories

/xoops_data
/xoops_lib

and the directories under them are all set to 777

At least that's what once happened to me.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

danyblue

Just popping in
Posted on: 2008/5/30 13:21
danyblue
danyblue (Show more)
Just popping in
Posts: 48
Since: 2002/4/15
#3

Re: Xoops 2.3 and previous version modules

Thank you for you feeback Mamba, but it seems that it doesn´t work for me. I have even tried to copy the modules to the xoops_lib folder, but it doesn´t work either.

Regards,
D.

Mamba

Moderator
Posted on: 2008/5/30 18:20
Mamba
Mamba (Show more)
Moderator
Posts: 10988
Since: 2004/4/23
#4

Re: Xoops 2.3 and previous version modules

What PHP/MySQL version are you using?
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

danyblue

Just popping in
Posted on: 2008/5/30 19:00
danyblue
danyblue (Show more)
Just popping in
Posts: 48
Since: 2002/4/15
#5

Re: Xoops 2.3 and previous version modules

This what the admin.php reports

XOOPS Version - XOOPS 2.3.0
PHP Version - 5.2.5
MySQL Version - 5.0.45-community-log
Server API Version - apache
OS Version - Linux

safe_mode - Off
register_globals - On
magic_quotes_gpc - On
allow_url_fopen - On
fsockopen - On
allow_call_time_pass_reference - On
post_max_size - 8M
max_input_time - 60
output_buffering -
max_execution_time - 30
memory_limit - 64M
file_uploads - On
upload_max_filesize - 2M

Mamba

Moderator
Posted on: 2008/5/31 13:15
Mamba
Mamba (Show more)
Moderator
Posts: 10988
Since: 2004/4/23
#6

Re: Xoops 2.3 and previous version modules

I was hoping, it would be PHP4x, as some users reported some issues there. I had some problems on PHP5.25, but after I made sure that all the xoops_data and xoops_lib directories were set to 777, the issues went away. Could you try to reinstall it, but during the installation make sure that the directories are indeed set to 777.

Remember, this is still "alpha" release, so not everything will work as intended, and we need all the feedback from test users.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

kolsch

Just popping in
Posted on: 2008/5/31 15:20
kolsch
kolsch (Show more)
Just popping in
Posts: 4
Since: 2002/11/10
#7

Re: Xoops 2.3 and previous version modules

Possibly the module administration page was stuck by one of your existing modules, so the following modules are not able to show up.

If you can't figure out which the module is, just try to move each module which is not appear in the module administration page out of the modules folder separately. Then you should find it in the end.

I don't know why the problem occurred, but that's how I solve it with XOOPS 2.3.0 & 2.3.1.

danyblue

Just popping in
Posted on: 2008/6/1 16:28
danyblue
danyblue (Show more)
Just popping in
Posts: 48
Since: 2002/4/15
#8

Re: Xoops 2.3 and previous version modules

It worked.

It was the NewBB module that was blocking the listing of modules.

I will try other versions of the newbb. I was using the last released version. So I will try to install it again, and then if failing, previous versions.

Regards,
D.

wishcraft

Module Developer
Posted on: 2008/6/1 17:00
wishcraft
wishcraft (Show more)
Module Developer
Posts: 3711
Since: 2007/5/18
#9

Re: Xoops 2.3 and previous version modules

So far with most of the complex modules, I have found the backward engineering phppp has done to be exemplary he is a smooth coder.. I have had CBB 3.08 working fine, myalbum-p, wf-link most of the smartfactory stuff and so on working fine with it.

Resized Image
www.ohloh.net/accounts/226400

Follow, Like & Read:-

twitter.com/SimonXaies
github.com/Chronolabs-Cooperative
facebook.com/SimonSXaies

danyblue

Just popping in
Posted on: 2008/6/1 18:50
danyblue
danyblue (Show more)
Just popping in
Posts: 48
Since: 2002/4/15
#10

Re: Xoops 2.3 and previous version modules

I have install again newbb/cbb and now it seems to work. I think that I have missed the addons packages to the newbb package, xoopseditor and framework.

I think that if a module is not being recognized, it should not block the overall other modules to appear, but instead to display a message error no?

Thanks all for the help.

Regards,
D.