xoops forums

chefry

Home away from home
Posted on: 2007/11/11 21:32
chefry
chefry (Show more)
Home away from home
Posts: 1005
Since: 2006/10/14
#1

php5/mysql5

Is my version of XOOPS compatible with php5/mysql5?

My host is doing the upgrade throughout the month.

Here's my system info

Website URL:
http://franksrecipes.com

XOOPS Version:
XOOPS 2.0.16

XOOPS Theme:
7Xred

XOOPS Template Set:
wraps

PHP Version:
4.4.7

MySQL Version:
4.1.22-standard

Server Software:
Apache

User's Browser:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9

Northern

Just can't stay away
Posted on: 2007/11/11 22:35
Northern
Northern (Show more)
Just can't stay away
Posts: 420
Since: 2004/12/26
#2

Re: php5/mysql5

Xoops its self will work with php 4 or 5 and sql 4 or 5
but thats not the probelm. its with in the modules
not all modules are php5 safe, they will put a stop to the site.
so its a matter of finding the ones that work.
a few of the members have stated a post about what modules work in php 5 but it seemed to never realy took off.


https://xoops.org/modules/newbb/viewto ... id=277350#forumpost277350

Good luck..

Marc

jdseymour

Friend of XOOPS
Posted on: 2007/11/11 23:23
jdseymour
jdseymour (Show more)
Friend of XOOPS
Posts: 3782
Since: 2004/11/11
#3

Re: php5/mysql5

I always use the latest php, MySQL and apache, only had a problem with a couple of modules (been over a year cannot remember which ones). But otherwise, no troubles. Actually better performance. Especially when I upgraded from apache 2.0 to 2.2.

Good luck.

peterr

Just can't stay away
Posted on: 2008/1/4 10:55
peterr
peterr (Show more)
Just can't stay away
Posts: 518
Since: 2004/8/5 9
#4

Re: php5/mysql5

I notice that XOOPS is not on the list of Software projects committed to using PHP 5.2 or greater. | GoPHP5.org
NO to the Microsoft Office format as an ISO standard.
Sign the petition

btesec

Friend of XOOPS
Posted on: 2008/1/4 15:12
btesec
btesec (Show more)
Friend of XOOPS
Posts: 623
Since: 2007/2/20
#5

Re: php5/mysql5

Hi,
I am using
# Apache Web Server Version 2.2.4
# PHP Script Language Version 5.2.1
# MySQL Database Version 5.0.27

and most if not all of the modules that are mantained/updated are functional with the above specs. It would be great to see all modules updated at least once or twice a year. Maybe someone/group with the programming skills can take this slack to update them. I know there are some useful modules(outdated ones i mean) that are not working. Maybe a forum can be started for this where all needed modules can be listed and updated since the current modules devs are not able or have abandoned the projects. What do you all think? It has taken me a while to identify modules that really work properly, I mean almost an year.

my 2 cents here.

BTESEC

chefry

Home away from home
Posted on: 2008/1/26 19:49
chefry
chefry (Show more)
Home away from home
Posts: 1005
Since: 2006/10/14
#6

Re: php5/mysql5

Well... my host changed to php5 and absolutely trashed my site.

THey put me back to an old php4 server that couldn't handle it. They kept suspending my site, saying it was my fault, but couldn't tell me what the fault was. Then closed my account.

The backups they created are absolutely trashed and I've lost 10 years of work

Stay away from TCH for a host

VTRIX

Just popping in
Posted on: 2008/1/26 20:57
VTRIX
VTRIX (Show more)
Just popping in
Posts: 37
Since: 2006/7/7 1
#7

Re: php5/mysql5

My host is using PHP 5 and PHP 4 for ages now... the bad thing is that ALL php5 files must end on .php5, which renders some PHP5 script useless (only one i know except XOOPS is wikimedia)

Is quite annoying too :(

Northern

Just can't stay away
Posted on: 2008/1/27 0:12
Northern
Northern (Show more)
Just can't stay away
Posts: 420
Since: 2004/12/26
#8

Re: php5/mysql5

What?...... who told you that? where did you read this?

you mean to tell me that all my customers in my server's thats running PHP 5.2.5/sql 5.0.45 have to change 100's if not thousands of files from .php to .php5...

thats good......

php4 will work in php5, but a few things need to be altered or corrected if it is to be accessable in php5.

there is no real need to have to end your files in ( .php5 ) to make it work or not...


ok with that done and over with...

Frank,


check your email...
and or give me a call.

Mamba

Moderator
Posted on: 2008/1/27 10:49
Mamba
Mamba (Show more)
Moderator
Posts: 10779
Since: 2004/4/23
#9

Re: php5/mysql5

Northern, some people/hosts when they have both PHP4 and PHP5 installed on the same server, they require/recommend to use a different file extension for PHP5 programs, so they are run directly under PHP5.

See:
http://forums.theplanet.com/index.php?showtopic=58825
http://wordpress.org/support/topic/131514
http://www.modwest.com/help/kb5-321.html

Here they did the opposite, renaming PHP4 files to .php4:
http://www.debianhelp.co.uk/apachephp.htm

He might need to change the host.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

Marco

Home away from home
Posted on: 2008/1/27 13:14
Marco
Marco (Show more)
Home away from home
Posts: 1256
Since: 2004/3/15
#10

Re: php5/mysql5

well :
- a serious hosting company should offer the hability to run php4 and php5, with a conf line within an .htaccess file, for example
- php6 is coming (end of first trimester,2008)
Do synergy or die.