1
harlis
Default file permission in XOOPS
  • 2007/10/23 2:27

  • harlis

  • Just popping in

  • Posts: 44

  • Since: 2004/3/24


Dear All,

I just move my XOOPS into another hosting, and I found some problem on it. I think it's related to folder and file permission for XOOPS.

What is the default folder and file permission in XOOPS ?
Here what I have in my XOOPS installation :
../public_html (750)
All folders using (755) except /cache /templates_c and /uploads which is using (777)
All files using (666)

Am I correct with all of that ?
Because not every page I can open, for some pages I found 500 Internal Server Error
Any clue of it ? May be somebody can tell me what is the default file permission of XOOPS

BR//Andy
When you stop learn, you've already dead......

2
jimmyx
Re: Default file permission in XOOPS
  • 2007/10/23 4:34

  • jimmyx

  • Quite a regular

  • Posts: 338

  • Since: 2007/7/18


i've the same problem long time ago...u have to re-set all file permission and do it twice if u could, clear cache, clear templatec

good luck

https://xoops.org/modules/smartfaq/faq.php?faqid=286

3
harlis
Re: Default file permission in XOOPS
  • 2007/10/23 7:16

  • harlis

  • Just popping in

  • Posts: 44

  • Since: 2004/3/24


I got the solution already.

Due to the fact that most Linux Host apache web server runs php as a cgi and has suexec enabled the maximum allowed permissions of your scripts is: 755 ( rwxr-xr-x ).

That's why I got so many problems when accesing my XOOPS. So I do this :
1. Keep all the folders using (755)
2. CHMOD all the files using (644) instead of (666)

Right now, it runs smoothly.
Thanks
When you stop learn, you've already dead......

Login

Who's Online

50 user(s) are online (28 user(s) are browsing Support Forums)


Members: 0


Guests: 50


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits