xoops forums

EtherBunny

Just popping in
Posted on: 2007/10/7 23:39
EtherBunny
EtherBunny (Show more)
Just popping in
Posts: 3
Since: 2007/10/7
#1

XOOPS 2.0.17 SMTP/ATT port 465

I am trying to set up my XOOPS mail for registration and my ISP (ATT) uses SSL for SMTP on port 465, but when I go to the mail settings in XOOPS I cannot get it configured. Does anyone know a work around for this? I would LOVE to get this working soon. It is going to be a family website.

Thanks in advance for your help!
Warren

hervet

Friend of XOOPS
Posted on: 2007/10/8 7:57
hervet
hervet (Show more)
Friend of XOOPS
Posts: 2267
Since: 2003/11/4
#2

Re: XOOPS 2.0.17 SMTP/ATT port 465

Here is what I have made for XOOPS 2.0.16.

find this line :
var $SMTP_PORT 25;


and replace it with :
var $SMTP_PORT 465;


find this line :
$this->smtp_conn fsockopen($host,    # the host of the server


And just before, insert :
$port 465;


And use the smtpAuth option.

EtherBunny

Just popping in
Posted on: 2007/10/9 20:44
EtherBunny
EtherBunny (Show more)
Just popping in
Posts: 3
Since: 2007/10/7
#3

Re: XOOPS 2.0.17 SMTP/ATT port 465

Which form do i need to edit for this?

christian

Just can't stay away
Posted on: 2007/10/9 21:54
christian
christian (Show more)
Just can't stay away
Posts: 401
Since: 2002/2/24
#4

Re: XOOPS 2.0.17 SMTP/ATT port 465

You must edit the file \class\mail\phpmailer\class.smtp.php and find the strings write by Hervet.

After in admin system menu, select mail setup for choose smtpAuth in Mail delivery method.

EtherBunny

Just popping in
Posted on: 2007/10/9 23:34
EtherBunny
EtherBunny (Show more)
Just popping in
Posts: 3
Since: 2007/10/7
#5

Re: XOOPS 2.0.17 SMTP/ATT port 465

I made the changes below. Uploaded the new file via filezilla and I still cannot get this working... I am using 2.0.17. Any other suggestions?

At line 30 i put:
var $SMTP_PORT = 465;






added at line 101:
$port = 465;
$this->smtp_conn = fsockopen($host, # the host of the server
$port, # the port to use
$errno, # error number if any
$errstr, # error message if any
$tval); # give up after ? secs