xoops forums

jimbofoxman

Quite a regular
Posted on: 2007/9/11 0:47
jimbofoxman
jimbofoxman (Show more)
Quite a regular
Posts: 292
Since: 2005/4/1 1
#1

Php5?

Maybe I am missing it, so I apologize in advance.

But, all the sites I run (just a few sites really) all support PHP4 obviously and offer PHP5.

What's the deal with converting XOOPS 2.2.x sites to run on PHP5? Just run the conversion tool the ISP gives me? Or is it more involved on the XOOPS side?

Or if there is a link someone can give, I will go read through it.

Thanks

Jim

sato-san

Quite a regular
Posted on: 2007/9/11 5:18
sato-san
sato-san (Show more)
Quite a regular
Posts: 224
Since: 2005/7/1 1
#2

Re: Php5?

XOOPS loves PHP5

Resized Image

Anonymous

Posted on: 2007/9/11 7:49
Anonymous
Anonymous (Show more)
Posts: 0
Since:
#3

Re: Php5?

I have the option of switching to PHP5 from 4 on my site and am considering doing so.

Does anyone know of any modules that would have "issues" were I to swap?

I'm using:

Protector 3.04
CBB3.08 (with Frameworks 1.10 and xoopseditors)
SmartSection 2.13
WiwiMod 0.8.3
ExtCal 2.0.4
News 1.55
Weather 1.3
iStats2.2
Xoopspoll 1.1
WF-Links 1.03
xyp4all 1.58

Anyone use these with XOOPS 2.0.17 and php5?

TIA

debianus

Not too shy to talk
Posted on: 2007/9/11 14:26
debianus
debianus (Show more)
Not too shy to talk
Posts: 179
Since: 2006/12/17
#4

Re: Php5?

I use without problems on PHP 5.2.3:
Protector 3.04
CBB 3.08 (with Frameworks 1.10 and xoopseditors)
SmartSection 2.13 (2.12: I had problems with the last version)
WiwiMod 0.8.3
News 1.55.

jimbofoxman

Quite a regular
Posted on: 2007/9/11 15:40
jimbofoxman
jimbofoxman (Show more)
Quite a regular
Posts: 292
Since: 2005/4/1 1
#5

Re: Php5?

Is it just a matter of running the utility that my host provides me to convert to PHP5? Or is there something I have to do on the XOOPS side. That's my only question.

brash

Friend of XOOPS
Posted on: 2007/9/11 20:56
brash
brash (Show more)
Friend of XOOPS
Posts: 2206
Since: 2003/4/10
#6

Re: Php5?

It will totally depend on what modules you are running jimbofoxman. Anything recent will be fine, though I have a friend I'm trying to help now with XOOPS who is using several modules which have not been updated since circa 2004 which are not PHP5 compatible. Seems he faces a difficult upgrade path now as he doesn't want to change modules as that will affect search engine rankings and I've so far been unable to find a developer with time to be able to update these modules for him. Only real way of knowing for sure is if PHP5 compatibility is explicitly listed in the module documentation, or by trying out the module in a testing environment using PHP5.
IT Headquarters
Innovative IT Solutions

svaha

Just can't stay away
Posted on: 2007/9/11 22:53
svaha
svaha (Show more)
Just can't stay away
Posts: 896
Since: 2003/8/2 2
#7

Re: Php5?

I use these modules on my testsite with XOOPS 2.016 : http://www.amevita.eu/modules/myCredits/