1
dlemkin
xoops failure on multiple domains after server upgrade
  • 2006/12/25 23:37

  • dlemkin

  • Just popping in

  • Posts: 10

  • Since: 2005/1/27


I had a server upgrade done and now i can not access several of the modules -of many XOOPS installations.

Xoops versions include both the 2.2 and 2.0.x iterations

Just about every module is affected, all showing varients of the same error message. On most sites I was not even able to get to admin to set php debugger, but here is data I did get:
---------------------------
Notice [PHP]: Only variable references should be returned by reference in file include/functions.php line 491

Notice [PHP]: Only variable references should be returned by reference in file kernel/configitem.php line 97

Notice [PHP]: Only variable references should be returned by reference in file kernel/module.php line 368

Notice [PHP]: Only variable references should be returned by reference in file class/module.textsanitizer.php line 259

When loading xoopsgallery module 1.3.3.7 I get more of the same plus:
Fatal error: Cannot re-assign $this in /home/alonso/public_html/x2/modules/xoopsgallery/classes/Album.php on line 412
--------------------------------
Server info
XOOPS Version:XOOPS 2.2.3 Final
XOOPS Theme:flash_test
XOOPS Template Set:default
PHP Version:5.2.0
MySQL Version:5.0.27-standard

Server Software:
Apache/1.3.37 (Unix) mod_gzip/1.3.26.1a mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 mod_ssl/2.8.28 OpenSSL/0.9.7a PHP-CGI/0.1b

User's Browser:Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

additional info
cpanel install
phpsuexec enabled
suexec enabled
php global_variables on
php dynamic libraries disabled

ANY IDEAS OR HELP WOULD BE GREATLY APPRECIATED...

2
dlemkin
Re: xoops failure on multiple domains after server upgrade
  • 2006/12/26 0:10

  • dlemkin

  • Just popping in

  • Posts: 10

  • Since: 2005/1/27


solved it...

I was running PHP 5.2.0

All I did was downgrade to 4.4.4 and it now works again... Is this a known compatibility problem. I found only one mention (another poster asking about php 5 incompatibility, but didn't find the answer anywhere?

3
Rhomal
Re: xoops failure on multiple domains after server upgrade
  • 2006/12/27 19:11

  • Rhomal

  • Quite a regular

  • Posts: 274

  • Since: 2004/10/5


Quote:

dlemkin wrote:
solved it...

I was running PHP 5.2.0

All I did was downgrade to 4.4.4 and it now works again... Is this a known compatibility problem. I found only one mention (another poster asking about php 5 incompatibility, but didn't find the answer anywhere?


The XOOPS 'support' team here runs away whenever you mention windows server or IIS. So sadly we MS people are more or less on our own. I converted (or tried to) from apache2 to IIS6 and after a week+ gave up. I am now back on apache. I have a feeling XOOPS is much less 'platform independent' then claimed. As getting it to run on IIS required what seemed like inhuman feats to not only get the core running but modules as well which MANY seemed to fail under IIS/php5 but worked fine on apache/php4.

If you'd like to poll our knowledge together perhaps we can work out the issues we both have together? Nice to have someone use MS here as well. :)

4
davidl2
Re: xoops failure on multiple domains after server upgrade
  • 2006/12/27 19:27

  • davidl2

  • XOOPS is my life!

  • Posts: 4843

  • Since: 2003/5/26


Possibly as we can't give support on something we don't use.

However if other users have experience with the combination, it would be good to get response from them.

Login

Who's Online

97 user(s) are online (42 user(s) are browsing Support Forums)


Members: 0


Guests: 97


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits