1
mpowell
Problems with user registration
  • 2006/9/6 4:14

  • mpowell

  • Friend of XOOPS

  • Posts: 119

  • Since: 2004/2/10


I have a couple of issues I need help with.

1. When my members register their number of posts numbers starts with -4. I have had this problem for sometime but just now have the time to tackle the issue. For some reason all my post numbers reset sometime ago (I think I mentioned that here somewhere) and since then I have had this problem. I can't find the place in the database to change this starting number to 0.

2. Recently when members register they are not assigned to the registered users group. They can sign in but can't go anywhere because they have no privileges.

I have over 1200 members and use XOOPS 2.2.3 with auto registration.

2
mpowell
Re: Problems with user registration
  • 2006/9/6 14:15

  • mpowell

  • Friend of XOOPS

  • Posts: 119

  • Since: 2004/2/10


bump. Anyone please.

3
Dave_L
Re: Problems with user registration
  • 2006/9/6 14:48

  • Dave_L

  • XOOPS is my life!

  • Posts: 2277

  • Since: 2003/11/7


1. The number of posts is in the column user_profile.posts.

2. I don't know why you would suddenly start having that problem.

"auto registration" - Do you mean that "Select activation type of newly registered users" is set to "Activate automatically"?

4
mpowell
Re: Problems with user registration
  • 2006/9/8 14:35

  • mpowell

  • Friend of XOOPS

  • Posts: 119

  • Since: 2004/2/10


Yes the system is set to "Activate automatically"? For almost three weeks now my system has not updated new users to the system as registered users. I can manually add them to the register users list if the contact me, but other than that they don't show up in users search list less than x days or show up in the new members block, etc. I am very much concerned about this issue.

In looking at MySQL I observe the following:

uid - after 1359 the numbers become random.
uid - the last member to successfully register with no problem was uid 1352.

up to 1352 the uid in users and the profileid in user_profile match. As I said before the numbers in uid become random but in profileid they remain in sequence.

As to posts numbers here is what I have.

field=posts, type=int(10), collation=blank, attributes=blank, null=no, default=0, extra=blank.

Although default is set to 0 there are many members who had a negative number in number of posts - as low as -78.

Any help would be appreciated as I am way over my head here.

5
mpowell
Re: Problems with user registration
  • 2006/9/8 22:03

  • mpowell

  • Friend of XOOPS

  • Posts: 119

  • Since: 2004/2/10


My web provider clearly lays the blame on xoops. Any ideas anyone?

6
allnewtome
Re: Problems with user registration
  • 2006/9/8 22:13

  • allnewtome

  • Not too shy to talk

  • Posts: 175

  • Since: 2005/11/30


1. Do a search and you'll find many many posts about this, but probably no answer.

2. In the admin site if you muck something up, when it goes back to the input screen, no user group is selected at all (you have to choose it manually). Perhaps on the user side the same thing happens. This is from memory as I'm on 2.0.15 now!

7
mpowell
Re: Problems with user registration
  • 2006/9/8 22:18

  • mpowell

  • Friend of XOOPS

  • Posts: 119

  • Since: 2004/2/10


But I have been using 2.2.3 for sometime with no problem. It just started out of the blue. Do you mean the only solution is to downgrade?

8
allnewtome
Re: Problems with user registration
  • 2006/9/8 22:25

  • allnewtome

  • Not too shy to talk

  • Posts: 175

  • Since: 2005/11/30


Quote:

mpowell wrote:
But I have been using 2.2.3 for sometime with no problem. It just started out of the blue. Do you mean the only solution is to downgrade?


I'm not an expert by any means. I spent ages fixing little problems in my 2.2.3 installation - which made me reluctant to upgrade to 2.2.4 in case I introduced more and undid my fixes.

Problems with user registration and post count (and join date) were fairly common on this forum the last few months. It's a problem I had but got no solution to. My problem sounds a bit different to yours though. To be fair, if there aren't that many users it's easy to change with sql.

2.0.15 is more of an upgrade than a downgrade... When we installed 2.2.3 we thought the higher number meant better, but apparently not

9
mpowell
Re: Problems with user registration
  • 2006/9/17 3:46

  • mpowell

  • Friend of XOOPS

  • Posts: 119

  • Since: 2004/2/10


I think I have been able to fix this problem. I found several errors by using phpmyadmin that I repaired and things seem to be working now and new members can register. I still have no solution to the -1 number problem but it is not a new problem with new members joining but I had a buch join before I tackled this issue. I am sure there must be some kind of a MySQL query to update the posts for each user but I don't know what it is.

Login

Username:
Password:

Lost Password? Register now!

Who's Online

55 user(s) are online (29 user(s) are browsing Support Forums)


Members: 0


Guests: 55


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jun 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits