51
javelin
Re: CSS100 [Holy Grail CSS Wireframe Theme]
  • 2006/9/11 13:09

  • javelin

  • Not too shy to talk

  • Posts: 160

  • Since: 2004/3/11


Nope - can't get that to work.

tried 50px just to test but no joy.

for some reason the margin tag has no effect but the padding does ??

So as a temp fix I have got round this by increasing the bottom padding and losing the background colour and border.
I might not be very clever but I can lift heavy weights!

52
javelin
Re: CSS100 [Holy Grail CSS Wireframe Theme]
  • 2006/9/13 10:35

  • javelin

  • Not too shy to talk

  • Posts: 160

  • Since: 2004/3/11


Also I've been trying to get the site through validation.

I get 17 errors on xhtml which compared to other themes is teriffic however the first four errors are all on the same issue,

ID "masthead" already defined

Also I have a couple of, ID "mainmenu" already defined

The next four are, I suspect, module/template related and not theme and highlight issues with, an attribute specification must start with a name or name token - which refers to the quote marks in a number of url lines like this,

/uploads/t1.pdf" " title="Training the trainer">

Any help with these would be very welcome
I might not be very clever but I can lift heavy weights!

53
technigrafa
Re: CSS100 [Holy Grail CSS Wireframe Theme]

@javelin

Your masthead ID in theme.html is being declared twice - IDs can only be used once per page - classes can be used several times (Same reason for mainmenu error below):

<div id="pageWrapper">
<
div id="masthead" class="inside">
<!-- 
masthead content begin --></div>

<
div id="masthead" class="inside" align="center">


I checked the file I have and it is correct there:

<div id="pageWrapper">
<
div id="masthead" class="inside">

<!-- 
masthead content begin -->

<
div id="logo"><a href="<{$xoops_url}>/"><img src="<{$xoops_imageurl}>images/logo.gif" alt="<{$xoops_sitename}>" /></a></div>
<
h2 id="title"><a href="<{$xoops_url}>"><{$xoops_slogan}></a></h2>
<
div id="banner"><{$xoops_banner}></div>
<
div style="clear:both;"></div>
        
<!-- 
masthead content end -->



Your mainmenu problem is because both the "Main Menu" and the "SVAPC" blocks are declaring the id="mainmenu" . Since you have two blocks needing that tag, you should use classes instead of ID. The "id=" should be changed to "class=" in your block templates and in your style.css change all the occurances of #mainmenu to .mainmenu.

I'm going to go ahead and change the replacement main menu block in the theme to use a class instead of an id. This will mean that any other module looking for the mainmenu "ID" won't find it though until it is modified to look for the class instead.

And you're right, the other errors are from your other blocks. Just read through the errors from W3C - often it will tell you exactly what the problem is.

54
javelin
Re: CSS100 [Holy Grail CSS Wireframe Theme]
  • 2006/9/13 15:11

  • javelin

  • Not too shy to talk

  • Posts: 160

  • Since: 2004/3/11


Many thanks.

Just about done except for this one,

Line 74, column 25: document type does not allow element "style" here .
<style type="text/css"><!--

and I don't understand enough to try a solution on my own.

Apart from the masthead issues which were of my making all the others seem to have been Multimenu related.
Which is a shame as Multimenu is such a handy module.
I might not be very clever but I can lift heavy weights!

55
technigrafa
Re: CSS100 [Holy Grail CSS Wireframe Theme]

Hmm,

I thought I had already fixed this, but I guess I only fixed it in skidoo2. Move this section below to right before the </head> line:

<{if !$xoops_rblocks}>
        <
style type="text/css"><!-- 
        
#outerColumnContainer {border-right:none;}
        
.centerLcolumn, .centerRcolumn {width:260px;}
        --></
style>
    <{/if}>
    
    <{if !
$xoops_lblocks}>
        <
style type="text/css"><!-- 
        
#outerColumnContainer {border-left:none;}
        
.centerLcolumn, .centerRcolumn {width:260px;}
        --></
style>
    <{/if}>


I think that should work. You're not supposed to declare CSS changes like that outside the head. I had a note about that in the changelog, but I think this will fix it. I'll update the themes again.

56
javelin
Re: CSS100 [Holy Grail CSS Wireframe Theme]
  • 2006/9/13 18:08

  • javelin

  • Not too shy to talk

  • Posts: 160

  • Since: 2004/3/11


Many thanks - xhtml and css both now validate

Need to try and sort Multimenu next.

For those who are following this and want to validate
the short term solution if you require extra menus is to create them using a custom block.

Seems to work for me :)
I might not be very clever but I can lift heavy weights!

57
Chappy
Re: CSS100 [Holy Grail CSS Wireframe Theme]
  • 2006/9/15 3:38

  • Chappy

  • Friend of XOOPS

  • Posts: 456

  • Since: 2002/12/14


Using the fixed theme, when I use search from a block in the left column, on IE the actual search results show perfectly, but they shift both left and right columns down. a right column block actually shows up in the center. I'm sure it's something that is related to the search block design. Again, this occurs in IE. You can see it here.
MMM...It tastes like chicken! ...

58
javelin
Re: CSS100 [Holy Grail CSS Wireframe Theme]
  • 2006/9/15 12:58

  • javelin

  • Not too shy to talk

  • Posts: 160

  • Since: 2004/3/11


It looks like the Search selection block with the tick boxes is not wrapping correctly.

Perhaps a small mod to this template might fix it.

I said prviously that the xhtml and css both now validate.

Well its half true as the Xhtml does validate but the css has two issues.
Quote:

word-wrap: break-word;
With the comment /* invalid CSS but keeps IE from breaking horribly under narrow viewports */

and

display: inline-block;
With the comment /* IE/Mac needs this */


Both, given the comments, appear to be known as issues by the Ruthersarian guy who created the original css.

Does anyone have any ideas how to solve or bypass these two issues?
I might not be very clever but I can lift heavy weights!

59
technigrafa
Re: CSS100 [Holy Grail CSS Wireframe Theme]

Chappy,

I think what's causing that is your advanced search box table on the bottom of the results page, because I don't have that problem. But I think it's because I don't have as many modules installed on my dev site, meaning the table isn't as wide:

http://dev.technigrafa.com/xoops/

I'm not sure why it's not wrapping for you - do you have the most recent version of the fixed theme?

Perhaps something like this in style.css would fix it:

#content table {width:400px}

You may have to play with the actual pixel width amount.

*EDIT: I reposted the fixed and skidoo2 themes with some color changes and some fixes for the Content module menus.

60
Chappy
Re: CSS100 [Holy Grail CSS Wireframe Theme]
  • 2006/9/17 1:01

  • Chappy

  • Friend of XOOPS

  • Posts: 456

  • Since: 2002/12/14


I uploaded the newest versions of both themes. Skidoo2 seems flawless so far as I can tell. Good comments from those who visit my site as well. As far as the fixed theme goes, I tried the suggestion you made and in IE still have problems even setting the content to 350, 400, and 450. No difference noted in the issue ot the downward displacement of the left column. Additionally, in the fixed them, on mine, when the font button is clicked at the larger sizes, the light blue header doesn't coninue to fill in the dark blue background on the right hand side i.e. the whole content area widens but the light blue header at the top does not fill in accordingly.

Thanks for all your work in this.


Mike D.
MMM...It tastes like chicken! ...

Login

Who's Online

92 user(s) are online (47 user(s) are browsing Support Forums)


Members: 0


Guests: 92


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Apr 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits