1
russtik
Site Migration Issues
  • 2006/9/13 16:54

  • russtik

  • Just popping in

  • Posts: 70

  • Since: 2004/8/13


That age old problem strikes again... running into a blank white page after migrating a site.

So, I backed up DB and site files. Imported DB and uploaded files to new server. Modified mainfile.php and run the new location in the browser and I get a blank white page. Turning debug on results in this:

Quote:

Notice [PHP]: Only variable references should be returned by reference in file include/functions.php line 493
Notice [PHP]: Only variable references should be returned by reference in file include/functions.php line 493
Notice [PHP]: Only variables should be assigned by reference in file class/database/mysqldatabase.php line 236


Originating Server:
FreeBSD 4.11-STABLE
PHP 4.4.2
Register_globals ON
MYSQL 4.1.19
Xoops 2.0.13.1

New Server:
Linux Fedora 2.6.11-1.1369_FC4smp
PHP 4.4.2
Register_globals OFF
MYSQL 4.1.21


re-backed up the files and database incase they were corrupt, but that hasn't yielded any results.

Can anyone help?

2
jensclas
Re: Site Migration Issues

Did you try eveything suggested in the blank page FAQ?

3
russtik
Re: Site Migration Issues
  • 2006/9/15 11:23

  • russtik

  • Just popping in

  • Posts: 70

  • Since: 2004/8/13


Right, o.k...

After the 4th attempt at dumping the database and backing up the files my site has sprung back into life. I think the database dump was the culprit. It's a hefty 68mb, what with a gazillion private messages in there.

Is there a way to set the notifications as email by default rather than PM?

Login

Who's Online

56 user(s) are online (41 user(s) are browsing Support Forums)


Members: 0


Guests: 56


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Oct 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits