xoops forums

rcjohnson

Not too shy to talk
Posted on: 2006/2/23 21:58
rcjohnson
rcjohnson (Show more)
Not too shy to talk
Posts: 187
Since: 2004/7/23
#1

Cannot get into Admin Module

I've had this problem for several months now. The same problem happens in 2.0.10 and 2.0.12a.

When I log into the site and try to access the Admin menu, im taken to a blank page that gives the following error:

Quote:
Fatal error: Call to a member function on a non-object in /home/xxxxxxx/public_html/header.php on line 100


the above message appears in 2.0.10

When I use 2.0.12a, the error message that appears is
Quote:
The seleted module does not exist!
When using the 12a setup, the error message appears inside my regular theme, wheras in 0.10, the error is just on a blank page.

I've activated all the logging I could access in teh FAQ section. I've also read several posts where other people are having the same problems, but they never get a good resolution.

I have no idea where to go from here. I've put in a fresh set of files for both the .10 and .12a versions, cleared /cache and /templates_cache, check and verified 777 permissions on /cache /templates_cache /upload and mainfile.php.

It is important to note that I can access my other modules on the site, nut not anything under the admin menu.

Thanks in advance for any assitance.

Ryan
- XOOPS 4 THE WIN!

rcjohnson

Not too shy to talk
Posted on: 2006/2/24 17:49
rcjohnson
rcjohnson (Show more)
Not too shy to talk
Posts: 187
Since: 2004/7/23
#2

Re: Cannot get into Admin Module

Does anyone have any ideas? I've searched and found countless posts with this same issue, but nobody ever offers up a solution.
- XOOPS 4 THE WIN!

rcjohnson

Not too shy to talk
Posted on: 2006/2/27 16:55
rcjohnson
rcjohnson (Show more)
Not too shy to talk
Posts: 187
Since: 2004/7/23
#3

Re: Cannot get into Admin Module

Here is some addtional information:

XOOPS Version:
XOOPS 2.0.12a

XOOPS Theme:
Zaja-System

XOOPS Template Set:
new1

PHP Version:
4.3.10

MySQL Version:
4.0.22-standard

Server Software:
Apache/1.3.33 (Unix) mod_jk/1.2.6-dev mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 PHP/4.3.10 FrontPage/5.0.2.2635 mod_ssl/2.8.22 OpenSSL/0.9.7a

User's Browser:
Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 2.0.50727)
- XOOPS 4 THE WIN!

rcjohnson

Not too shy to talk
Posted on: 2006/2/27 19:16
rcjohnson
rcjohnson (Show more)
Not too shy to talk
Posts: 187
Since: 2004/7/23
#4

Re: Cannot get into Admin Module

well, I found at least a part of the problem with not being able to access the admin menus. I had a duplicate "system" row in the _modules table.

I deleted the second one and can now access everything under the admin area, however I do get a lot of script debugging errors while in the admin menus. I guess I can live with it for now.
- XOOPS 4 THE WIN!