1
serf1
Site suddenly only displaying white page - Help, Please
  • 2005/12/22 15:31

  • serf1

  • Just popping in

  • Posts: 49

  • Since: 2005/11/30


My site has gone. It was working a couple of hours ago and now its a white page.

It has been running without problem for a couple of weeks and today I have not done anything more than add a topic or two to the forum. How can an error occur out of nowhere?

Where do I start looking?

I have checked the FAQs on white pages and I failed to run the SQL query properly. I checked the error line in the php file mentioned, it didn't need to be changed.

How do I understand where the problem came from?


[size=x-small][Edit by Bender] Subject changed. Please use meaningfull subjects. [/size]

2
Bananadude
Re: Help, Please
  • 2005/12/22 15:42

  • Bananadude

  • Not too shy to talk

  • Posts: 155

  • Since: 2005/9/16


Go to http://www.rightlinks.co.uk/portal/user.php
log in to your control panel, enable phpdebug from system preferences, go back to the index and see if you gets any errors/warnings.

Best Regards,
Bananadude
--- censored by Bananadude ---

3
kakos
Re: Help, Please
  • 2005/12/22 16:14

  • kakos

  • Friend of XOOPS

  • Posts: 78

  • Since: 2002/6/6 2


I believe that your problem is in "xhld". If I am not going wrong you have also xhld as start module.

Costas

4
bluenova
Re: Help, Please

yup, seems like xhld is the problem, you can access your site here:
http://rightlinks.co.uk/portal/modules/newbb/

It could be a problem with one of your feeds if it suddenly started.

Please see the 'please read before posting' message for more info on debugging.

5
serf1
Re: Help, Please
  • 2005/12/26 8:36

  • serf1

  • Just popping in

  • Posts: 49

  • Since: 2005/11/30


Thanks for the pointers. I have managed to get into the site and I am getting the following error message:

Notice [PHP]: Undefined index: theme in file kernel/object.php line 279
Notice [PHP]: Undefined index: theme in file kernel/object.php line 280
Notice [PHP]: Undefined index: theme in file kernel/object.php line 375

Now if I can just work out what that means :).

I disabled xlhd for now. but it has not, as yet solved the problem.

Thanks Chaps

6
serf1
Re: Help, Please
  • 2005/12/26 9:20

  • serf1

  • Just popping in

  • Posts: 49

  • Since: 2005/11/30


I also found an SQL error

SELECT COUNT(*) FROM xoops_users u, xoops_user_profile p WHERE u.uid = p.profileid AND level > '0'
Error number: 1146
Error message: Table 'right_xoop1.xoops_user_profile' doesn't exist
( 0.000303)

Now all my users have mysteriously disappeared. Thankfully there were only 30 odd of them.

7
Bananadude
Re: Help, Please
  • 2005/12/26 18:25

  • Bananadude

  • Not too shy to talk

  • Posts: 155

  • Since: 2005/9/16


I think that the sql-error can be solved by updating the Profile module, go to modules in the adminpanel and choose update for the Profile module.

Best Regards,
Bananadude
--- censored by Bananadude ---

Login

Who's Online

231 user(s) are online (75 user(s) are browsing Support Forums)


Members: 0


Guests: 231


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jul 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits