1
Mantooth
i tried to upgrade and my site exploded - i need advice
  • 2005/12/7 16:22

  • Mantooth

  • Friend of XOOPS

  • Posts: 189

  • Since: 2004/11/2


Hi. I tried to upgrade my site to 2.2.3 and I had some serious problems. if someone could answer any of my questions, it would be most appreciated.

I followed the upgrade instructions but after upgrading, every page on the site was blank... with no debug phperror messages. i tried going to admin.php and recovery.php manually but with no luck. after that, i attempted to downgrade and followed the patch's instructions but using downgrade.php came up with nothing but a blank page.

Does it matter that XOOPS isn't installed on my home directory?

Also, I turned my site off to visitors before attempting the upgrade. Could that have caused anything to go wrong?


After all these problems, I wiped my database and restored with a backup. everything is working fine now except that whenever a user logs in or makes a post, the "thanks for your submission" page doesn't automatically redirect and you have to use the "click here" link.

Does anyone know why that would happen?
www.slopeanime.com/main
user : testing
pass : testing123

----Here is my server/xoops info:

XOOPS Version: 2.0.13.1
Operating system: FreeBSD
Kernel version: 5.4-RELEASE
Apache version: 1.3.34 (Unix)
PHP version: 4.4.1
MySQL version: 4.0.26
Theme you are using: MontisArts halo2
Custom template: (No)
PHP Debug Messages: None (completely blank page)
MySQL Debug Messages: None
Smarty Debug Messages: None


Thanks to anyone who takes the time to read the long post.
-Mantooth
...


I hate Mortal Kombat

2
Bender
Re: i tried to upgrade and my site exploded - i need advice
  • 2005/12/7 16:51

  • Bender

  • Home away from home

  • Posts: 1899

  • Since: 2003/3/10


Any entries in the servers error.log?



Since its not perfectly clear from your post:

Did you also backup the files and deleted/restored them?



How about downloading your site and using xampp or something to play around with the upgrade process localy?

Here is a list of different versions to find one that matches or comes close to your php/mysql combination.
Sorry, this signature is experiencing technical difficulties. We will return you to the sheduled signature as soon as possible ...

3
Mantooth
Re: i tried to upgrade and my site exploded - i need advice
  • 2005/12/7 18:46

  • Mantooth

  • Friend of XOOPS

  • Posts: 189

  • Since: 2004/11/2


yea, i backed up my files before upgrading and restored them before attempting to downgrade like the instructions said. nothing worked until i imported the backup of my old database though.

my main concern at this point is getting the page redirection to work again after reverting to the backup. If i get that fixed, i'll at least feel comfortable knowing that i can get everything back the way it was before i attempt to upgrade again.


i'll try xampp and play around upgrading on my computer in the meantime


if anyone can tell me how to get the page redirection to work again i'd REALLy appreciate it.
...


I hate Mortal Kombat

4
Bender
Re: i tried to upgrade and my site exploded - i need advice
  • 2005/12/7 19:49

  • Bender

  • Home away from home

  • Posts: 1899

  • Since: 2003/3/10


Your redirect screen is incomplete.

If you look at the source you only have
Quote:

<div style="text-align:center; background-color: transparent; border-top: 0px solid #FFFFFF; border-left: 0px solid #FFFFFF; border-right: 0px solid #AAAAAA; border-bottom: 0px solid #AAAAAA; font-weight : bold;">
<h4>Thank you for logging in, testing.</h4>
<p>If the page does not automatically reload, please click <a href='http://www.slopeanime.com/main/modules/news/'>here</a></p>
</div>


The complete set of metatags is missing.

Go into templates and check how system_redirect.html looks in your database.

Does it contain these lines:

Quote:
00001: <html>
00002: <head>
00003: <meta http-equiv="Content-Type" content="text/html; charset=<{$xoops_charset}>" />
00004: <meta http-equiv="Refresh" content="<{$time}>; url=<{$url}>" />
00005: <title><{$xoops_sitename}></title>
00006: <link rel="stylesheet" type="text/css" media="all" href="<{$xoops_themecss}>" />
00007: </head>
00008: <body>


Especially without line 0004 its obvious why it does not redirect automaticly.

Maybe regenerating this template helps (clear templates_c again after doing so).

In the original package the file is located here:
\html\modules\system\templates\system_redirect.html
Sorry, this signature is experiencing technical difficulties. We will return you to the sheduled signature as soon as possible ...

5
Mantooth
Re: i tried to upgrade and my site exploded - i need advice
  • 2005/12/7 21:24

  • Mantooth

  • Friend of XOOPS

  • Posts: 189

  • Since: 2004/11/2


Thanks! I uploaded a new version of that file and it works great.

i'm feeling better about this upgrade problem. because now i can test it on my computer and even if it messes up on the server i can restore things perfectly.
...


I hate Mortal Kombat

6
sikey
Re: i tried to upgrade and my site exploded - i need advice
  • 2005/12/7 22:48

  • sikey

  • Not too shy to talk

  • Posts: 151

  • Since: 2003/4/29


Better stay away from the 2.2.X versions...

Login

Username:
Password:

Lost Password? Register now!

Who's Online

67 user(s) are online (40 user(s) are browsing Support Forums)


Members: 0


Guests: 67


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jan 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits