1
eon03
No blocks in 2.2.3
  • 2005/12/2 18:12

  • eon03

  • Just popping in

  • Posts: 23

  • Since: 2005/2/3 2


I upgraded to 2.2.3 2 days ago and today there are no blocks being displayed on my site. I can view each module and its contents and I can go to admin.php and view all settings. It is all there, just no blocks on my site. Has any one experienced this or know a possible solution?

I have tried switcing back to the default templates and default themes with no success.

With all debug modes on I get this error in the queries core:

SELECT DISTINCT i.instanceid, b.*, i.* FROM xoops_block_instance i, xoops_newblocks b, xoops_block_module_link m WHERE m.block_id=i.instanceid AND i.instanceid IN (1,41,2,49,5,7,9,10,51,14,26,40,52,61,65,67) AND i.visible=1 AND i.bid=b.bid AND b.isactive=1 AND m.module_id=0 AND m.pageid IN (0, 1) ORDER BY i.weight,i.instanceid
Error number: 1
Error message: Can't create/write to file '/tmp/#sql_4a2_0.MYI' (Errcode: 13)
( 0.001095)

and these are the PHP errors on my index:

Notice [PHP]: Undefined index: xoops_module_header in file templates_c/%%57^578^578A4102%%theme.html.php line 9
Notice [PHP]: Undefined index: xoops_showrblock in file templates_c/%%57^578^578A4102%%theme.html.php line 46
Notice [PHP]: Undefined index: xoops_showlblock in file templates_c/%%57^578^578A4102%%theme.html.php line 61
Notice [PHP]: Undefined index: xoops_showcblock in file templates_c/%%57^578^578A4102%%theme.html.php line 82
Notice [PHP]: Undefined index: xoops_showrblock in file templates_c/%%57^578^578A4102%%theme.html.php line 140

The site is www.thefirsteon03.com

2
jdseymour
Re: No blocks in 2.2.3

Not sure about the MySQL error, but the PHP errors state that template_c is not writable. Double check it.

3
eon03
Re: No blocks in 2.2.3
  • 2005/12/2 21:35

  • eon03

  • Just popping in

  • Posts: 23

  • Since: 2005/2/3 2


Templates_c is all 777. If I delete all the templates then browse the the site admin and revisit templates_c there are new files created. Ill keep investigating.


Update- the site is back running. It must have been a server error with my web host. <sarcasm>I LOVE hosting for 1.95 a month.</sarcasm>

4
lord74
Re: No blocks in 2.2.3
  • 2005/12/21 11:02

  • lord74

  • Just popping in

  • Posts: 1

  • Since: 2004/12/2


Hi Eon
I have the same problem, but don't know how to resolve this error. I ask you because your site is good now ....

Sorry for the language, i'm french

Fred

5
jdseymour
Re: No blocks in 2.2.3

Hi Fred,

Go to System Admin - Templates, Check the templates for "system" see if any need to be generated.

Login

Username:
Password:

Lost Password? Register now!

Who's Online

78 user(s) are online (52 user(s) are browsing Support Forums)


Members: 0


Guests: 78


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Dec 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits