1
macmend
mail problems in xoops 2.0.9
  • 2005/9/28 8:27

  • macmend

  • Quite a regular

  • Posts: 285

  • Since: 2004/2/27


On a private site I use as a helpdesk facility using the excellent xhelp...I have suddenly started to have mail problems, using phpmail and also send mail, although XOOPS says it has sent a mail, it never arrives (I have checked this using my own mail accounts) what reasons could there be for this and is it possible to check whether it is sent or not.
Free Mac Support

Ordinary Wisdom

apache server with php sshexec turned on
xoops version 2.0.18.1 & 2.3.1
php version 5.2.5
mysql version 5.0.45

2
highlander
Re: mail problems in xoops 2.0.9
  • 2005/9/28 12:41

  • highlander

  • Not too shy to talk

  • Posts: 151

  • Since: 2004/12/5


Hi Macmend,

Have youspoken to your host about this ?
If things "all of a sudden" stop working it is most likely to be an external factor (server setup, dns etc.) whic is to blame.
Quite often the webhost will also be able to trac and debug mail problems alot easier than you can.

kind regards,

Highlander
So, I'm in the park wondering why frisbees get larger as they get closer when suddenly, it hits me...
http://www.AnimalPedigree.com

3
macmend
Re: mail problems in xoops 2.0.9
  • 2005/9/28 13:02

  • macmend

  • Quite a regular

  • Posts: 285

  • Since: 2004/2/27


yes, its on a subdomain of macmend.com, all seems to work perfectly on macmend.com but not on the subdomain

jonathan
Free Mac Support

Ordinary Wisdom

apache server with php sshexec turned on
xoops version 2.0.18.1 & 2.3.1
php version 5.2.5
mysql version 5.0.45

4
macmend
Re: mail problems in xoops 2.0.9
  • 2005/9/29 8:19

  • macmend

  • Quite a regular

  • Posts: 285

  • Since: 2004/2/27


so it turns out they have turned off the ability for 'nobody' to send mail as this was causing lots of spam, however as the mail works on the main domain and not the sub, I can't see why this would effect the subdomain site.
Free Mac Support

Ordinary Wisdom

apache server with php sshexec turned on
xoops version 2.0.18.1 & 2.3.1
php version 5.2.5
mysql version 5.0.45

5
macmend
Re: mail problems in xoops 2.0.9
  • 2005/9/29 15:23

  • macmend

  • Quite a regular

  • Posts: 285

  • Since: 2004/2/27


have updated to 2.013 and the result i still can't send mail, its driving me mad, the whole mail thing seems not to be able to work!
Free Mac Support

Ordinary Wisdom

apache server with php sshexec turned on
xoops version 2.0.18.1 & 2.3.1
php version 5.2.5
mysql version 5.0.45

6
ackbarr
Re: mail problems in xoops 2.0.9

sounds like you'll need to configure your XOOPS site to send email via SMTP (not SMTP Auth). If your host provides normal mail services, use the same SMTP settings for your site that you would use in your mail client.
Site Hosting - PlanetXoops

7
macmend
Re: mail problems in xoops 2.0.9
  • 2005/9/29 19:01

  • macmend

  • Quite a regular

  • Posts: 285

  • Since: 2004/2/27


I checked in MySQL and i get these error messages

Problems with indexes of table `xoops_banner`
PRIMARY and INDEX keys should not both be set for column `bid`
Problems with indexes of table `xoops_citas`
PRIMARY and INDEX keys should not both be set for column `id`
Problems with indexes of table `xoops_newblocks`
More than one INDEX key was created for column `mid`
Problems with indexes of table `xoops_priv_msgs`
PRIMARY and INDEX keys should not both be set for column `msg_id`
More than one INDEX key was created for column `to_userid`
Problems with indexes of table `xoops_ranks`
More than one INDEX key was created for column `rank_min`
Problems with indexes of table `xoops_smartfaq_answers`
PRIMARY and INDEX keys should not both be set for column `answerid`
Problems with indexes of table `xoops_smartfaq_categories`
PRIMARY and INDEX keys should not both be set for column `categoryid`
Problems with indexes of table `xoops_smartfaq_faq`
PRIMARY and INDEX keys should not both be set for column `faqid`
Problems with indexes of table `xoops_users`
PRIMARY and INDEX keys should not both be set for column `uid`
More than one INDEX key was created for column `uname`
Problems with indexes of table `xoops_xhelp_department_mailbox`
PRIMARY and INDEX keys should not both be set for column `id`


can anyone tell me what to do with this?
Free Mac Support

Ordinary Wisdom

apache server with php sshexec turned on
xoops version 2.0.18.1 & 2.3.1
php version 5.2.5
mysql version 5.0.45

8
macmend
Re: mail problems in xoops 2.0.9
  • 2005/9/30 8:56

  • macmend

  • Quite a regular

  • Posts: 285

  • Since: 2004/2/27


I cannot use SMTP, it seems to me that something has gone wrong in the XOOPS install, but i have no idea how this has happened, unless somewhere in updating a module things went awry... is there anything i can do, reinstall everything? scrap it all and start again? ...but I already have a lot of records and a good knowledgebase built up with the excellent smartfaq module. if i have to scrap it all it will be a disaster, especially as it seems the "something wrong' is also in the database.
Free Mac Support

Ordinary Wisdom

apache server with php sshexec turned on
xoops version 2.0.18.1 & 2.3.1
php version 5.2.5
mysql version 5.0.45

9
McNaz
Re: mail problems in xoops 2.0.9
  • 2005/9/30 9:22

  • McNaz

  • Just can't stay away

  • Posts: 574

  • Since: 2003/4/21


It doesn't look like there is anything wrong with your XOOPS install. The MySQL messages look like warning messages as opposed to critical "your site is going to die now" error messages.

I suggest you take ackbarr's advise and configure XOOPS to use SMTP. Ask your host these details as they are in far better position to help you.

Good luck.

10
macmend
Re: mail problems in xoops 2.0.9
  • 2005/9/30 12:24

  • macmend

  • Quite a regular

  • Posts: 285

  • Since: 2004/2/27


I found another posting with a similar error, it looks like it must be realted to the server host disallowing 'nobody' and XOOPS must send via user nobody, and i ask same as that poster did is there anyway to recode the routine so it doesn't do this.

Thanks, i have now asked my hosts if they could help...smtp or the nobody thing and I have full smtp facility but it will not work either on smtp or smtpauth

What i can't understand is why as i run two XOOPS sites at macmend.com one private and one public...why one can send mail and the other can't!!??
Free Mac Support

Ordinary Wisdom

apache server with php sshexec turned on
xoops version 2.0.18.1 & 2.3.1
php version 5.2.5
mysql version 5.0.45

Login

Who's Online

261 user(s) are online (222 user(s) are browsing Support Forums)


Members: 0


Guests: 261


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jun 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits