1
Mithrandir
Activation Link fix test

First job for the beta testing team, until we get the infrastructure finalised:

Could you try replacing
if (!strpos(XOOPS_URL"http")) {
        
//Relative URL used, calculate absolute URL
        
$protocol strtolower(substr($_SERVER['SERVER_PROTOCOL'], 0strpos($_SERVER['SERVER_PROTOCOL'], "/"0)));
        
define("XOOPS_ABS_URL"$protocol."://".$_SERVER['HTTP_HOST'].XOOPS_URL);
    }
    else {
        
define("XOOPS_ABS_URL"XOOPS_URL);
    }

with
if (strpos(XOOPS_URL"http") === 0) {
        
define("XOOPS_ABS_URL"XOOPS_URL);
    }
    else {
        
//Relative URL used, calculate absolute URL
        
$protocol strtolower(substr($_SERVER['SERVER_PROTOCOL'], 0strpos($_SERVER['SERVER_PROTOCOL'], "/"0)));
        
define("XOOPS_ABS_URL"$protocol."://".$_SERVER['HTTP_HOST'].XOOPS_URL);
    }

in include/common.php (around lines 119-126)

Then see if it fixes the activation link as well as other links in emails.

Thanks
"When you can flatten entire cities at a whim, a tendency towards quiet reflection and seeing-things-from-the-other-fellow's-point-of-view is seldom necessary."

Cusix Software

2
JMorris
Re: Activation Link fix test
  • 2005/9/17 23:42

  • JMorris

  • XOOPS is my life!

  • Posts: 2722

  • Since: 2004/4/11


Sorry it took so long to get back to you on this.

Your fix worked like a charm on MyWebResource. Looks like someone already beat me to it on the beta testing sites.

Best Regards,

James
Insanity can be defined as "doing the same thing over and over and expecting different results."

Stupidity is not a crime. Therefore, you are free to go.

3
Chappy
Re: Activation Link fix test
  • 2005/9/18 3:52

  • Chappy

  • Friend of XOOPS

  • Posts: 456

  • Since: 2002/12/14


Worked for me as well. Thanks!
MMM...It tastes like chicken! ...

4
jakeabiva
Re: Activation Link fix test
  • 2005/11/16 8:06

  • jakeabiva

  • Just popping in

  • Posts: 20

  • Since: 2005/6/25


Hi,

Are you ver 2.2.3? Because I did not find this code on my common.php. I'm using 2.2.3



Quote:

Mithrandir wrote:
First job for the beta testing team, until we get the infrastructure finalised:

Could you try replacing
if (!strpos(XOOPS_URL"http")) {
        
//Relative URL used, calculate absolute URL
        
$protocol strtolower(substr($_SERVER['SERVER_PROTOCOL'], 0strpos($_SERVER['SERVER_PROTOCOL'], "/"0)));
        
define("XOOPS_ABS_URL"$protocol."://".$_SERVER['HTTP_HOST'].XOOPS_URL);
    }
    else {
        
define("XOOPS_ABS_URL"XOOPS_URL);
    }

with
if (strpos(XOOPS_URL"http") === 0) {
        
define("XOOPS_ABS_URL"XOOPS_URL);
    }
    else {
        
//Relative URL used, calculate absolute URL
        
$protocol strtolower(substr($_SERVER['SERVER_PROTOCOL'], 0strpos($_SERVER['SERVER_PROTOCOL'], "/"0)));
        
define("XOOPS_ABS_URL"$protocol."://".$_SERVER['HTTP_HOST'].XOOPS_URL);
    }

in include/common.php (around lines 119-126)

Then see if it fixes the activation link as well as other links in emails.

Thanks

Login

Username:
Password:

Lost Password? Register now!

Who's Online

68 user(s) are online (27 user(s) are browsing Support Forums)


Members: 0


Guests: 68


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jun 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits