xoops forums

-snake-

Just popping in
Posted on: 2005/7/31 11:56
-snake-
-snake- (Show more)
Just popping in
Posts: 38
Since: 2005/6/9 8
#1

phpwiki problem in xops 2.0.10 plz help

hi all I have installed XOOPS 2.0.10 and have downloaded phpwiki module from bluetopia.net

I have installed it succesfully:
-------------
Version: 0.1
Author: Original phpwiki ( http://phpwiki.sourceforge.net/ )

SQL file found at C:/xampplite/htdocs/html/modules/phpwiki/sql/mysql.sql.
Creating tables...
Table xoops_phpwiki_page created.
Table xoops_phpwiki_version created.
Table xoops_phpwiki_recent created.
Table xoops_phpwiki_nonempty created.
Table xoops_phpwiki_link created.
Table xoops_phpwiki_session created.
Module data inserted successfully. Module ID: 4
Setting group rights...
Added admin access right for Group ID 1
Added user access right for Group ID: 1
Added user access right for Group ID: 2

Module Wiki installed successfully.
Back to Module Administration page

--------

but when I try to access module I get this error:

-----------

C:\xampplite\htdocs\html\class\xoopssecurity.php:42: Fatal[2048]: var: Deprecated. Please use the public/private/protected modifiers

C:\xampplite\htdocs\html\class\xoopssecurity.php:42: Fatal[2048]: var: Deprecated. Please use the public/private/protected modifiers

--------------------

please help me what to do....

DCrussader

Friend of XOOPS
Posted on: 2005/7/31 14:54
DCrussader
DCrussader (Show more)
Friend of XOOPS
Posts: 573
Since: 2005/7/4 7
#2

Re: phpwiki problem in xops 2.0.10 plz help

u have to replace it with Wiwimod, most of the module are incompatible with XOOPS 2.0.9 and later.

2.0.13 is the most stable instead of 2.0.10 and 2.2, but this will not fix the problem with phpwiki. If u wanna exatcly this module, u have to install XOOPS 2.0.7.3 the last stable (without Mith's security class addition).
May The Source Be With You!

-snake-

Just popping in
Posted on: 2005/7/31 19:13
-snake-
-snake- (Show more)
Just popping in
Posts: 38
Since: 2005/6/9 8
#3

Re: phpwiki problem in xops 2.0.10 plz help

yeah u r right! this module is not compatible XOOPS 2.0.10 or later. I have installed wiwimod.... I was having proble with it first but now it fine...

thanks for the info