xoops forums

EricLomm

Just popping in
Posted on: 2005/7/7 16:11
EricLomm
EricLomm (Show more)
Just popping in
Posts: 10
Since: 2005/6/3 1
#1

"Cannot instantiate non-existent class" in icontent

I have down loaded and installed the icontent module onto my linux box. It seems to have installed correctly except for the fact that when I try to go into the admin module I am getting the error message "Cannot instantiate non-existent class" when I try to open the admin module.

What it appears is happening from the full text that appears on the screen is that the icontent admin window is trying to call the class named "admin.class.php" located in the subdirectory class under the icontent folder and is not able to open this file. I have tried changing the path that it is looking for this class to include the full absolute path to the file it is looking for and I was still getting this error.

I also change the permissions to 755 and did not have any success. I then tried using the premissions at 777 and had the same result.

Does anybody have some suggstions on what I would need to do to get this admin module to work correctly?

Thanks in advance