xoops forums

DevlshOne

Just popping in
Posted on: 2005/4/20 23:42
DevlshOne
DevlshOne (Show more)
Just popping in
Posts: 56
Since: 2005/4/15
#1

Admin option gone from User Menu

Really need some help here...

My Admin Menu option has disappeared from my User Menu when I am logged in. I've checked the databases manually and everything appears to be in order. The only thing I did was remove all user signatures and add "flat" to umode in the user database.

Need some desperate help here!!!

jdseymour

Friend of XOOPS
Posted on: 2005/4/20 23:56
jdseymour
jdseymour (Show more)
Friend of XOOPS
Posts: 3782
Since: 2004/11/11
#2

Re: Admin option gone from User Menu

check back in the database and make sure your username is UID 1.

DevlshOne

Just popping in
Posted on: 2005/4/21 0:50
DevlshOne
DevlshOne (Show more)
Just popping in
Posts: 56
Since: 2005/4/15
#3

Re: Admin option gone from User Menu

My `username` is not 'UID 1', it's DevlshOne and it's worked all this time until now. My `uid` = '1'.

kain

Just popping in
Posted on: 2005/4/21 2:29
kain
kain (Show more)
Just popping in
Posts: 56
Since: 2002/1/9 9
#4

Re: Admin option gone from User Menu

yes, I was searching for a similar problem, and I see that I'm not only the only one having this issue.

I've currently finished a custom upgrade (and very complicated) upgrade script from e-xoops 1.05rev3 custom to XOOPS 2, so I do a lot of testing.

Administration button disappears in XOOPS 2.0.10RC2 on a clean install, it shows up with a stable 2.0.9.2 from scratch.

I've searched through tplsource data and I haven't find a solution (as I don't have a clue about it).
Plus I noticed an issue with RC2, when installed into a folder (eg. www.something.com/folder) paths are not corrects.

System will try to login, for example, in www.something.com/user.php and not folder/user.php, even avatars/ranks/smilies path are wrong (eg. img src url: www.something.com/rank3e632f95e81ca.gif) - mainfile.php's values are correct of course.

kain

Just popping in
Posted on: 2005/4/21 3:11
kain
kain (Show more)
Just popping in
Posts: 56
Since: 2002/1/9 9
#5

Re: Admin option gone from User Menu

maybe I sorted out this thing..
XOOPS 2.0.10 RC2 missed this:
INSERT INTO xoops_tplsource VALUES("15""<table cellspacing="0">rn  <tr>rn    <td id="usermenu">rn      <a class="menuTop" href="<{$xoops_url}>/user.php"><{$block.lang_youraccount}></a>rn      <a href="<{$xoops_url}>/edituser.php"><{$block.lang_editaccount}></a>rn      <a href="<{$xoops_url}>/notifications.php"><{$block.lang_notifications}></a>rn      <a href="<{$xoops_url}>/user.php?op=logout"><{$block.lang_logout}></a>rn      <{if $block.new_messages > 0}>rn        <a class="highlight" href="<{$xoops_url}>/viewpmsg.php"><{$block.lang_inbox}> (<span style="color:#ff0000; font-weight: bold;"><{$block.new_messages}></span>)</a>rn      <{else}>rn        <a href="<{$xoops_url}>/viewpmsg.php"><{$block.lang_inbox}></a>rn      <{/if}>rnrn      <{if $xoops_isadmin}>rn        <a href="<{$xoops_url}>/admin.php"><{$block.lang_adminmenu}></a>rn      <{/if}>rn    </td>rn  </tr>rn</table>rn");


in table xoops_tplsource, as it's present in XOOPS 2.0.9.2 .

in XOOPS 2.0.10 RC2 it corresponds to:

INSERT INTO xoops_tplfile VALUES("15""1""system""default""system_block_dummy.html""Dummy template for custom blocks or blocks without templates""1114046527""1114046527""module");


that is not present in earlier versions.
someone can shade the light on this?

DevlshOne try to update system module via admin interface.
access it from www.yoursite.com/admin.php

thanks

DevlshOne

Just popping in
Posted on: 2005/4/21 3:51
DevlshOne
DevlshOne (Show more)
Just popping in
Posts: 56
Since: 2005/4/15
#6

Re: Admin option gone from User Menu

Without a single change, it's magically come back. Something weird going on in RC2. Cookies seem to be broken, too, as many of my 20000+ users are complaining that they have to relogin every time they change pages.

One feature that really stinks is when you send a PM, the entire list of users is populated in the select box. Couldn't you just have a text entry box that does error checking instead?

Also, is there a list somewhere of all the XOOPS smartys? I'd like to try and build some custom blocks and modify existing but knowing all available smartys would be very helpful. For example, is there a smarty that shows me how many registered users are on my site, a smarty for how many hits my site has received?

Thanks!

tripmon

Module Developer
Posted on: 2005/4/21 4:02
tripmon
tripmon (Show more)
Module Developer
Posts: 462
Since: 2004/2/28
#7

Re: Admin option gone from User Menu

You can check the FAQ for smarty variables and there is a list there.

Additionally, turn on smarty debug and you can see all smarty vars for a given page.

Last... in.html files
<{$this}>
is a smarty variable passed from the calling php page as :
$xoopsTpl->assign('this'$this);

where $this is the php variable and 'this' is the smarty variable to be passed to the template

<{$smarty.const._XX_WHATEVER}> is a smarty constant defined in the in the lang folder (usually the XX prefix will describe which file _MI_XXXX for modinfo, etc.) .

Hope that helps

DevlshOne

Just popping in
Posted on: 2005/4/22 6:20
DevlshOne
DevlshOne (Show more)
Just popping in
Posts: 56
Since: 2005/4/15
#8

Re: Admin option gone from User Menu

XOOPS is beginning to disappoint me. Many of my users say that they must login over and over to stay online. I've turned on sessions to try to fix that. Would someone from the XOOPS team mind poking around my site and see if they have any issues?

Dawn of War Planet

Thanks.

Herko

XOOPS is my life!
Posted on: 2005/4/22 7:09
Herko
Herko (Show more)
XOOPS is my life!
Posts: 4238
Since: 2002/2/4 1
#9

Re: Admin option gone from User Menu

Do you use XOOPS 2.0.10 RC2 in a production environment? A quote from the release news:
Quote:
[...]And although we want to test this both from fresh installations and upgrade installations, we do NOT encourage the use of this release candidate on production sites. You've been warned!


Next, to get a better idea of your problems, can you give us the basic information?
server, version, modules installed, hacks installed, php version, MySQL version, upgrade or clean install, etc. etc.

Have you been able to reproduce the problem your users reported yourself yet? what browsers are they using? Do they have firewall software installed? Does adding your site to their 'trusted sites list' of their firewall software solve this issue?

If we're to help you solve this, we need some more information

Herko

Herko

XOOPS is my life!
Posted on: 2005/4/22 7:12
Herko
Herko (Show more)
XOOPS is my life!
Posts: 4238
Since: 2002/2/4 1
#10

Re: Admin option gone from User Menu

Taken from your site: Quote:

3) Blank pages may appear when replying to comments. I'm looking into this and will request assistance from the XOOPS team on this.

Turn on PHP debug for the errors on blank pages. That will provide a clue as to what is wrong.

Herko