1
finalfiler
XOOPS 2.0.9 Email Notification Died
  • 2004/12/30 19:57

  • finalfiler

  • Documentation Writer

  • Posts: 111

  • Since: 2002/1/19


After upgrading the email notification of new registrations no longer works, ie the new registrant never receives their responses.

I have tried PHP (mail), sendmail, SMTP settings. No good.

Any ideas, anyone?

2
Dave_L
Re: XOOPS 2.0.9 Email Notification Died
  • 2004/12/30 20:35

  • Dave_L

  • XOOPS is my life!

  • Posts: 2277

  • Since: 2003/11/7


Which version, precisely? 2.0.9, 2.0.9.1a(b,c), 2.0.9.2?

3
finalfiler
Re: XOOPS 2.0.9 Email Notification Died
  • 2004/12/30 21:06

  • finalfiler

  • Documentation Writer

  • Posts: 111

  • Since: 2002/1/19


I noticed it in the 2.0.9beta. The problem remained on 2.0.9 and now also on 2.0.9.2, which I have just installed.

AFAIK nothing has changed on our host, although a test may be to roll back to 2.0.7?


Thanks

4
finalfiler
Re: XOOPS 2.0.9 Email Notification Died
  • 2004/12/31 23:36

  • finalfiler

  • Documentation Writer

  • Posts: 111

  • Since: 2002/1/19


Before I begin I should point out that my original post about this was in reaction to a number of new registrants on my sites, who complained that they never received their notification to activate their new account.

After my original post here I dropped the server XOOPS version back to 2.0.7 and everything was OK. So, at least I knew it was (is?) a 2.0.9 issue.

I then put 2.0.9 back and tried a new registration on my home system. I experienced the described problem, ie I never received the notification. However, the registration details were committed into the XOOPS db.

OK, after some messing about and much gnashing of teeth, I established that the problem is related to users' firewalls.

In my case I use Kerio. Other (complaining) users are using Zonealarm and the WinXP_SP2 FW.

Notifications are NEVER sent if the firewall is enabled. (In my case my firewall has been configured to let thru the domains in question)

However, notifications are sent if the firewall is disabled. But that's not really desirable, is it?

The other thing that I don't understand is how come the problem has only appeared in version 2.0.9?

And finally, and most importantly, how come it's only me and my prospective users? Or are we the only ones using firewalls ?


Thanks

5
masel
Re: XOOPS 2.0.9 Email Notification Died
  • 2005/2/3 11:48

  • masel

  • Friend of XOOPS

  • Posts: 34

  • Since: 2004/10/6


In my event of the notifications sended from some modules. Other modules of the notifications do not send.

Login

Who's Online

72 user(s) are online (48 user(s) are browsing Support Forums)


Members: 0


Guests: 72


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits