1
RossC0
mainfile.php changing XOOPS Virtual Path (URL)
  • 2004/9/9 7:54

  • RossC0

  • Just popping in

  • Posts: 5

  • Since: 2004/8/23


Hi,

I've set up a site and it runs well. However, I have been asked to change the XOOPS Virtual Path (URL) for athestic reasons:

Currently, we have:

http://mysite.com

Which I want to change to:

http://www.mysite.com

When I change this URL - the site loads without errors but doesn't display anything!

What is the cause of this - I notice the XOOPS site has the full URL displayed when loading modules etc - so I presume its possible - any ideas what I need to change or do?

2
RossC0
Re: mainfile.php changing XOOPS Virtual Path (URL)
  • 2004/9/15 15:40

  • RossC0

  • Just popping in

  • Posts: 5

  • Since: 2004/8/23



Anyone got any ideas what causes the problems with changing the URL ??

3
jlm69
Re: mainfile.php changing XOOPS Virtual Path (URL)
  • 2004/9/15 15:52

  • jlm69

  • Module Developer

  • Posts: 719

  • Since: 2002/7/19


I don't understand totally.
In the mainfile.php did you change

define('XOOPS_URL', 'http://yousite.com');

to

define('XOOPS_URL', 'http://www.yousite.com');

and have this problem, or are you asking how to?

4
vagelis
Re: mainfile.php changing XOOPS Virtual Path (URL)
  • 2004/9/15 16:08

  • vagelis

  • Just popping in

  • Posts: 79

  • Since: 2004/9/5 5


Have a look in your main file if these things are correct:

// XOOPS Physical Path
// Physical path to your main XOOPS directory WITHOUT trailing slash
define('XOOPS_ROOT_PATH', '/home/httpd/vhosts/yoursite.com/httpdocs/yourxoop');

// XOOPS Virtual Path (URL)
// Virtual path to your main XOOPS directory WITHOUT trailing slash
define('XOOPS_URL', 'http://www.yoursite.com');

Quote:

RossC0 wrote:
Hi,

I've set up a site and it runs well. However, I have been asked to change the XOOPS Virtual Path (URL) for athestic reasons:

Currently, we have:

http://mysite.com

Which I want to change to:

http://www.mysite.com

When I change this URL - the site loads without errors but doesn't display anything!

What is the cause of this - I notice the XOOPS site has the full URL displayed when loading modules etc - so I presume its possible - any ideas what I need to change or do?

5
JackJ
Re: mainfile.php changing XOOPS Virtual Path (URL)
  • 2004/9/15 16:29

  • JackJ

  • Community Support Member

  • Posts: 747

  • Since: 2003/8/31


Which version of XOOPS do you have? Their was a similar problem in 2.06, but this was resolved in 2.07

See this topic

http://xoops-tips.com/modules/news/article.php?storyid=4

Or this thread:

https://xoops.org/modules/newbb/viewto ... 6&forum=7#forumpost102486

If this does not help and the site loads without displaying anything, can you access admin general preferences and switch on phpdebug and post the results?


Login

Who's Online

52 user(s) are online (25 user(s) are browsing Support Forums)


Members: 0


Guests: 52


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits