xoops forums

Forum Index


Board index » All Posts (madDan)




madDan

Not too shy to talk
Posted on: 2/4 17:34
madDan
madDan (Show more)
Not too shy to talk
Posts: 105
Since: 2010/1/6 1
#1

Re: Newposts querey in Newbb 4.33 Final

After trying a sync forums and getting a lack of access to the site completely unable to reach the db, the site recovered after 20 minutes and no longer caused the time out it is now working as it should.

So not sure if the host had problems or newbb, one thing I noticed the sync forum didn't come up with the choices page as the older version used to.

Bit odd but now the site is functioning fine.


madDan

Not too shy to talk
Posted on: 2/2 15:34
madDan
madDan (Show more)
Not too shy to talk
Posts: 105
Since: 2010/1/6 1
#2

Newposts querey in Newbb 4.33 Final

Has anyone else had issues with using

SiteURL/modules/newbb/viewpost.php?status=new View New Posts link at bottom of main forum page or from the drop down at the top timing out the site with to many requests?

Trying to work out if problem with our updated site running 2.5.9 along with newbb 4.33Final or if there is an issue at our hosts end?


madDan

Not too shy to talk
Posted on: 1/20 13:56
madDan
madDan (Show more)
Not too shy to talk
Posts: 105
Since: 2010/1/6 1
#3

Re: Time for an upgrade/update host no longer supporting older php

Cheers for the reply

I have lost a few modules but nothing the site can't live without.

Mylinks
Sections
CatAds.

I will look at Publisher which I think nicely can not only take over from Articles but also fill in the gap left by Sections.

It went better than I thought.

Nice to finally get some house keeping done.


madDan

Not too shy to talk
Posted on: 1/19 12:59
madDan
madDan (Show more)
Not too shy to talk
Posts: 105
Since: 2010/1/6 1
#4

Time for an upgrade/update host no longer supporting older php

A site I have helped keep ticking over over the years has had changed forced upon it, namely the host no longer supports older php.

The site is based on 2.5.0 yes I know bad person it didn't get the interim updates as to many modules didn't work at the time.

In the past when I updated I resorted to doing a complete fresh install of the site and its modules.

I have never successfully done an upgrade style of update is going from 2.5.0 to the latest build achievable in a single step or will I have to do several iterations?

Current issues look like

Deprecated: Non-static method XoopsCache::read() should not be called statically, assuming $this from incompatible context in D:\theroadster.net\wwwroot\trc\class\preload.php on line 85

Deprecated: Non-static method XoopsCache::getInstance() should not be called statically, assuming $this from incompatible context in D:\theroadster.net\wwwroot\trc\class\cache\xoopscache.php on line 263

Deprecated: Non-static method XoopsLoad::load() should not be called statically, assuming $this from incompatible context in D:\theroadster.net\wwwroot\trc\class\cache\file.php on line 110

Deprecated: Non-static method XoopsLoad::loadCore() should not be called statically, assuming $this from incompatible context in D:\theroadster.net\wwwroot\trc\class\xoopsload.php on line 71

Deprecated: Non-static method XoopsFile::getHandler() should not be called statically, assuming $this from incompatible context in D:\theroadster.net\wwwroot\trc\class\cache\file.php on line 111

Deprecated: Non-static method XoopsFile::load() should not be called statically, assuming $this from incompatible context in D:\theroadster.net\wwwroot\trc\class\file\xoopsfile.php on line 108

Deprecated: Non-static method XoopsLoad::load() should not be called statically, assuming $this from incompatible context in D:\theroadster.net\wwwroot\trc\class\file\file.php on line 105

Deprecated: Non-static method XoopsFile::getHandler() should not be called statically, assuming $this from incompatible context in D:\theroadster.net\wwwroot\trc\class\file\file.php on line 106

Deprecated: Non-static method XoopsFile::load() should not be called statically, assuming $this from incompatible context in D:\theroadster.net\wwwroot\trc\class\file\xoopsfile.php on line 108

Deprecated: Non-static method XoopsLists::getFileListAsArray() should not be called statically, assuming $this from incompatible context in D:\theroadster.net\wwwroot\trc\class\preload.php on line 89

Deprecated: Non-static method XoopsLists::getFileListAsArray() should not be called statically, assuming $this from incompatible context in D:\theroadster.net\wwwroot\trc\class\preload.php on line 89

Deprecated: Non-static method XoopsLists::getFileListAsArray() should not be called statically, assuming $this from incompatible context in D:\theroadster.net\wwwroot\trc\class\preload.php on line 89


At the top of each page

Current modules

System 2.1
xforms 1
MP Manager 2.75
Polls 1.3
Sections 1
Catads 1.53
newbb 4.3
user profile 1.6
news 1.65
xoopsfaq1.11
articles 1.03
mylinks 1.1

Happy Linux Framework 1.5
Waiting contents 0.95
Indexscan 2.03
Clockcalendar 2
protector3.4


Primarily the site has become little more than a forum but it does utilise articles heavily as static content

Clearly the most important functionality to keep for the site will be the forum and the articles, the owners of the site are not software technical and leave it to me several attempts to migrate the site over the years were proposed but got no where so here we are still running on this old version.


Currently I have the site closed to users

From Overview


XOOPS Version XOOPS 2.5.0
PHP Version 5.6.23
mySQL Version 5.6.19


Is it just a case of bite the bullet and do a new build or would an upgrade work given a lot of the older modules?


madDan

Not too shy to talk
Posted on: 2014/4/8 14:15
madDan
madDan (Show more)
Not too shy to talk
Posts: 105
Since: 2010/1/6 1
#5

Re: 2.5.7 Main Menu submenus

The plot thickens!

My local build doesn't suffer this just the remote build!

This should prove interesting to track down.

I am wondering if tables imports have messed up a configuration option somewhere?


madDan

Not too shy to talk
Posted on: 2014/4/8 9:51
madDan
madDan (Show more)
Not too shy to talk
Posts: 105
Since: 2010/1/6 1
#6

Re: 2.5.7 Main Menu submenus

Hmm odd? Themes made no difference? plain vanilla default theme! eek like going back in time!

I even tried differing level user logins still the same.

Looks like I'll have to do a clean install on my recently acquired QNAP NAS - although trying to get my head around the physical paths on this machine!

Maybe doing a clean build then activate a module one by one will see if a particular one effects the menu function?


madDan

Not too shy to talk
Posted on: 2014/4/6 11:47
madDan
madDan (Show more)
Not too shy to talk
Posts: 105
Since: 2010/1/6 1
#7

2.5.7 Main Menu submenus

Not sure if I have hit a problem or missed something obvious.

When using 2.5.7 the Main Menu is populated with the Modules used but when you select a module from the menu and it switches to that page the Main Menu does not show the submenu say for instance adding a news item or a calendar event, weblink etc.

I have been using 2.5.7 prior to the RC version.

I had corrected various issues to the live site but have to switch the php between the two as there are incompatibilities as the previous guy looking after it had done no updates since 2.5.0 so it's been a bit of a challenge getting new modules to replace the older ones and get them to function as there have been tables changes etc.

Has this been noticed before? No errors showing in debug - I have run over permissions again and again for all modules but as it is so common it seems something to do with System in my eyes?

Any pointers folks?


madDan

Not too shy to talk
Posted on: 2014/2/15 18:31
madDan
madDan (Show more)
Not too shy to talk
Posts: 105
Since: 2010/1/6 1
#8

Re: today and yesterday under 2.5.6

Hi I had to double up the \ for e as well


it doesn't show correctly if I put up the code here in the forum

that was in locale.php lines 27-34 in the english language folder.


Regards

Mark


madDan

Not too shy to talk
Posted on: 2014/2/14 17:54
madDan
madDan (Show more)
Not too shy to talk
Posts: 105
Since: 2010/1/6 1
#9

Re: today and yesterday under 2.5.6

Hmm the errors have gone under 2.5.7 beta 1 but the odd yesterday persists! this is on clean installs of the above

the only reference to the word yesterday is in local under language.

// !!IMPORTANT!! insert '' before any char among reserved chars: "a","A","B","c","d","D","F","g","G","h","H","i","I","j","l","L","m","M","n","O","r","s","S","t","T","U","w","W","Y","y","z","Z"    
// insert double '' before 't','r','n'
define("_TODAY","Today G:i");
define("_YESTERDAY","Yes\te\rday G:i");
define("_MONTHDAY","n/j G:i");
define("_YEARMONTHDAY","Y/n/j G:i");


More digging I gues?



madDan

Not too shy to talk
Posted on: 2014/2/14 10:59
madDan
madDan (Show more)
Not too shy to talk
Posts: 105
Since: 2010/1/6 1
#10

Re: today and yesterday under 2.5.6

Cheers mamba

The version of newbb was irmtfan

When I copy the word Ystrday it shows as Y□st□rday.

I will try the 2.5.7 over the weekend.




TopTop
(1) 2 3 4 ... 9 »