xoops forums

Forum Index


Board index » All Posts (JammerPro)




JammerPro

Just popping in
Posted on: 2018/12/13 8:06
JammerPro
JammerPro (Show more)
Just popping in
Posts: 32
Since: 2008/8/24
#1

Re: PHP 7.0 Mods and Responsive Themes -Last Question

I was able to get publisher installed, and the overlay language is now displaying... but I have no idea why it took hours to begin to display...

Now I'm not understanding how to use the the nav-menu.tpl

<div class="navbar-collapse collapse">
                <
ul class="nav navbar-nav">
                    <
li class="active"><a href="<{$xoops_url}>"><{$smarty.const.THEME_HOME}></a></li>
                    <
li><a href="javascript:;"><{$smarty.const.THEME_MODULE1}></a></li>
                    <
li class="dropdown"><a data-toggle="dropdown" class="dropdown-toggle" href="javascript:;"><{$smarty.const.THEME_MODULE2}><class="caret"></b></a>
                        <
ul class="dropdown-menu">
                            <
li><a href="#">Topic 1</a></li>
                            <
li><a href="#">Topic 2</a></li>
                            <
li><a href="#">Topic 3</a></li>
                            <
li class="dropdown-submenu">
                                <
a href="#" class="dropdown-toggle" data-toggle="dropdown">Topic 4</a>
                                <
ul class="dropdown-menu">
                                    <
li><a href="#">Sub-Topic A</a></li>
                                    <
li><a href="#">Sub-Topic B</a></li>
                                    <
li><a href="#">Sub-Topic C</a></li>
                                    <
li><a href="#">Sub-Topic D</a></li>
                                </
ul>
                            </
li>
                            <
li><a href="#">Topic 5</a></li>
                        </
ul>
                    </
li>
                    <
li><a href="<{$xoops_url}>/modules/newbb"><{$smarty.const.THEME_MODULE3}></a></li>
                    <
li><a href="<{$xoops_url}>/modules/contact"><{$smarty.const.THEME_MODULE4}></a></li>
                </
ul>


I was able to get publisher installed, in 2.5.9...

Can't call it from the menu...

I saw Rocha's note and did the following:
Go to publisher >> Preferences
Change "Articles display type" to: -WF Section Style-

How do I use the navbar for publisher?

For example. if I wanted to show the index I would simply type in the URL like this:
http://mytrademarksearch.com/modules/publisher/


What do I do with the nav-menu command above... Let;s say we use the contact choice:


How do I code this and show Docs as the heading? This doesn;t work:


<li><a href="<{$xoops_url}>/modules/publisher"><{$smarty.const.THEME_MODULE4}</a></li>


Where am I going wrong?


JammerPro

Just popping in
Posted on: 2018/12/13 3:03
JammerPro
JammerPro (Show more)
Just popping in
Posts: 32
Since: 2008/8/24
#2

Re: PHP 7.0 Mods and Responsive Themes

OK, did a fresh install of 2.5.9 with XBootstrap Theme at http://MyTrademarkSearch.com. Congrats to you. Xoops is working with the initial bare minimal install.

Can you help me a little with some initial issues putting the site back together. I will test each mod one by one and report back.

ISSUE 1 ---------------------------------------------------------------------------
First, I need to customize the XBootstrap theme which is giving me some trouble.

At themes/xbootstrap/tpl/slider.tpl starting at line 11 is the overlay text for the pictures in the slider as follows:
<div class="carousel-caption hidden-xs">
                <
h1>Lorem ipsum dolor sit amet</h1>

                <
p>Cras justo odiodapibus ac facilisis inegestas eget quamDonec id elit non mi porta gravida at eget metusNullam id dolor id
                    nibh ultricies vehicula ut id elit
.</p>

                <
p><a href="javascript:;" class="btn btn-large btn-primary"><{$smarty.const.THEME_READMORE}></a></p>
            </
div>
        </
div>
        <
div class="item"><img alt="XOOPS" src="<{$xoops_imageurl}>images/slider2.jpg">

            <
div class="carousel-caption hidden-xs">
                <
h1>Lorem ipsum dolor sit amet</h1>

                <
p>Cras justo odiodapibus ac facilisis inegestas eget quamDonec id elit non mi porta gravida at eget metusNullam id dolor id
                    nibh ultricies vehicula ut id elit
.</p>


No matter what language I insert between the H1 tags and the P tags, the overlay doesn't change!

What's up with that?

ISSUE 2 ---------------------------------------------------------------------------
Which version of publisher should I try first? Could you give me a link?

ISSUE 3 ---------------------------------------------------------------------------
Which version of myIFrame should I try first? Could you give me a link?

Let's see of I can get a totally compliant site, just using the above for now!!!

Best wishes...

Elliot


JammerPro

Just popping in
Posted on: 2018/12/12 16:47
JammerPro
JammerPro (Show more)
Just popping in
Posts: 32
Since: 2008/8/24
#3

Re: PHP 7.0 Mods and Responsive Themes

I have myiframe-master.zip (I renamed to myiframe when unzipped), also, had ams-master.zip... from GitHub. Both gave me the "white screen of death" when trying to install. AMS had a red 3 in the version number... I have publisher-master and can uninstall AMS to see if that was the issue. The version I have is called publisher-master.zip from the GitHub repository...


JammerPro

Just popping in
Posted on: 2018/12/11 23:16
JammerPro
JammerPro (Show more)
Just popping in
Posts: 32
Since: 2008/8/24
#4

Re: PHP 7.0 Mods and Responsive Themes

OK.

Here's what I've done, but still can't get the site to run under php 7.0 (Centos 6 with WHM and CPanel Multiphp manager). MySQL ver. 5.7.

I upgraded to 2.5.9, upgraded the mods as follows:

System - 2.14 | User Profile - 1.89 Final | Private Messages 1.12 Final | Protector - 3.51 Final...

However, both versions of AMS didn't install under any circumstances, whether PHP 5.6 or 7.0.

I am using the xsimpleblocks theme (nice, responsive). I do have banners turned on.

Wondering what to do next?

Any suggestions on what to use rather than AMS for an article editor? Is xsimpleblocks 7.0 friendly...

Any advice would be helpful. Would love to know that Xoops can run with just a few of the essentials in php 7.0 with MySQL 5.7.

Hope all else is well!!!

HAPPY HOLIDAYS!

JammerPro


JammerPro

Just popping in
Posted on: 2018/12/10 13:21
JammerPro
JammerPro (Show more)
Just popping in
Posts: 32
Since: 2008/8/24
#5

Re: PHP 7.0 Mods and Responsive Themes

Thanks for the quick response...

I tried the new myiframe in php7 and it doesn't work yet. That one is really important.

Is there something I can do about that?

I am busy learning the Xoops interface again and might be productive in development again LOL.

I will be adventurouse with AMS and try the responsive themes you mentioned...

Thanks again!!!!!


JammerPro

Just popping in
Posted on: 2018/12/9 23:56
JammerPro
JammerPro (Show more)
Just popping in
Posts: 32
Since: 2008/8/24
#6

PHP 7.0 Mods and Responsive Themes

Greetings all (and Mamba). It's nice to be back...

There's been quite a bit of development since I was last active and have a few catch up questons.

A few of my Xoops sites run nicely on PHP 7 with the latest MySQL... a few don't.

1) Is AMS News php 7.0 friendly (I don't think it is)? If it is comliant, where can I get an update? If not, I know News is compliant because I have it running on another Xoops site in php 7.0

2) Can anyone recommend English responsive themes that are php 7.0 complian? I've found a few Dutch and German beautiful themes, but I just need something in English that's simple for now...

Best wishes and holiday wishes to all!!!

JammerPro


JammerPro

Just popping in
Posted on: 2018/12/8 3:45
JammerPro
JammerPro (Show more)
Just popping in
Posts: 32
Since: 2008/8/24
#7

Re: Can't connect to database...

Thanks a million!


JammerPro

Just popping in
Posted on: 2018/12/7 19:25
JammerPro
JammerPro (Show more)
Just popping in
Posts: 32
Since: 2008/8/24
#8

Can't connect to database...

I moved servers, copied files over, set permissions, imported database (used a new user name and password for MySQL account.

Now, Although I filled out mainfile.php right, it doesn't ask for the db connection string so I can use the new user name and password to the MySQL data. Where do I change that to the new ones?


JammerPro

Just popping in
Posted on: 2018/12/1 7:06
JammerPro
JammerPro (Show more)
Just popping in
Posts: 32
Since: 2008/8/24
#9

Re: xoops modules in sourceforge.net

Hi Mamba, It's me...JammerPro. I have 2.5.5 installed and want to move up to 2.59... I'm thinking of getting more active again. Can I upgrade by just installing 2.5.9 over my existing 2.5.5 installs. What's the procedure.

On another note, I've been through a lot in the last few years, and I do appreciate our telecons in the past re: intellectual property law. I've had a few personal tragedies which kind of stopped me in my tracks over the last 4-5 years. But I'm ready for action again. Hope all is well with you!


JammerPro

Just popping in
Posted on: 2012/12/31 2:19
JammerPro
JammerPro (Show more)
Just popping in
Posts: 32
Since: 2008/8/24
#10

Re: eXtCal 2.37 Beta 4, will this ever get out of beta?

I can't thank you enough for getting to extcal... I wish I could help, but my programming skills are not up to par.

I would like to ask all those who benefit from Xoops and can program to help Mamba and the team working on this special mod, extcal.

Again, thanks Mamba and the Xoops team! This is above the call of duty!

Best wishes and happy new year to all...

JammerPro

P.S. Thanks to sabahan too for beta testing... I missed a lot of the bugs he reported. Incidentally, is there an easy way to allow docx to be uploaded and displayed?



TopTop
(1) 2 3 »