xoops forums

Forum Index


Board index » All Posts (Lupin)




Lupin

Just popping in
Posted on: 1/24 19:44
Lupin
Lupin (Show more)
Just popping in
Posts: 68
Since: 2007/6/1 2
#1

Re: Cannot enter in PUBLISHER module administration ... but "sometimes" ...

TYVM Mamba ,

I will report.

Pino


Lupin

Just popping in
Posted on: 1/23 16:50
Lupin
Lupin (Show more)
Just popping in
Posts: 68
Since: 2007/6/1 2
#2

Re: Cannot enter in PUBLISHER module administration ... but "sometimes" ...

Is anyone working on this problem?
Since yesterday none of the administrators has managed to enter the administration panel of the module !!!
Since we would soon need to go into production, is it possible to have a version without this "automatic data collector"?

Thanks

Pino


Lupin

Just popping in
Posted on: 1/17 15:49
Lupin
Lupin (Show more)
Just popping in
Posts: 68
Since: 2007/6/1 2
#3

Re: Cannot enter in PUBLISHER module administration ... but "sometimes" ...



Unfortunately the problem has been repeated ... the two errors (the same) have only moved to lines 127 and 128 ...

Quote:
Notice: Trying to get property 'tag_name' of non-object in file /modules/publisher/class/Common/VersionChecks.php line 127 Error: Error: Cannot use object of type stdClass as array in file /modules/publisher/class/Common/VersionChecks.php line 128


Here the mod.

(#100)
public static function checkVerModule($helper$source 'github'$default 'master')
    {
        
$moduleDirName      basename(dirname(dirname(__DIR__)));
        
$moduleDirNameUpper mb_strtoupper($moduleDirName);
        
$update             '';
        
$repository         'XoopsModules25x/' $moduleDirName;
        
//        $repository         = 'XoopsModules25x/publisher'; //for testing only
        
$ret             '';
        
$infoReleasesUrl "https://api.github.com/repos/$repository/releases";
        if (
'github' === $source) {
            if (
function_exists('curl_init') && false !== ($curlHandle curl_init())) {
                
curl_setopt($curlHandleCURLOPT_URL$infoReleasesUrl);
                
curl_setopt($curlHandleCURLOPT_RETURNTRANSFERtrue);
                
curl_setopt($curlHandleCURLOPT_SSL_VERIFYPEERfalse);
                
curl_setopt($curlHandleCURLOPT_HTTPHEADER, ["User-Agent:Publisherrn"]);
                
$curlReturn curl_exec($curlHandle);
                if (
false === $curlReturn) {
                    
trigger_error(curl_error($curlHandle));
                } elseif (
false !== strpos($curlReturn'Not Found')) {
                    
trigger_error('Repository Not Found: ' $infoReleasesUrl);
                } else {
                    
$file              json_decode($curlReturnfalse);
                      
/* nuovo if */
                    
if (json_last_error() !== JSON_ERROR_NONE) {
                        
curl_close($curlHandle);
                        return [];
                    } 
/* fine nuovo if */
                    
$latestVersionLink sprintf("https://github.com/$repository/archive/%s.zip"$file reset($file)->tag_name $default);
                    
$latestVersion     $file[0]->tag_name;
                    
$prerelease        $file[0]->prerelease;
(
#129)


Lupin

Just popping in
Posted on: 1/16 19:34
Lupin
Lupin (Show more)
Just popping in
Posts: 68
Since: 2007/6/1 2
#4

Re: Cannot enter in PUBLISHER module administration ... but "sometimes" ...

TYVM Goffy ,

tomorrow you will have the report.

Pino


Lupin

Just popping in
Posted on: 1/16 15:34
Lupin
Lupin (Show more)
Just popping in
Posts: 68
Since: 2007/6/1 2
#5

Re: JQuery problems for MAC OS ?

This is : https://xoops.org/modules/newbb/viewtopic.php?post_id=364799


Lupin

Just popping in
Posted on: 1/16 15:30
Lupin
Lupin (Show more)
Just popping in
Posts: 68
Since: 2007/6/1 2
#6

Cannot enter in PUBLISHER module administration ... but "sometimes" ...

OK, this is really strange ...

Sometimes (without any apparent connection with times or activities ...) we are unable to enter the module administration (version 1.07 final, xoops 2.5.10).
It almost always happens after inserting new categories or items ... but I'm almost sure that it is purely random.
Given the frequency of the problem I activated the debugging and here I report what I read:
1) on the web page: Error : Error: Cannot use object of type stdClass as array
2) in debugging: Errors
Notice: Trying to get property 'tag_name' of non-object in file /modules/publisher/class/Common/VersionChecks.php line 122
Error: Error: Cannot use object of type stdClass as array in file /modules/publisher/class/Common/VersionChecks.php line 123


One question: is it possible to know when the last modification was made to the module?

Thank you

Pino


Lupin

Just popping in
Posted on: 1/15 19:41
Lupin
Lupin (Show more)
Just popping in
Posts: 68
Since: 2007/6/1 2
#7

Re: JQuery problems for MAC OS ?

We believe that the problems with Jquery is just a coincidence ... instead, a problem with the publisher module doesn't seem to be a coincidence.
When I have more data I will post in the related category.

Pino


Lupin

Just popping in
Posted on: 1/10 16:22
Lupin
Lupin (Show more)
Just popping in
Posts: 68
Since: 2007/6/1 2
#8

Re: JQuery problems for MAC OS ?

TYVM geekwright !

of course I will apply the patch and I wil ask my friend to repeat tests.

I will return the report.

Pino


Lupin

Just popping in
Posted on: 1/9 20:53
Lupin
Lupin (Show more)
Just popping in
Posts: 68
Since: 2007/6/1 2
#9

JQuery problems for MAC OS ?

Xoops 2.5.11 , PHP 7.2 , MySql 5.6.44 , xswatch theme.

My co-admin works with a MAC ( MAC OS Hih Sierra 10.13.6) and I had some probs with his account , but at first I was thinking of some of his mistakes (he is not an expert on portals) ...
Yesterday, however, a constant error occurred: loading a change in the text of a publisher article, this was not loaded! It seemed impossible that this would happen because I could do it correctly (Windows 10).

I asked him to make the same changes with a tablet and a smartphone and the changes were made without problems.
Obviously I started thinking that it could be a problem with the O.S. of his MAC ... but for what reason ??? And why in loading situations?

Then I had an intuition and I made an attempt: I disabled the jGrowl redirect and asked him to repeta tests : his MAC resumed normal functionality. Do you have news of MAC problems with JQuery?

Pino


Lupin

Just popping in
Posted on: 2019/11/27 9:58
Lupin
Lupin (Show more)
Just popping in
Posts: 68
Since: 2007/6/1 2
#10

Re: Xoops Comment system

Confirmed , I have the same prob ... very strange : problem appears ONLY at firs cooment added ... then the redirect bring correctly at the image page ...

Pino



TopTop
(1) 2 3 4 ... 7 »