1
fufujuice
Drop-down Menu?
  • 2006/6/13 19:06

  • fufujuice

  • Just popping in

  • Posts: 9

  • Since: 2005/5/10


Is there a way to create a drop down menu as the main menu with Xoops? -- such as the ones that are created with Javascript.



2
fufujuice
Programs not showing up in Modules Admin - Help!
  • 2006/6/13 19:04

  • fufujuice

  • Just popping in

  • Posts: 9

  • Since: 2005/5/10


I've running 2.0.10 and have had to migrate the site a few times, but each time has been smooth. What I'm noticing, though, is that there are a lot of uninstalled modules that are uploaded but not showing up on the admin modules page. Do I need to do something to update/refresh this?

One of the modules not showing up is MyDownloads. I deleted the one online and re-uploaded it, but still nothing shows up on the admin page.

Thanks for any help!



3
fufujuice
Re: SMTP mail error - through website only
  • 2005/7/15 5:55

  • fufujuice

  • Just popping in

  • Posts: 9

  • Since: 2005/5/10


Unfortunately, I have it set for SMTP, and it's still not working. Thanks for the suggestion.



4
fufujuice
Re: SMTP mail error - through website only
  • 2005/6/30 22:54

  • fufujuice

  • Just popping in

  • Posts: 9

  • Since: 2005/5/10


Still have this issue. Can anyone help, please?



5
fufujuice
SMTP mail error - through website only
  • 2005/6/21 4:57

  • fufujuice

  • Just popping in

  • Posts: 9

  • Since: 2005/5/10


Ok, I've got a strange error. I'm trying to send an email out through the XOOPS admin panel to only those users who specified that receiving notifications from administrators would be ok. It sent the email only to the two addresses that I created for myself through my server (in other words, name@mydomain.com). For the rest of the addresses (the actual users of the site), it gave me this error message:

SMTP Error: The following recipients failed [person@email.com]. Could not send mail to "username"

So, I tried sending an email through Outlook and through the Mac Mail program (both setup with my pop account), and it works. I ended up sending individual emails this way to get it out.

What could be wrong? I sent an email via the admin panel last week, and it was fine. That time, though, I sent it to everyone and didn't specify that it limit it only to those who accepted emails.

Can anybody help me troubleshoot?

Thanks!



6
fufujuice
Re: Site Hacked - database errors
  • 2005/6/7 2:51

  • fufujuice

  • Just popping in

  • Posts: 9

  • Since: 2005/5/10


My host has replied and said that the errors I was experiencing was due to MySQL server issues. I was able to get my tables restored, and all is well with the site now. I wonder if these "server issues" is a different way of saying that the site was hacked through the host/server end.

Glad to hear, though, that it wasn't XOOPS or anything I may have done.



7
fufujuice
Re: Site Hacked - database errors
  • 2005/6/6 6:43

  • fufujuice

  • Just popping in

  • Posts: 9

  • Since: 2005/5/10


Okay. So the username and password you're referring to would have to be the cpanel username and password (since it's what you'd need to create a database). That's a little scary. Someone has way too much time on their hands.

Yes, I found it through phpmyadmin. It's strange, though, because it's not reflected (the 100 databases that were added) in the MySQL admin summary page. I only see those databases when I'm in phpmyadmin.



8
fufujuice
Re: Site Hacked - database errors
  • 2005/6/6 5:53

  • fufujuice

  • Just popping in

  • Posts: 9

  • Since: 2005/5/10


Thanks for the reply.

I have XOOPS 2.0.10 installed, the latest version of smartfaq, and the version of newbb that came with the 2.0.10 installation.

So, this may have been a security flaw on the host/server side of things? I suppose that may explain why only the database was hacked and not the files on the site itself.

I remember having to enter a username and password for the XOOPS database when installing Xoops. If it's not stored anywhere in Xoops, where is it stored?



9
fufujuice
Site Hacked - database errors
  • 2005/6/6 5:30

  • fufujuice

  • Just popping in

  • Posts: 9

  • Since: 2005/5/10


Hello,

I just installed XOOPS on my server a few weeks ago, built my site, and officially launched it a few days ago. I went out of town for the weekend and came back to a site that's apparently been hacked (today, I believe).

All the ftp files appear to be okay. The problem is with the MySQL database. The hacker messed around with 3 tables (2 tables associated with newbb and 1 table associated with smartfaq). I basically lost all my postings and forums for those two modules. Whoever did this also installed almost 100 databases that's not accounted for in my cpanel summary. All my MySQL usernames have been deleted, and I'm unable to create any new usernames (it says it's been created, but it doesn't show up in the MySQL admin afterwards).

Did I leave something open for this to happen? How can I prevent this in the future? I have an IP address associated with this and have placed it on the banned users list, but I'm not sure if this will prevent it from happening again. I'm new to this, so any help would be much appreciated.

Also, I've written to my host and am awaiting a reply.

Thanks!




TopTop



Login

Who's Online

154 user(s) are online (110 user(s) are browsing Support Forums)


Members: 0


Guests: 154


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: May 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits