xoops forums

Forum Index


Board index » All Posts (Parafal)




Parafal

Just popping in
Posted on: 2009/1/23 19:54
Parafal
Parafal (Show more)
Just popping in
Posts: 98
Since: 2003/6/7 2
#1

Re: a phishing site has been uploaded to your

Quote:

noo-b wrote:
sorry to hear this..

i think this is related

https://xoops.org/modules/news/article.php?storyid=4601

1. make sure there's an index.html file in every folder with the following code inside:
<script>history.go(-1);</script>




Hi, just a question.

I can only put this code in a empty html file? that's it? Or I need to put another code like <body></body> etc?

And I must put this index.html file in every folder, no exceptions?

Thanks
-|Parafal|-


Parafal

Just popping in
Posted on: 2008/12/18 21:45
Parafal
Parafal (Show more)
Just popping in
Posts: 98
Since: 2003/6/7 2
#2

Re: XOOPS causing performance problems!

Hi,

I put cache everywhere. Everything seams to be ok. So far, so good.

I find out that my SQL had about 23Mb in Private Messages. I deleted them, too.

I'll keep looking this weekend and if the problem starts again I'll let you know.

Thank you for the tip about cache, I never used it before!

-|Parafal|-


Parafal

Just popping in
Posted on: 2008/12/18 3:40
Parafal
Parafal (Show more)
Just popping in
Posts: 98
Since: 2003/6/7 2
#3

Re: XOOPS causing performance problems!

Here are some infos I took from the CPU log:

Quote:

CPU Exceeded Log For Wed Dec 17 16:45:49 2008

Wed Dec 17 16:45:49 2008: used 1486.00 seconds of cpu time for mysql query
Wed Dec 17 16:45:47 2008: used 0.12 seconds of cpu time for /ramdisk/bin/php5 /home/tac/public_html/mysite/html/index.php
Wed Dec 17 16:45:47 2008: used 0.15 seconds of cpu time for /ramdisk/bin/php5 /home/tac/public_html/mysite/html/modules/news/article.php
Wed Dec 17 16:45:39 2008: used 0.03 seconds of cpu time for HTTP Request: www.mysite.com : GET /favicon.ico HTTP/1.1
Wed Dec 17 16:45:00 2008: used 0.11 seconds of cpu time for /ramdisk/bin/php5 /home/tac/public_html/mysite/html/index.php


-|Parafal|-


Parafal

Just popping in
Posted on: 2008/12/18 3:33
Parafal
Parafal (Show more)
Just popping in
Posts: 98
Since: 2003/6/7 2
#4

Re: XOOPS causing performance problems!

Thanks for your reply.
I'll ask them to put my website online again to check these debugs informations.
I'm getting about 800 visits daily on my XOOPS site.

Do you think it's time to migrate for a more professional host? like dedicated one?
-|Parafal|-


Parafal

Just popping in
Posted on: 2008/12/18 2:05
Parafal
Parafal (Show more)
Just popping in
Posts: 98
Since: 2003/6/7 2
#5

XOOPS causing performance problems!

Hi,

I'm using Blueost since 2006 but in 2008 my problens started.

Today I received this message here:

Quote:
This is why the account was suspended. A performance issue: "Exdessive MySQL usage, must fix. mywebsite_website 40600.129812 85799993?


I see the CPU_log and mysql_log but I can't figure out where is the problem because I only know how to install XOOPS and that's it.

What can be the problem?

I didn't hack XOOPS and I use the last update 2.3.2b

Any idea or what can I do for someone to help me?

Should I change for a dedicated webhost?
-|Parafal|-


Parafal

Just popping in
Posted on: 2008/12/2 0:56
Parafal
Parafal (Show more)
Just popping in
Posts: 98
Since: 2003/6/7 2
#6

Re: User profile 1.51 - ERROR: Email address already registered.

and you think I shoudl stop this module? or configurate it to something else?

It's hard when we just know the basic stuff...
-|Parafal|-


Parafal

Just popping in
Posted on: 2008/12/2 0:28
Parafal
Parafal (Show more)
Just popping in
Posts: 98
Since: 2003/6/7 2
#7

Re: User profile 1.51 - ERROR: Email address already registered.

Quote:

dhsoft wrote:
Yes, this is the mysql-debug.
is this the error that occurs when the message?


Yes, this debug infos I got after I tried to update my account using the new profile account editor at the menu.
-|Parafal|-


Parafal

Just popping in
Posted on: 2008/12/2 0:27
Parafal
Parafal (Show more)
Just popping in
Posts: 98
Since: 2003/6/7 2
#8

Re: User profile 1.51 - ERROR: Email address already registered.

Quote:

ghia wrote:
Notice on the side: Do you use the SPAW editor? It was (is?) notorious for attracting hackers, because it has some security issues.


I really don't know. How can I change that? I'm not a PHP or SQL man, I only know the basic stuff how to update my xoops, install modules etc...
-|Parafal|-


Parafal

Just popping in
Posted on: 2008/12/1 17:59
Parafal
Parafal (Show more)
Just popping in
Posts: 98
Since: 2003/6/7 2
#9

Re: User profile 1.51 - ERROR: Email address already registered.

How can I get this debug from Mysql?

I tried the normal debug and I got this after I tried to chage my profile:

Quote:

Queries
SELECT * FROM xoops_config WHERE (conf_modid = '0' AND conf_catid = '1') ORDER BY conf_order ASC
SELECT sess_data, sess_ip FROM xoops_session WHERE sess_id = '13a7677bdf645626ae9483a2a5d8995e'
SELECT * FROM xoops_users WHERE uid = '2'
SELECT * FROM xoops_modules WHERE dirname = 'profile'
SELECT * FROM xoops_config WHERE (conf_modid = '59') ORDER BY conf_order ASC
SELECT * FROM xoops_config WHERE (conf_modid = '0' AND conf_catid = '2') ORDER BY conf_order ASC
SELECT COUNT(*) FROM `xoops_users` WHERE `uname` = 'nickname' AND `uid` <> 2
SELECT COUNT(*) FROM `xoops_users` WHERE `email` = 'my-email@my-website.com' AND `uid` <> 2
SELECT COUNT(*) FROM xoops_banner
SELECT * FROM xoops_banner LIMIT 0, 1
UPDATE xoops_banner SET impmade = impmade+1 WHERE bid = 20
SELECT * FROM xoops_config WHERE (conf_modid = '0' AND conf_catid = '3') ORDER BY conf_order ASC
SELECT DISTINCT gperm_itemid FROM xoops_group_permission WHERE gperm_name = 'block_read' AND gperm_modid = 1 AND gperm_groupid IN (1)
SELECT b.* FROM xoops_newblocks b, xoops_block_module_link m WHERE m.block_id=b.bid AND b.isactive=1 AND b.visible=1 AND m.module_id IN (0,59) AND b.bid IN (143,145,144,146,147,148,149,142,119,118,117,152,69,134,133,132,89,88,87,20,19,17,16,15,14,13,12,11,10,9,8,7,6,5,4,3,2,1,131,105,103,102,150,129,83,65,64,63,48,28,79,25,24,18,23,151,153,154) ORDER BY b.weight,b.bid
SELECT * FROM xoops_modules WHERE (hasmain = '1' AND isactive = '1' AND weight > '0') ORDER BY weight ASC, mid ASC
SELECT * FROM xoops_group_permission WHERE (gperm_name = 'module_read' AND gperm_modid = '1' AND (gperm_groupid = '1'))
SELECT * FROM xoops_modules WHERE dirname = 'news'
SELECT * FROM xoops_config WHERE (conf_modid = '3') ORDER BY conf_order ASC
SELECT * FROM xoops_modules WHERE dirname = 'wfchannel'
SELECT * FROM xoops_config WHERE (conf_modid = '43') ORDER BY conf_order ASC
SELECT CID, pagetitle, defaultpage FROM xoops_wfschannel WHERE defaultpage = '0' AND submenu = 1 AND (publishdate > 0 AND publishdate <= 1228154168) AND (expiredate = 0 OR expiredate > 1228154168) ORDER BY weight
SELECT submenuitem, titlelink FROM xoops_wfslinktous
SELECT submenuitem , titlerefer FROM xoops_wfsrefer
SELECT * FROM xoops_modules WHERE dirname = 'spaw'
SELECT * FROM xoops_groups
SELECT * FROM xoops_modules WHERE dirname = 'pm'
SELECT COUNT(*) FROM `xoops_priv_msgs` WHERE (read_msg = '0' AND to_userid = '2')
SELECT COUNT(*) FROM xoops_online WHERE online_uid=2
UPDATE xoops_online SET online_updated=1228154168, online_module = 59 WHERE online_uid = 2
SELECT * FROM xoops_online
SELECT COUNT(*) FROM xoops_online WHERE online_module = '59'
SELECT * FROM xoops_profile_profile WHERE profile_id = '2'
SELECT * FROM `xoops_profile_field` WHERE field_id != '0' ORDER BY field_weight ASC
SELECT * FROM xoops_group_permission WHERE (gperm_name = 'profile_edit' AND gperm_modid = '59' AND (gperm_groupid = '1'))
SELECT * FROM `xoops_profile_category` ORDER BY `cat_id` DESC
SELECT * FROM xoops_smiles
SELECT * FROM xoops_groups WHERE groupid != '3'
Total: 37 queries


This helps?
-|Parafal|-


Parafal

Just popping in
Posted on: 2008/12/1 15:26
Parafal
Parafal (Show more)
Just popping in
Posts: 98
Since: 2003/6/7 2
#10

Re: User profile 1.51 - ERROR: Email address already registered.

Quote:

dhsoft wrote:
Sorry, I meant the profiles module disable times and then test it.


When I update the profile using the "ADMIN/SYSTEM/EDIT USER" I can change it, but not using the USER PROFILE module.

Do you know what is happening?
-|Parafal|-



TopTop
(1) 2 3 4 ... 9 »