Mamba Mamba
  • Moderator
  • Moderator
  • Joined: 2004/4/23 14:58
  • From Ohio, USA
  • Group: Webmaster Registered Users Designer Group Super Moderator
  • Posts: 10293
  • Posted on: 1/6 12:55
About Us 1.04 Beta 1 released for testing #1
Resized Image

The "About" module is for adding "About Us" section to your Website. It allows adding a multi-page section, as well as external links.

It was originally developed by Susheng Yang (ezsky) and Mengjue Shao (magic.shao).

It is a simple module, but it could be quite useful, since it is very easy to use.

REQUIREMENTS:

- PHP 5.5+ (the new official minimum PHP version for XOOPS. It might work on PHP 5.3.7+, but we don't test anymore on it)

- XOOPS 2.5.8 (if you don't have it, you should start testing your modules on in TODAY)


DOWNLOAD: About repository on GitHub


CONTRIBUTING: please fork About module on GitHub and submit your improvements there


BUGS/ISSUES:GitHub Issues


Resized Image

TUTORIAL: Available on GitBooks. It is in the early stages, and we need your help to make useful

To help, you can fork the Tutorial from GitHub and provide you submissions there

To check out other XOOPS Tutorials, please visit XOOPS section on GitBooks

Happy Xoopsing and May the Source be with You!
Please support XOOPS & DONATE
Use 2.5.8 | Debug | Requests | Bugs
Zap_English Zap_English
  • Not too shy to talk
  • Not too shy to talk
  • Joined: 5/24 14:06
  • From Ukraine
  • Group: Registered Users
  • Posts: 128
  • Posted on: 5/30 15:44
Re: About Us 1.04 Beta 1 released for testing #2
Is there a version of this that will run on 2.5.7.2?

I know this post says it will, but when you install it, it says it requires 2.5.8
zyspec zyspec
  • Module Developer
  • Module Developer
  • Joined: 2004/9/21 9:28
  • From USA
  • Group: Registered Users
  • Posts: 980
  • Posted on: 5/30 16:46
Re: About Us 1.04 Beta 1 released for testing #3
Zap_English,

Here's a duplicate of the comment I posted in reply to to your comment on the About module news release....
Quote:

I looked over the latest changes on github and although the module now claims it requires 2.5.8 there were no changes made that actually require 2.5.8. At this point (ver 1.04 RC 1) will run on 2.5.7.2 as well.

Just be forewarned that future revisions of the About module may not work on 2.5.7.x - but for now all that will happen is that the module "screams at you" that it needs 2.5.8.
Mamba Mamba
  • Moderator
  • Moderator
  • Joined: 2004/4/23 14:58
  • From Ohio, USA
  • Group: Webmaster Registered Users Designer Group Super Moderator
  • Posts: 10293
  • Posted on: 5/30 20:17
Re: About Us 1.04 Beta 1 released for testing #4
Quote:
I looked over the latest changes on github and although the module now claims it requires 2.5.8 there were no changes made that actually require 2.5.8. At this point (ver 1.04 RC 1) will run on 2.5.7.2 as well.

All the modules that I am working on, will "scream" to use XOOPS 2.5.8 and PHP 5.5+

We need to test all of them on XOOPS 2.5.8 to make sure that both the modules and XOOPS 2.5.8 work well together on the current PHP versions. Due to very limited time, I won't be able to test any modules on older versions of XOOPS. However, if somebody wants to do it, and fix any potential issues related to an older version, then please free to do it.

In the future, we'll add a checker at each module installation, that will fail if we try to install a "2.5.8" module on an older version of XOOPS. This way we'll avoid user confusion and disappointments.

IMHO we need to focus our very limited resources on making sure that XOOPS 2.5.8, which runs on the latest version of PHP (i.e. PHP 7) is as solid as possible, and we have all key modules running on it without any problems ASAP.
Please support XOOPS & DONATE
Use 2.5.8 | Debug | Requests | Bugs
How to effectively post a question in the Xoops forums? - Read here...
Design by: XOOPS UI/UX Team