smartfaq
SmartFAQ is developed by The SmartFactory (http://www.smartfactory.ca), a division of InBox Solutions (http://www.inboxsolutions.net)

Can I use phpbb or IPB forums with xoops?
Requested and Answered by Carnuke on 2004/12/25 15:14:05 (23300 reads)
http://bbpixel.com is a site dedicated to integrating these 2 forum scripts within xoops. Installing them does however, require changes to core files, so updating your xoops version core files may overwrite any changes.

There are also import data scripts for bringing existing users/posts etc.

Recently there has been a release of a modularised phpbb forum for xoops that does not change core files. Project is HERE

This is a phpbb module (using bbpixel's work as a base), properly using Xoops Groups (currently not allowed in bbpixel's port), along with bug-fixes, code cleanup, phpbb hacks, etc. The project will attempt to remove all xoops core hacks, or at least provide a module that functions *without* the hacks, and have the hacks installable separately. This is a branch from future phpbb/bbpixel releases.


The comments are owned by the author. We aren't responsible for their content.
  • Quite a regular

 Reminder on selecting module with core hack

I would suggest we give a 'stronger' reminder/note that if we choose to use modules with a core hack, it will cause forward compatibility issue with future XOOPS versions (and potentially security issue, due to incapability to keep upgrading the xoops/phpbb to the latest version). We will be really rely on bbpixel to provide the upgrade.

[ Just as a background, please don't take my message below negatively or as an attempt to discredit someone else. I just hope the leason I learnt can be an input for the other new Xoopers.

I picked BBPixel’s X-PHPBB as my forum module for my XOOPS website (due to the reason I have ever had an experience with the phpBB previously). What I didn’t aware of is that it changes some of the Xoops’ core files. Being a non programmer, I experienced difficulties in upgrading the XOOPS and the PhpBB then.

Until now I can’t upgrade my XOOPS to the newest version and can’t also upgrade the phpbb to the newest version which is actually really required due to some security holes exist in the current version. It is not BBPixel’s fault, I can understand that the developer’s of X-PHPBB must be busy and have other priority (unfortunately X-PHPBB does not have enough communities which can share the required changes need to be applied to the module; different with X-IPB, I saw that it’s been updated regularly by m0nty , even the latest XOOPS 2.0.9 version ).

Please just use core hacks and modules with core hacks ONLY IF you are an experienced php programmer/Xoops programmer. This kind of hacks can cause forward compatibility issue with future XOOPS versions. ]

 
  • XOOPS is my life!

 Re: Reminder on selecting module with core hack

Thanks for reminding me of this.

I'll recommend adding "no core hacks" as one of the mandatory requirements for the new module certification standard that the XOOPS QA team is working on. That means that a module that includes core hacks would receive a lower certification label, which would serve as a caveat to potential users of that module.

 
  • Home away from home

 Re: Reminder on selecting module with core hack

Thanks for raising this point. Please see this new FAQ to clarify this. Ammend as required please.