XOOPS: XOOPS goes exclusively PHP5

Posted by: Mambaon 2009/4/29 10:10:00 10731 reads Resized Image

As indicated year ago (read here), the XOOPS 2.3.x version is the last one version that is supported on PHP4.

Since PHP4 has been discontinued as of August 8th, 2008, and majority of Host providers offer nowadays PHP5, it's time for XOOPS to discontinue support for PHP4 as well.

This will help us to focus our resources on PHP5 development and to take full advantage of PHP5 features, which will benefit our users and developers. It will also help us to shorten our testing cycle.

Therefore, our upcoming XOOPS 2.3.4 will be the last release compatible with PHP4. However, we will make sure that it is a solid release, that will serve our users for many months, if not years, to come, if they need to keep it on PHP4.

XOOPS 2.4 that will follow, will be only tested and certified exclusively on PHP 5.2 and up.

We would also like to encourage everybody to start switching to MySQL 5.x, as pretty soon this will be also our standard supported configuration: PHP5/MySQL5