xoops forums

thgirblam

Just popping in
Posted on: 2019/11/30 2:41
thgirblam
thgirblam (Show more)
Just popping in
Posts: 32
Since: 2004/8/14
#1

XOOPS Version for Godaddy Installation

I have been unsuccessful installing XOOPS 2.5.10 on one of my Godaddy sites. I suspect it is because of the PHP version.

Godaddy
PHP Version: 5
MySQL Version: 5.5.51-38.1-log
Operating System: LINUX

What version of XOOPS would be most compatible with my Godaddy setup?

Thanks,

Mark

Mamba

Moderator
Posted on: 2019/11/30 6:10
Mamba
Mamba (Show more)
Moderator
Posts: 10812
Since: 2004/4/23
#2

Re: XOOPS Version for Godaddy Installation

You should update your PHP version to 7.0+, as the older versions are not maintained anymore, and you'll open yourself to hacking.

Our current version 2.5.10 should work on PHP 5.3+, but again, this is not recommended.

It's better to be safe than sorry!!!
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

thgirblam

Just popping in
Posted on: 2019/11/30 23:09
thgirblam
thgirblam (Show more)
Just popping in
Posts: 32
Since: 2004/8/14
#3

Re: XOOPS Version for Godaddy Installation

It is a Godaddy hosted site and I am stuck with their version of PHP.

I've had a couple other Xoops sites on this server before but that was back at Xoops 1.7 and prior.

I've been trying to troubleshoot it, I have set the site up to the instructions - best I can tell. I have adjusted all the CHMods I can find instructions to modify but I don't even get the install wizard. I only get a FATAL ERROR when I attempt to initiate the install wizard:

Fatal error: Class 'XoopsPreload' not found in /home/content/92/13963592/html/_SiteFolder_/index.php on line 32

Mark

Mamba

Moderator
Posted on: 2019/12/1 0:12
Mamba
Mamba (Show more)
Moderator
Posts: 10812
Since: 2004/4/23
#4

Re: XOOPS Version for Godaddy Installation

GoDaddy has a PHP 7, but it seems like they might want you to move to another contract.

The minimum PHP version for XOOPS 2.5.10 is PHP 5.3

You might try to update your current installation to PHP 5.6, or move to another hosting company and have PHP 7.

Also, check your PM messages
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs