xoops forums

GlemBell

Just popping in
Posted on: 11/14 22:01
GlemBell
GlemBell (Show more)
Just popping in
Posts: 5
Since: 11/5 11:16
#1

Pedigree module problems adding field/dog/owner

Good evening.

Can you suggest me please from where and which type of pedigree module to download? I downloaded 3 different XOOPS pedigre module from different website. 1 of them adding dogs and owners perfectly, list them perfectly and allows search but I cant add custom field (dysplasia, colors, deceased etc..) because when I open the Webmaster tool --- create user fields nothing happenes just a blank page opens (totally white - not text). I find other module where I can add perfectly custom fields but nothing is saved. I can add dog, but its not listed, I can add owner also not listed (in module homepage and adminsitration menu either).
The last module is way bigger in kb than other 2 but works same as first type, owners/dogs saved but cant add custom field.
Both of the modules write the newest 1.31 Alpha 6 version, updated. Thank you!

Mamba

Moderator
Posted on: 11/18 0:23
Mamba
Mamba (Show more)
Moderator
Posts: 10631
Since: 2004/4/23
#2

Re: Pedigree module problems adding field/dog/owner

Which one module does what?

It would be helpful to know the location you've downloaded the module from, and what is not working there...
Support XOOPS => DONATE
Use 2.5.9 | Docs | Modules | Bugs

GlemBell

Just popping in
Posted on: 11/18 9:52
GlemBell
GlemBell (Show more)
Just popping in
Posts: 5
Since: 11/5 11:16
#3

Re: Pedigree module problems adding field/dog/owner

On the official XOOPS website (this page) I did not find in modules the pedigree module. So I searched the internet and downloaded the following:

https://github.com/XoopsModules25x/pedigree - This module writes 1.31 Alpha 6. This module for me not letting add dog/owner. The adding page opens I fill every info, when it changes to the database after saving it writes out 0 dog is in the database. Same with owner, after adding it there is no owner in the database. Custom field maker in the webmaster tools works, but after saving it doesnt show either in tools and in adding dog (so to fill out datas like color..)

Here seen on screenshot: Database error


https://sourceforge.net/projects/xoops ... pository/XOOPS2/Pedigree/ - 1.31 Alpha 1 I tried this too, in hope that maybe an older version will work at me, here it writes out the following error: Call to undefined function mysql_num_fields()


https://xoops.sk/modules/wfdownloads/visit.php - Same as Github version.

Unfortunately I can not find the website of the last pedigree module. 1.31 Alpha 2 I think was. There dogs/ownes adds and show in database, but custom field is a blank page only.

Mamba

Moderator
Posted on: 11/18 19:12
Mamba
Mamba (Show more)
Moderator
Posts: 10631
Since: 2004/4/23
#4

Re: Pedigree module problems adding field/dog/owner

Can you try the 1.32 Alpha 1 from here:

https://github.com/mambax7/pedigree

and let me know if this is better.

I did some more changes, but they are not ready yet to upload, but hopefully in the next 2-4 weeks.
Support XOOPS => DONATE
Use 2.5.9 | Docs | Modules | Bugs

GlemBell

Just popping in
Posted on: 11/19 8:32
GlemBell
GlemBell (Show more)
Just popping in
Posts: 5
Since: 11/5 11:16
#5

Re: Pedigree module problems adding field/dog/owner

I tried it out.

Adding dogs is working.
Checking dog info works.
Adding owner is working.

Adding litter does not work. I can fill infos inside, choose father and mother out but when I save the litter than the dogs does not shows in pedigree database.

Checking owner details does not work (blank page open... )see here:
http://www.kepfeltoltes.eu/view.php?f ... me=536Screenshot_176_.png

Adding custom field still does not work. Blank page opens:
http://www.kepfeltoltes.eu/view.php?f ... me=194Screenshot_177_.png

Mamba

Moderator
Posted on: 11/19 16:22
Mamba
Mamba (Show more)
Moderator
Posts: 10631
Since: 2004/4/23
#6

Re: Pedigree module problems adding field/dog/owner

Thanks, that's helpful.

I'll look into it in the next few weeks...
Support XOOPS => DONATE
Use 2.5.9 | Docs | Modules | Bugs