1
ullone
Error during the installation initial setting
  • 2017/12/27 7:54

  • ullone

  • Friend of XOOPS

  • Posts: 49

  • Since: 2003/4/24


I have tried to install xoops-259 in localhost with easyPHP in window 7. I have no error in the creation of database and tables using the user root with all privileges in the database xoops. But during the installation of the datas of the administrator of the site in the initial setting i have the error :
Fatal Error Maximum execution time of 30 seconds exceeded file: J:\EasyPHP-12.1\www\xoops-2.5.9\htdocs\class\database\mysqldatabase.php : 66
Can someone help me ?

2
Mamba
Re: Error during the installation initial setting
  • 2017/12/27 12:38

  • Mamba

  • Moderator

  • Posts: 11245

  • Since: 2004/4/23


What version of PHP do you have?

Since this is your local PC, why don't you increase the "Maximum execution time" in your INI file?
On my test PC I have:
max_execution_time 600


But you should check the PHP error log to see if there are any errors that would indicated what is wrong there....
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

3
geekwright
Re: Error during the installation initial setting

Try changing the MySQL host to "127.0.0.1" instead of "localhost".

By default the installer will use "localhost" as the MySQL host. In some stacks on some versions of Windows that will cause issues. The underlying issue is each connection experiencing a time out waiting on a response from MySQL due to IPV6 vs. IPV4 versions of localhost.

There is a longer discussion of this here: https://xoops.org/modules/news/article.php?storyid=6758

Login

Username:
Password:

Lost Password? Register now!

Who's Online

69 user(s) are online (43 user(s) are browsing Support Forums)


Members: 0


Guests: 69


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: May 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits