xoops forums

jlm69

Module Developer
Posted on: 2015/7/16 11:09
jlm69
jlm69 (Show more)
Module Developer
Posts: 719
Since: 2002/7/19
#1

Installing 2.6.0 get fatal error

first problem is weird,

My cpanel shows I have php - 5.4.41 but all my Xoops running on this server say
php 5.3.26, which shows a red X for php in my installation of 2.6.0. If I just continue, when I get to

mysite/install/page_configsite.php

I get this error

Fatal error: Interface 'SessionHandlerInterface' not found in /home/jlmzone/260/xoops_lib/Xoops/Core/Session/Handler.php on line 27

What is the min php for 2.6.0?

In all the modules in 2.6.0 it says

$modversion['min_php'] = '5.3.7';

but I get a red X for min php when installing saying I have 5.3.26
which is higher than 5.3.7 and again my cpanel says php - 5.4.41

Anyone have any ideas?

Thanks,

John



Dante7237

Friend of XOOPS
Posted on: 2015/7/16 14:25
Dante7237
Dante7237 (Show more)
Friend of XOOPS
Posts: 288
Since: 2008/5/28
#2

Re: Installing 2.6.0 get fatal error

Have you double checked the "handler" in .htaccess?

(AddHandler application/x-httpd-php54 .php54 .php)
The more I know, the more I know that I really didn't wanna know.

jlm69

Module Developer
Posted on: 2015/7/16 19:04
jlm69
jlm69 (Show more)
Module Developer
Posts: 719
Since: 2002/7/19
#3

Re: Installing 2.6.0 get fatal error

Dante,
Thanks, this is what I had in .htaccess

# Custom Legacy PHP 5.3 handler placed by host
AddType application/x-httpd-php53 .php5 .php4 .php .php3 .php2 .phtml
suPHP_ConfigPath /usr/local/lib/php53.ini
# End Custom Legacy PHP 5.3 handler placed by host


I just needed to delete those lines.

But then I got this error on the module install page

Parse error: syntax error, unexpected 'return' (T_RETURN) in /home/xxxx/public_html/xxx/class/xoopseditor/tinymce4/editor_registry.php on line 1

I just deleted tinymce4 and everything worked great.

Thanks for showing me where to look.

John