xoops forums

mandrake

Just popping in
Posted on: 2014/6/12 13:30
mandrake
mandrake (Show more)
Just popping in
Posts: 16
Since: 2014/5/26
#1

xoopstube url - w3c validation problem with &

Hello

I have a problem for validated my website with w3c, when i scan my page, i have a lot off error of this:

Firstly, if title truncate is at the place of an accentuated letters i have this message:

Quote:
Sorry, I am unable to validate this document because on line 355 it contained one or more bytes that I cannot interpret as utf-8 (in other words, the bytes found are not valid values in the specified Character Encoding). Please check both the content of the file and the character encoding indication.
The error was: utf8 "\xC3" does not map to Unicode


i have searching where the bad caracters was and it's in bloc title truncate.I have tested to replace strlen and substr in bloc php files by mb_strlen and mb_substr but without succes.

Have you an idea for fix it - i have html5 utf8 doctype.

In second and the most bigger problem i have 64 error when my test succes(if aleatory bloc don't contain vidéo title with accentuated letters in truncate place).

W3c don't accept the & in url of xoopstube page :

url problem is here: /singlevideo.php?cid=1&lid=178

& between cid and lid

Line 180Column 68: & did not start a character reference. (& probably should have been escaped as &.)


I just want to know where i need to replace & by & amp; for w3c validate my page?

Or perrhaps is external problem, i don't know.

Thank in advance for your help

mandrake

Just popping in
Posted on: 2014/6/13 4:11
mandrake
mandrake (Show more)
Just popping in
Posts: 16
Since: 2014/5/26
#2

Re: xoopstube url - w3c validation problem with &

No answer?

This is what append in title truncate: Princesse mononok�...

Bleekk

Theme Designer
Posted on: 2014/6/13 9:07
Bleekk
Bleekk (Show more)
Theme Designer
Posts: 934
Since: 2002/12/14
#3

Re: xoopstube url - w3c validation problem with &

how about using your editor search function to search for & in the xoopstube module?

mandrake

Just popping in
Posted on: 2014/6/15 15:09
mandrake
mandrake (Show more)
Just popping in
Posts: 16
Since: 2014/5/26
#4

Re: xoopstube url - w3c validation problem with &

I have find where the problem is, it's in block h templates, url & is not encoded.