1
mandrake
xoopstube url - w3c validation problem with &
  • 2014/6/12 13:30

  • mandrake

  • Just popping in

  • Posts: 16

  • Since: 2014/5/26


Hello

I have a problem for validated my website with w3c, when i scan my page, i have a lot off error of this:

Firstly, if title truncate is at the place of an accentuated letters i have this message:

Quote:
Sorry, I am unable to validate this document because on line 355 it contained one or more bytes that I cannot interpret as utf-8 (in other words, the bytes found are not valid values in the specified Character Encoding). Please check both the content of the file and the character encoding indication.
The error was: utf8 "\xC3" does not map to Unicode


i have searching where the bad caracters was and it's in bloc title truncate.I have tested to replace strlen and substr in bloc php files by mb_strlen and mb_substr but without succes.

Have you an idea for fix it - i have html5 utf8 doctype.

In second and the most bigger problem i have 64 error when my test succes(if aleatory bloc don't contain vidéo title with accentuated letters in truncate place).

W3c don't accept the & in url of xoopstube page :

url problem is here: /singlevideo.php?cid=1&lid=178

& between cid and lid

Line 180Column 68: & did not start a character reference. (& probably should have been escaped as &.)


I just want to know where i need to replace & by & amp; for w3c validate my page?

Or perrhaps is external problem, i don't know.

Thank in advance for your help

2
mandrake
Re: xoopstube url - w3c validation problem with &
  • 2014/6/13 4:11

  • mandrake

  • Just popping in

  • Posts: 16

  • Since: 2014/5/26


No answer?

This is what append in title truncate: Princesse mononok�...


3
Bleekk
Re: xoopstube url - w3c validation problem with &
  • 2014/6/13 9:07

  • Bleekk

  • Theme Designer

  • Posts: 937

  • Since: 2002/12/14


how about using your editor search function to search for & in the xoopstube module?

4
mandrake
Re: xoopstube url - w3c validation problem with &
  • 2014/6/15 15:09

  • mandrake

  • Just popping in

  • Posts: 16

  • Since: 2014/5/26


I have find where the problem is, it's in block h templates, url & is not encoded.

Login

Username:
Password:

Lost Password? Register now!

Who's Online

76 user(s) are online (55 user(s) are browsing Support Forums)


Members: 0


Guests: 76


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Dec 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits