xoops forums

naaon

Just popping in
Posted on: 2011/8/25 2:41
naaon
naaon (Show more)
Just popping in
Posts: 2
Since: 2011/8/25
#1

d3forum-0.86-pre and d3diary on XOOPS2.5.1a

Hi everyone,

This is naaon from Japanese commnunity.
So my English is not good that please be patient for a moment.

** GIJOE's forum module "d3forum" is recently started maintainance and upgraded to adopt to php over 5.3 and mySQL 5.5, release version 0.86-pre, I tested on XOOPS 2.5.1a and it worked.

This version of d3forum contains some new functions as follows:

1. comment integration with permission synclonization to the integrated module's each entry.
It means, in case the blog entry is not allowed to be shown for GUEST, no comment is listed on all d3forums list pages, blocks and xoops search results for GUEST.

2. "uname" or "nickname" display is selectable on the admin's module prefference.
3. Changed CSS to implements theme colors.
4. Page divides for many comments on listpost page.
5. Added tree information also to listpost page and comment integrated module's entry page

** And, I also released and tested blog module "d3diary" on XOOPS 2.5.1a and it worked ,too. -->d3diary-0.22 Download

** Requirements
Both module requires following condition.

6. Altsys-0.71d (domifara version) is necessary. Please download from here and install it before installing above modules.

7. Packaged smarty plugin "xoopsdhtmltarea" cannot work properly on XOOPS2.5.x. please see this page (sorry in Japanese) and make as plugin file "function.xoopsdhtmltarea.php" in the directory (htdocs)/class/smarty/xoops_plugins/ .

** Language files
All the Japanese language files must be renamed from "ja_utf8" to "japanese".

D3forum's language files were not tested for many language or may be broken. Their new constants added at this release may be only in English or not added.

D3diary has only Japanese, English and Portguage files.

** Screen Shot
Working screen shots is on my blog here (sorry also in Japanese).

Cesagonchu

Moderator
Posted on: 2011/8/25 20:37
Cesagonchu
Cesagonchu (Show more)
Moderator
Posts: 864
Since: 2010/2/1 2
#2

Re: d3forum-0.86-pre and d3diary on XOOPS2.5.1a

Great news, thank you :)

btesec

Friend of XOOPS
Posted on: 2011/8/26 17:58
btesec
btesec (Show more)
Friend of XOOPS
Posts: 623
Since: 2007/2/20
#3

Re: d3forum-0.86-pre and d3diary on XOOPS2.5.1a

I'd prefer the english versions for testing.
Thanks.

kakos

Friend of XOOPS
Posted on: 2011/9/8 9:09
kakos
kakos (Show more)
Friend of XOOPS
Posts: 73
Since: 2002/6/6 2
#4

Re: d3forum-0.86-pre and d3diary on XOOPS2.5.1a

I don't know why GIJOE stopped updating his modules. Have someone correct the Pico module to be compatible with recent versions of PHP and xoops? It is one of the most powerful modules for content I've ever see for xoops family.

naaon

Just popping in
Posted on: 2011/9/12 4:27
naaon
naaon (Show more)
Just popping in
Posts: 2
Since: 2011/8/25
#5

Re: d3forum-0.86-pre and d3diary on XOOPS2.5.1a

Since GIJOE has stopped his development and maintenance last year, and still stopping right now. We have started to maintain some his modules.

The pico_r project has been stared, too. It's ready for php5.3 and mySQL5.5.
You can download GNU tarball from the page below but it's not checked on XOOPS 2.5 or recent core except for XCL2.1 or 2.2.
http://sourceforge.jp/projects/pico/svn/view/pico/?root=pico

Mamba

Moderator
Posted on: 2011/9/12 5:04
Mamba
Mamba (Show more)
Moderator
Posts: 10797
Since: 2004/4/23
#6

Re: d3forum-0.86-pre and d3diary on XOOPS2.5.1a

Thank you Naaon for the update, and thanks to the XOOPS Japan community for taking on the task of further development of these modules!

Let's work together on how can we maintain and improve module compatibility between xCube and XOOPS

I just tested Pico in with the upcoming XOOPS 2.5.2, and it seems to work fine, with two issue:

1) during installation:

Quote:
Unknown: Assigning the return value of new by reference is deprecated in file /class/smarty/plugins/function.d3comment.php line 42

2) When submitting content, I got following error:

Quote:
Fatal error: Class 'XoopsFormDhtmlTextArea' not found in S:\wamp64\www\xtest252xmf1\class\smarty\plugins\function.xoopsdhtmltarea.php on line 34


So it seems like this check:

if (!class_exists('xoopsformelement')) {
        require_once 
XOOPS_ROOT_PATH."/class/xoopsformloader.php";
    }

doesn't work with XOOPS 2.5.x, because the "xoopsformelement" is there, and "xoopsformloader.php" will never be loaded.

If don't do the check 'if (!class_exists('xoopsformelement'))' and place the line

require_once XOOPS_ROOT_PATH."/class/xoopsformloader.php";

directly, then Submit works without any problems.

BTW: I used the older Altsys 0.71 from GIJOE, and not the one from domifara that you recommended in your previous post. I might check it later...

[EDIT] I just tested with the "domifara" version of Altsys, and Pico is working OK.

Once again, thank you for keeping the modules updated
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs